cancel
Showing results for 
Search instead for 
Did you mean: 

Controllers Keep Losing Tracking - Has been going on since I bought it almost a year ago

imraxus
Explorer

I own a Quest 2 and I've been satisfied with the product. It still works to this day. I bought a Quest Pro because I wanted to have a better VR experience, I was willing to drop $$$ for this thing. 

Unfortunately, day 1 of getting it, I experienced problems. I'm not a fussy person, I used the knowledge database to solve those problems. I was expecting the quest 2 problem of controllers sliding wherever and hitting the guardian despite me being in the middle to be solved. It's a minor inconvenience.

However, 3 months into owning the Quest Pro, the controllers would lose tracking. The hands would just hang in the air, or disappear entirely. And yet, I can still press the buttons. 

I've tried to contact customer support this time, and they've been very unhelpful. The best solution they got was to send me refurbished controllers. And I've seen horror stories of people getting poor refurbished units back. 

It's almost a year now and the problem still exists. Will you fricking solve this thing already? Or at least give better controllers and not refurbished ones?

This experience has definitely made me think twice in getting the Quest 3 and will likely not purchase future Meta VR products. 

0 REPLIES 0
Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?