cancel
Showing results for 
Search instead for 
Did you mean: 

Crackling audio in Rift S

StefanosG
Explorer

I updated my mobo: MSI tomahawk B550

and my CPU: 5600x

 

after that, the audio sounds like crackling/popping. Everything else works fine.

 

Any ideas?

 

Ive changed all usb seats, reinstalled oculus etc. nothing works

1 ACCEPTED SOLUTION

Accepted Solutions

Oculus ended up replacing my headset and it worked, after spending countless hours on various solutions. 

View solution in original post

32 REPLIES 32

MetaQuestSupport
Community Manager
Community Manager

Hi there, 

 

 We would love to help you get your audio back, please help us to clarify this matter, by letting us know if you are hearing any sound at all or possibly just the crackling in the headset?

 

If you are no longer hearing sound please follow these steps: 

 

  • Check to make sure your Rift on-ear headphones are selected. To select your Rift on-ear headphones:
    1. Open the Oculus app on your computer.
    2. Select Devices in the left menu and then click Rift.
    3. Below Audio Output in VR, check to make sure Rift headphones are selected.
  • Check to make sure that the audio for your computer is turned up
  • Check to see if there are updates for your Rift. To check updates for your Rift:
    1. Open the Oculus app on your computer.
    2. Select Library in the left menu and then click Updates to check for updates.

Please respond back here and let us know how this has helped you.

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

The issue I am having is audio popping/crackling. I have sound, but there are lots of "pops" and "crackles" in there which makes the headset audio unusable. It all started after I upgraded my PC to a MSI tomahawk B550 along with a Ryzen 5 5600x.
I have updated to the latest BIOS and Chipset Drivers. My guess is that it has to do with the USB connectivity. In the Oculus App, I get the "No headset Audio" even If I have. 
 
I have tried to reseat the display port cable, the audio speakers cable and their counterparts at the PC case. I have also tried all the USB ports avaiable. I have also tried the headset with all other USBs removed. 
 
I have also lowered the volume of the Rift S headphones which improves the audio a little bit, but  nothing noticeable.

Hey again, 

 

We are going to keep doing our best to help out. For now, we'd like to as a few more questions.

  • Are you using our build in speakers or do you have your own audio headset setup?
  • Have you attempted using a different set of headphones with the Rift S? If so, tell us if those issues lessen or improve the popping effect.
  • Are all relevant drivers up to date?
  • Is the headset up to date?

Yes these are some pretty basic questions, but having a solid base to work with is paramount to moving forward with a clear idea in mind.

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Thank you for your time.

 

I am using the buit-in speakers. Not externals.

 

I have tried external headphones through the 3.5mm jack (located on the rift s itself) and the crackles/pops remain. Not worse/not better.

 

I did a fresh install of Windows 10, updated to the latest version, and I use the oculus app too, updated. I have also tried the beta version- with no luck.

 

I am not sure i understand what headset up to date means. I use the oculus App for any updates.

 

What i found intersting is that occasionally i get an oculus app red error message: headphones have no audio. If I reseat the usb drive, the message will disappear.

 

I have updated the bios of my motherboard, and I have tried other USB seats. If I use the 2.0, the audio gets much worse.

 

 

Hey there StefanosG, thanks for providing that information! I see you mentioned you use the oculus app for any updates. Please make sure the relevant audio drivers for your motherboard are installed and updated from the manufacturer's website. Also, be sure all oculus drivers are up to date and you aren't using any third party audio programs like VoiceMeeter or an audio mixer, as these are known to cause audio popping issues. Cheers!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

As my main audio driver is my Sound Blaster Z (I do not have Realtek Audio Installed), installed with the latest drivers. My guess would be that oculus does not uses the Sound Blaster Z drivers as it is not connected to it, but through USB. Do you think it is a good idea to install the realtek drivers also?

 

I do not use third party programs.

Hey there Stefanos, thanks for the reply! We recommend using realtek drivers, as the Sound Blaster Z PCIE card seems to have a popular problem of audio popping with the Rift S.

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Hello there!

 

I removed the Sound Blaster Z pcie completely from the motherboard, uninstalled the drivers. Installed the Realtek Drivers, but still it didnt make any difference.

 

Do you have any other ideas?

 

Thank you.

I’m having the exact same issue

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?