cancel
Showing results for 
Search instead for 
Did you mean: 

D-LINK AIR BRIDGE QUEST 3 AIR LINK NOT CONNECTING

DiabloGordito
Explorer

So Just received my air bridge, I managed to get it working yesterday and now it just does not. In the headset it just says it is searching for PC indefinitely. Every once and a while I see the Air Bridge listed but can't select it most of the time, and if I can it won't highlight the pair button.

Before you send through the generic steps, tried restarting Oculus PC app, Headset, PC. Tried reinstalling Oculus app, restoring the Air Link to factory and setting up again. Also tried disconnecting and reconnecting the Air Bridge from the PC.

No difference.

7 REPLIES 7

CosmicBuddha
Honored Guest

I'm having the same problem, endlessly searching for pc.  I got it to work briefly once and launched me into a black room that showed the boundary ring beneath me.  Hoping someone reaches out with a fix.

 

Yeah, no response from Meta or anything intelligent from D-link. My solution was to get a refund and purchase a dedicated router. I splashed and got thd rog gt-axe16000 WiFi 6E router and it works flawlessly with Virtual Desktop. Good luck!

Howdy there, @DiabloGordito! We completely understand that you're encountering some issues connecting while utilizing the D-Link Air Bridge. We know how this might affect your VR experience. We'd want to step in and assist you so that we can get this resolved as quickly as possible. Please let us know if your PC configuration has changed recently. We'd also want to provide some ideas, which we'll post below for you to consider.

 

  • Do not use VPN
  • Toggle on and off Quest Link in system settings in the headset
  • Beta restart Meta Quest PC app
  • Factory Reset VR Air Bridge in the Meta Quest PC app
  • Reboot Headset
  • Reboot PC

Please let us know how it goes so we can determine any additional steps if necessary!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Too little too late and FYI, I already did all of that multiple times. Nothing worked, purchased a router to do the job and not 1 single issue.. the product is faulty, not only that but it lagges out the PC when connected..fail of a product, cheaply made and better off spending the money on a router

Raison75
Protege

Meta and D-Link should be ashamed for releasing such a garbage product. Every 1-star review on Amazon was right. Worked ONE TIME and even that was extremely laggy.  After that it wouldn't even connect.  Returning this thing immediately.

joemg82
Honored Guest

I'm having the same exact issue as t

I have the same issue with trying to get the Oculus app to work with Quest 3 over the D-Link Air Bridge, however, the Steam App works flawlessly connected over the D-Link Air Bridge.