Showing results for 
Search instead for 
Did you mean: 

Dealing with Meta Quest Customer Support is a Nightmare



I have had three issues over the course of the last three months.  Dealing with them has been an absolute nightmare.

When I first received the Meta Quest 3, I noticed nearly immediately it had tracking issues regarding it's controllers. I contacted support the first time after 3 days. I should have just got the receipt (it was a gift) at that point and returned it to the store, possibly for a brand new one, or just returned it and never looked back.

But I didn't.
I contacted Support.

I went through the gauntlet of troubleshooting for tracking issues. 
Batteries back in and out? Check. 30 seconds? Check.
Different room? Reflective surfaces? Check and negative.
Final resort, factory reset! Okay! done.
The tracking issue never resolved though, and as annoying as it was, I decided to live with it because dealing with support had taken me outside of my return window and I had no real options at this point. 
But the problem persisted, and something new was happening.
The headset was getting glitchy. Now, it should be noted, this is a vanilla flavoured, unmodified headset that is well treated.
The headset would start to randomly shut off and resume. I started getting black screens. The controllers were being finicky and still disconnecting, but it was the headset turning off and on that had me concerned. 
So I went through the gauntlet again, this time, it ended in factory reset, but that didn't work, because it never woke up from being reset. It had bricked, and no matter what we did or how long we waited, it simply wouldn't come back to a state where it wasn't frozen.
So, feeling pretty miffed at this point, I wanted to exchange it for a new working one. Because I had basically been dealing with support over issues since the third day I received it.

Can I just take a moment to say how incredibly frustrating it is that all the information you type in before chat isn't really paid much attention to? I get asked serial number for the headset / controllers every time I talk to them, the controllers haven't ever changed so it's always the same, and I always put that information at the start of the conversation, but I still inevitably get asked for that information again. I list all the troubleshooting I have done, and they ask me to do the same things again that I just finished doing.

I can only get a refurbished headset as a replacement, I really wasn't feeling great about that. Let's not go into just how bad that is considering if it really is refurbished, that means you are wearing other people's sweat... but that aside, they wouldn't let me send the controllers back with the headset. I explained to them... the first issues that happened were with the controllers, and they weren't ever fixed. I was told that it was likely just an issue with the headset and not the controllers. I was very skeptical, and would have much rather have sent it all back and had it all replaced to guarantee everything worked together when I received it again, but they were insistent.

So I mailed in the headset after getting the Purolator label. There is one purolator out here. It's 40 minutes away. It's only open during the hours that I work. So I lost work hours and paid gas etc to go to purolator to drop it off.
A hassle, but I would live.

I waited until it was processed, watched as the replacement made it's way back to me. I was apprehensive, I had a gut feeling that the controllers would still have issues... but I didn't think the issues would be as profound as they turned out to be.

I fired up the "new" headset, the blue logo twirled cheerfully in the display, and I came to the screen with the animation of a woman pulling the tab away from the battery case on the controller. I immediately knew this could end up an issue.

I first tried out some buttons to see if it would connect. Nothing. I expected that might be the case... so I took the batteries out (Multiple times actually and for longer and longer as I got frustrated.) But pulling the batteries was doing nothing. The woman still cheerfully and repetitively was pulling that tab away from the battery bay... I feared she might be getting tired of that repetitive action. I certainly was.

I contacted support, waiting on hold in a queue for chat. Typing a nice long description of what had happened. Thorough as I could possibly be, describing in detail down to the clothing the animated woman was wearing, what I saw and had done. 

Batteries were taken out again, I had done this many times before, but hey, humour the nice chat support agent.
Try the Meta Button / Y pairing mode Menu / B (haptic response and flashing white lights, but no dice... it still wasn't connecting.

Then we tried the factory reset on the controllers, something I have read in many forums and it would seem, no one has successfully done. The press in the menu button and hit the A button five times, and on the other controller the meta button and the X button five times. Yep... The light pattern you are supposed to see? That's not what I saw... and by the sounds of it, I haven't seen a single forum person get that to work either. I also tried it the other way, holding the A, hitting menu five times, holding x button, hitting meta button 5 times... And every other button combination I could think of.

By now, several support agents later, and several disconnects later... because the agents on Meta support really seem to like to drop you in the middle of a chat, or the beginning of a chat, or before you even get to chat.... Basically anytime really... We were at that point where you do the factory reset. I was highly skeptical of this helping. It had either been factory reset, or wasn't used before... but I still did this. In fact I probably tried this and the above steps at least 3 times before it was time to give up.

But not before support said to unpair the controllers through the app. And that would have been great... wonderful even, if that were remotely possible. You see, they had my headset... the original one that was paired to the controllers I had, but didn't want. In order to unpair the controllers, I would need to connect to my headset I didn't have... and I wouldn't' be able to unpair without doing that. It was still amazing to me that so many support agents asked me to do this step without realizing it would be impossible to do. I was shocked at how many steps I was asked to do that would either depend on having the original headset, which they already had, or I would need working controllers that were already connected to the headset, which... of course would mean I wouldn't have a problem anymore, and wouldn't be talking to them in the first place.

So once again in line with the technical support... This time significantly miffed as it turned out how I had anticipated, with the controllers having issues. At this point I am fairly certain this is a software issue, not a hardware issue. You see, the controller's lights all work nicely. You can feel it is trying to pair, but the software... which is doing first time setup, isn't expecting controllers that have been paired to another device before. It is more than likely expecting you will take that tab out, and it will already be set to pair with the controllers that were sent with it originally, or at least ones that have never been paired before, but it hasn't taken into account this situation.

So I talk to... at this point I am not sure how many support agents in I am. I am really frustrated though... and I really just want to send everything back and get a completely new in box Quest to just... have it work? I have basically had problems since day 1 even though I only talked to meta on day 3.
So they were not willing to do that of course, because they had already wasted 2 months of my time.
They were going to send me...  care to guess?  Yet another headset! 

At this point I said, you know what, you should really take the controllers too. There have been issues with them in the past, and even if I don't think the connection error is related to the glitching, they are going to have to be addressed at sometime anyway.

I really pleaded with the support agent. I explained the wringer I had already been through, and I really didn't want to go through it again. I just wanted it to work. But the agent insisted it was the headset, not the controllers, because I had lights that worked. I explained that I believed it was more of a software malfunction that is fundamentally causing it to fail because the controllers still think they belong to the first headset. 
At which point they suggested unpairing in the app again.

So, at this point, I have no choice. They aren't giving me one, and I am not happy. I ask, what happens if it still doesn't work. The support agent is pretty confident, but if that happens, we will deal with the controllers at that time. Missing the point that at headset number three... maybe we should be looking at replacing everything. I am an expert at getting serial numbers, factory resets, pairing and resetting controllers at this point.  

At this point I have spent a good deal of time getting to know this headset. Sure we never get to talk about anything too deep. There's a wall there, but I think I will name it Bob. Anyway, again I look for some good secure fill to keep Bob safe. I am pretty sure there is nothing wrong with him, but never-the-less I send it away... again, again the 40 minutes in, 40 minutes out... time off work.
I wait.

Finally the last headset arrives today.
I don't bother naming this one. I am immediately taking down serial numbers in anticipation of the support chat I will undoubtedly have.  Fire it up... everything works the way it did the last time.
The nice spinning cheerful Meta Logo is mocking me. As I see the rather plain animated woman pop up on the screen and begin to remove the controller tab again, I sigh... I close my eyes and look skyward. I pop in the first battery, gingerly..., then the second. I hesitate for a moment. Do I really want to know if it will work this time?

I have been hurt so many times before...

Taking a deep breath I start to click buttons. It should be mentioned the batteries have been out for two weeks and were brand new.... it's important to state that... It's something support asks pretty much every time I talk to them.

I press buttons, I try pairing, and go through all the usual steps that end in yet another factory reset. I already have all my serial information already jotted down along with a nice and even lengthier explanation of what I have gone through tinged with a bit of sarcasm and frustration.

I suppose I can't fault the first support agent for giving up on the chat before she had even got through the description of what I had been through, and maybe I should give the next one a little credit for hanging in their with me despite the now very "I told you so... more than once..." tone that may have been oozing out of the letters I was typing on the screen, but it was at the point that... after I detailed very clearly every step I had taken and every little thing that appeared in the animation I saw on the screen to indicate exactly how it was not working, and how the controllers were just producing purely decorative lights... that I decided I may need to write this, because no matter what the solution ends up being, which at this point... will mean likely having to head out to purolator after printing the label, and finding packing... and taking time off work again.. the hassle has not been worth it.

You may notice you get to a point in the support chat where they try to get rid of you and say they will follow up with emails. They don't actually offer you an answer as to what they are going to do, only that they will look into options. This is in response to me asking to please, not to send any more used refurbished parts. The issue started when this was brand new, so I figured the solution should probably be a replacement new part. In this case, the controllers. They basically pushed me along without answering whether they could do that and cut and pasted a bunch of prepared scripts for ending calls with this purpose in mind.

I had an idea what would be coming in my email. This time I got the email saying that They wanted both controllers sent to them, but in separate packages. Which... seems very odd. They will be processed separately apparently, and I will get two back which MAY BE refurbished.



Heroic Explorer

Then we tried the factory reset on the controllers, something I have read in many forums and it would seem, no one has successfully done. The press in the menu button and hit the A button five times, and on the other controller the meta button and the X button five times. Yep... The light pattern you are supposed to see? That's not what I saw... and by the sounds of it, I haven't seen a single forum person get that to work either.


You may have just typed it wrong in the message, but the reset sequence you typed doesn't match the web ...

  1. Right: Hold the A button and tap the Home (Meta logo) button 5 times.
  2. Left: Hold the X button and tap the Menu button 5 times.

Thanks for the reply, but yes... I typed it backwards. lol. (though to be fair, I have tried it the other way around as well) Actually I think I tried holding every button with every combination of button being pressed 5 times. 


Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?