Showing results for 
Search instead for 
Did you mean: 

Device update in progress


my kids have being trying to play gorilla tag and among us for weeks and the oculus Keeps saying device update on progress. It has been left over night plugged in and connected to Wi-Fi for a number of days but never changes. Please can you help


Community Manager
Community Manager

Hey hey Noakes_Family_1234! Oh no we see you are having issues with playing Gorilla Tag and Among Us. We really want to get your kids back to gaming so that we can do so please provide the following:

  • What device do you currently own?
  • Have you tried any steps to resolve this issue?
  • Are you able to provide a screenshot of the error message?

We look forward to getting your kids back into the wonders of VR!

I have an oculus, my quest 2 I have attached a picture of what it’s says. I have tried to factory default the quest and reboot but it always comes back up with that message, I have even left it plugged in overnight many of times as it states but it never updates come the next day. I brought the game among us on Tuesday and it does the same thing with that game too.A4735387-ABDF-448D-8AB5-D577ABE251DE.jpeg

Hey there, thanks for reaching out to us! We understand how inconvenient this is for you, so let's see what we can do to get this issue resolved!

If you don't mind us asking, how long has this issue been occurring for you? Is this the only game that it's occurring for? What software version is your quest on, and could you try updating it manually to see if that'd result in any changes? Reach back out to let us know if any changes occur. We'll be waiting!

this issue has been 5/6 weeks only with gorilla tag which unfortunately was there favourite game, this week I purchased among us and the game is doing the same thing. I have tried to manual update it but I assume I have the latest version because the box to update is faded out meaning I can’t click to update. On the app it’s says version 189.0. How this helps.

Thanks for confirming that for us! We hate to see your family has gone 6 weeks without their favorite games, and we'd love to get this resolved for you. Since you've already tried rebooting and a factory reset, we recommend you reach out to our amazing support team here so we can look into this further for you. We look forward to hearing from you soon!

Level 2

I have a simalar issue with my headset. Left it multiple days turned-on (connected to power)  but won't update.

Headset is still Version 24721951509000000

Did already factory resets multiple time but it is stuck on this version and application keeps saying device update in progress.  Headset can't be used now 


What can I do ?



Hey Danny, we're sadden to hear that your headset isn't updating properly, and it's even more troubling that you can't use it right now. Since we've been in your position before, allow us to offer our assistance.


  1. Which type of device are you attempting to update?
  2. Does the headset display the update's progress when it is updating?

Level 2
  1.  I am attempting to update my Quest 2
  2. No, it is showing this when I start an application. The application won't due to this pop-up window.

Hey Danny, We appreciate you getting back to me with the information we needed. Here is a link to open a support ticket so that our experts can look into this matter for you in more detail.