Showing results for 
Search instead for 
Did you mean: 

Displayport not connecting

Honored Guest

I have a rift S that is not able to finish setup. I've had it for a couple years, hasnt been used in maybe 6 months, but after trying to set it up on another computer, it does not connect. USB connects, displayport will not. I've done a clean install of nvidia drivers, I've reinstalled USB drivers, windows updates have been performed, I've disconnected all other monitors and USB devices, tried the oculus driver exe, still nothing. Sometimes it'll connect, but then when I click next onto the sensor setup, it will disconnect. Any suggestions?


Community Manager
Community Manager

Hey there, @ajsmith1217!


Thank you for reaching out! We're never happy to hear about someone having a hard time getting set up, but it does pop up from time to time. Fortunately, we've seen it before, and we're always more than happy to take a look with you. You've done a fair amount of work and got a good head start, so let's see what we can make happen!


You mention that you're getting set up on a new computer. Do you know if this particular computer meets all the Rift S requirements? Also, are you running a laptop or desktop? Just to double check on that real quick, here's the requirements for getting the Rift S to run.


With that bit out of the way, let's move on to a proper possible solution, eh!? With your DisplayPort not being recognized, you could be looking at a power supply issue, mate. Give this a shot!


  • Make sure the Rift S cable is plugged directly into the primary dedicated graphics card without using an adapter
  • Verify all connections to the PC are secure
  • Reseat the Rift S cable on both the headset side and the side that plugs into the GPU
  • Restart the computer
  • Ensure that USB power settings in Windows Device Manager are not enabled by following the steps below:
  1. Open Device Manager
  2. Locate your USB ports
  3. Right click and select Properties
  4. Navigate to Power Management
  5. Ensure that the options to save power are deselected

This usually resolves the whole "No DisplayPort" issue. Please let us know if it doesn't, and we'll definitely have more tricks up our sleeve for you!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

I've already done all of this, same result.

Hello again, @ajsmith1217!


Oh no! That's not what we were hoping for! Just to clarify, and this is an important detail, are you on a desktop or laptop? Our next steps could change depending on what you're using.


As far as what we can do for now, let's go for an complete uninstall and clean install of the Oculus Software. This is going to be a bit of a different process opposed to the usual "uninstall and reinstall", but this usually takes care of  things when adjusting the power settings don't work out. Please follow it step-by-step and let us know how it goes!


Here's the whole process:

1. Disconnect the Rift/Link cable from the computer.

2. Disconnect your computer from the internet.

3. Backup any necessary content.    

  • You can find steps on how to do so by clicking here.

4. Reboot into Safe Mode.

5. Uninstall Oculus PC app using the Control Panel.

6. Delete all Oculus folders from the following folder:    

  • C:\Program Files

7. Remove any Oculus folders from the following locations:

  • C:\Users\YourUserProfile\AppData
  • C:\Users\YourUserProfile\AppData\Local
  • C:\Users\YourUserProfile\AppData\LocalLow
  • C:\Users\YourUserProfile\AppData\Roaming
  • C:\OculusSetup-DownloadCache

8. Restart your computer in normal mode.

9. Reconnect your computer to the internet.

10. Install Oculus PC app again using the setup tool from our website here.

11. Reconnect the Rift/Link cable and re-test the headset.


We've got you, mate!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Hey there, @ajsmith1217!


We're just checking in to see if you were able to get that DisplayPort issue under control.

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!


my rift s that i bought from backmarket does not work it says that the dp is not connected any fixes? edit: i am on desktop my specs are GPU: nvidia GTX 1660 super, CPU: intel core i5 4690k, 16gb of ddr3 ram, 2 ssds, one 1tb and one 223gb and a corsair v550 psu

Hey there, @Garfieldcat3288!


Did you follow the steps we previously posted? Check those USB power settings and it will take care of this most of the time. If that doesn't work, going for the complete uninstall and clean reinstall usually resolves everything.


If you're still in the weeds after following both of those steps, let us know! We'll be more than happy to take a closer look at everything with you. Grab your logs by following the instructions listed here, and send us and email or chat by following this link. We have more tools at our disposal there, and will be able to see exactly what issues are keeping your headset from working properly.


Hopefully the steps above help, but if not we'll see you on the support side. Good luck! We're looking forward to seeing you in VR soon.

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

thanks, but sadly it did not work

@Garfieldcat3288 Have you checked to see if your GPU drivers are up to date? This is a common one some people tend to miss and it does tend to help out with DisplayPort issues. 


Let me know if that does anything for you.

Sometimes it's okay to be a little Bing Chilling

i tried this and it did not work sadly.

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?