Showing results for 
Search instead for 
Did you mean: 

Does 4070 TI super work with oculus link? Or any 4000 series GPU?

Expert Protege

I built a brand new pc this week with a 4070 ti super, i7 14700k, msi z690 unify motherboard and 192gb of ddr5 memory.

The issue I have is when I connect to oculus link I get a usb kernel error and a cannot write video (access is denied) to a specific path which I can't remember off the top of my head.

Is it just because the GPU is new that it does not work or is there some other obvious error? I am using a fiber optic link cable so I doubt that is the issue. I tested several other cables but unfortunately I do not own another GPU I can test on.

GPU drivers are the latest (only) ones since GPU only came out 7 days ago. My bios is also brand new as I had to flash it to install the new CPU. Some suggested usb issues but it's not that as I have tested USB A and USB-C with no effect.

I do get audio if I launch games froom the pc side but I see the 3 dots and no video. And on the mirror screen on my desktop I see the game running and tracking the headset movements. This is clearly a video issue.


Accepted Solutions

Meta Quest Support
Meta Quest Support


Don't worry be happy.

View solution in original post


I have been back and forth with Meta Tech Support since September ( Case #(Redacted) - old, Case #(Redacted) - new ) trying to fix my Oculus Link on my Razer 16 4090 which stopped working after an update when I started getting a Blue Alert banner saying

"Your computer doesn't meet the updated minimum specifications, which can lead to poor experience in VR. Learn More"

Case #(Redacted) <-Closed because I had to go on work trip and wasn't responsive in time.
Case #(Redacted) <- Closed because my "4090 GPU is not supported" and I should upgrade (my laptop) GPU

For Background, I've been a VR Dev since DK2, with published VR Experiences I've produced, and bought this Razer 16 4090 specifically for my next game, so I can dev on the road while I travel.

However, Since September, I have only been able to connect my Quest to PCVR via Virtual Desktop and ALVR.  Conversely,  Link Cable and Air Link stopped working and the Oculus App believes "Your computer doesn't meet the updated minimum specifications,..."

For the Record it's a Razer 16" with 32GB of RAM, a 4090 GPU and an i9-13950HX 5.5 GHz CPU.

So I've done everything including wiping the computer, reinstalling the OS and swapping the motherboard (by Razer under warranty).  Of course tech support has their list of things they asked me to do as well, but after jumping through all the hoops they requested they finally get to the point of evaluating my logs and tell me:
{snip}....Upon checking the log files that you have sent to my colleague, your GPU is "NVIDIA GeForce RTX 4090 (laptop)," which is currently not supported on any PCVR device, including the use of Quest Link or Air Link.

As much as I wanted to help you, what I can only advise is for you to change your GPU to one of our recommended for you to enjoy more of the features of the Air link.

To learn more about the minimum and supported requirements to use Quest Link and Air Link, you may visit this link to view more information:
Note: the NVIDIA GeForce RTX 40-series is supported on the link they sent me. 
(Face Palm)
So after my 3rd month of Meta tech support not being helpful and (confusingly) telling me a 4090 doesn't meet the minimum spec, I'm a bit at my wits end on how to get the Quest Link working again so I can go back to VR Development on this station.

Any Ideas?
(And yes I've tried on this laptop a Quest 3, Quest 2 and Quest Pro, Multiple different Oculus Link Cables. Virtual Desktop connection into SteamVR works, but Oculus Link does not and the App and tech support claim my GPU doesn't meet the minimum specification...)
le sigh.



Just so everyone can see what I mean about the Blue Alert Banner at the top of the App...


Screen Shot 2023-11-28 at 12.19.29 PM.png

I reinstalled the OS and returned the Razer 16 to Factory settings.
I installed Firefox
I used Firefox to navigate to Meta, and Download the installer.
I installed the Oculus App
Link is now working(Woo Hoo!),
HOWEVER the Blue Banner warning:
"Your computer doesn't meet the updated minimum specifications, which can lead to poor experience in VR. Learn More"

Is still there.  So it's possible I had (2) issues on my machine, one affecting the Link Cable and another causing the Blue Alert Banner (Which is still there).

Meanwhile Meta Tech Support has not replied to my last trouble shooting message on my support case for this.

What's the problem exactly? Just use virtual desktop. Airlink is crap.

I have the same laptop and same problem.  Thank you for figuring it out.

Community Manager
Community Manager

Hey hey @echo.sonic.x! We think it's so cool you've built a brand new PC! We'd love to provide you with as much information as possible, and help you as best you can so you may enjoy your VR experience! With that being said, check out this link with information on the requirements to use Meta Quest Link. This will give you the windows PC requirements, as well as the supported GPU's for Link. We hope this helps! 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

can you stop with these useless, canned, responses and stop to read the question?

4070 ti super, 14700k, 192gb of ram is a upper-mid system containing brand new 2024 components and in the grand scheme of things is a highe end performing system. Of course I meet the requirements. What a stupid respons

i have the same think slightly lesser pc, but still better thenminimum specs required. 

Everything works but still get this error. noying


Hello @lairnoc! We understand that an error message might ruin your fantastic VR experience and be very frustrating. Our goal is for each and every one of our users to have an uninterrupted experience. Having said that, have you attempted:

  • Updating GPU Drivers
  • Updating NVIDEA drivers
  • Updating AMD drivers

If you have already tried attempted these, please don't hesitate to reach back out to us to look through other troubleshooting options we have for you!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!
Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?