cancel
Showing results for 
Search instead for 
Did you mean: 

Elite Dangerous still reporting "anti-virus blocked installation" even when anti-virus is off

Devilstower
Level 5
Weeks after the problem first started, I'm still getting repeated fails from Elite: Dangerous. 

The message says "Sorry, it looks like your anti-virus software blocked the installation of Elite ..." This is true even though both Oculus and Elite are explicitly white-listed. In fact, the problem continues even if I turn both the antivirus software and the firewall completely off. Even if the machine is wide open, over every security warning, Elite still gives the same error.

Every other application updates without issue, but Elite won't budge. I've been waiting weeks now, thinking "surely they'll address this issue." But ... nope. It's still there,
10 REPLIES 10

FrontierSupport
Level 6
Hello Devilstower, the Elite Dangerous launcher does not produce error messages with this wording, I believe this is an error message produced by Oculus. I've found a similar report in this forum thread: https://forums.oculusvr.com/community/discussion/57144/no-games-work-sorry-it-looked-like-your-antivirus-software-blocked-the-installation-of-game

Apparently the solution in that case was a clean reinstall of Windows 10, which seems a bit invasive. I suspect that the error may be caused by a permission issue -  maybe Oculus is unable to write some files in the target folder and believes this is caused by antivirus blocking it. Please try the steps in our support article here:

https://support.frontier.co.uk/kb/faq.php?id=409

Hopefully, this will improve the situation 🙂

-CMDR Kosmos
Frontier Support

vannagirl
Level 12
@Devilstower

is this on a clean install or a backup you did of your software folder?
Look, man. I only need to know one thing: where they are. 

Devilstower
Level 5
It may not be an Elite message, but considering that every other application loads without error, and I get this message on Elite even if the antivirus is completely disabled, it certainly suggests that Elite is doing something that no other application is doing, and that whatever it's doing is interfering with a normal update.

79ar38w4rn6r.png

Devilstower
Level 5
Is there no support available from anyone on this? I've turned the antivirus completely on and off. Tried removing files. 
Nothing works.
I haven't been able to play Elite in MONTHS. This is not seeming like a good investment.

escapppe
Level 3
you can try this as a workaround:
install elite dangerous from steam
if you launch elite dangerous (even through steam) it should recognize oculus runtime automaticly and launch into the HMD with native oculus SDK

Devilstower
Level 5
Wouldn't this work around involve buying the game a second time?

Syrellaris
Level 8
Start the Oculus Launcher in Administrative mode, same for the Elite Dangerous File.
Also, which antivirus are you using?

Devilstower
Level 5
I am on an Administrator account, and am only using Windows Defender -- which can be completely disabled. It fails whether it's on or off.

Syrellaris
Level 8
What windows version are you using?  You  could also delete the whole app data folder for frontier developments and try again