Showing results for 
Search instead for 
Did you mean: 

Emerging Issue - Unable to log into Oculus App after Meta Account Merge

Level 3



I am on Windows 10, I have an Oculus RiftS and the Oculus PC application.


I have just updated my Oculus account to a Meta account. 


When I log in to my Oculus app I get the message in the title: 

"You're using a version of this app that's no longer supported. Download the latest version to continue."


There's no download link and I don't know how to continue. I cannot use my Oculus Rift S at the moment.



383 REPLIES 383

Retired Support

Hey everyone, thank you all for bringing this issue to our attention. We're currently in communication with our engineering team to get this issue nailed down, find the root cause and get this resolved. We'd like to encourage everyone to share their experiences and any troubleshooting steps you've tried in this thread so that we can collect this valuable information for our teams. We greatly appreciate the feedback, as well as your patience while we look into this!

Take your destiny into your own hands. Sand cannot keep a shape by itself, but add water and it becomes malleable. Fate can be such, if you add the right element.

Same here. And when I try to login through Facebook, it tells me there's already an Oculus account associated with my Facebook email. When I try to merge (which I didn't want to do, as the new Meta Horizon account is supposed to let you forgo a Facebook connection) it asks for my login and then tells me there is no account connected with that. So frustrating.

I had this problem. A couple of hours ago I created a Meta account and setup my Quest, Quest 2 and mobile app without any problems, however upon launching the desktop app I initially had the wrong version error.

I tried downloading the software again from Meta's Quest page. I then ran the downloaded file (without bothering to uninstall anything). I then chose 'Repair' which re-downloaded and reinstalled the Oculus app. After launch the login page only had two options: 1. Continue with Facebook, 2. Have an Oculus account? So I closed the Oculus desktop app. I was just about to give up but luckily my Quest 2 was connected on the USB so I thought I would try using Oculus Link just to see what would happen. When I did so an error message appeared in the Quest 2 saying I needed to login. After taking off the headset I noticed the desktop app login screen had now magically changed to a different opening screen which had the Meta login available. So this has fixed it for me. Sorry to Rift/-S users as this is'nt going to help them.

Level 2

Okay I find a solution here:

- Win10

- Oculus App version

You have to click on "login with email", so it open a browser who let you correctly connect with your new META account.

note: Some user reported that you have to change the Windows Language (from english uk to english us for example) in order to have the "login with email" button correctly work.

I 'repaired' my app with the latest software download. That allowed the app to at least start. However, it then asks me to login via Facebook or Oculus.


When I choose Oculus and enter my email/password it gives me an error that one of them is incorrect, which I know it is not.


When I go to login via Facebook (which I didn't want to do, since the new Meta Horizon account is supposed to allow you to not have to use Facebook) it tells me there's an existing Oculus account associated with my Facebook email. When I go through the process to Merge accounts, it asks my to login to my Oculus account, at which point it gives me the same error and won't let me login.


When I try to reset my password for my Oculus account and enter my email address, it doesn't send me an email with a link. Instead, it just gives me a different web page to go to to reset my password...which is my new Meta account which I am perfectly able to login into with that exact email/password.


It's a loop with no way out.

I have tried uninstalling/reinstalling with no luck. 

I have the exact same problem!


I migrated from an Oculus account to a Meta account. I then started the Oculus app on the PC and clicked on "Have an Oculus account" (as there is no option to choose a Meta account).

After entering my credentials, which I know is correct as it works to login with them at, I get the following error:


I hesitated to do the migration to a Meta account as I was afraid that something strange would happen. And of course it did ☹️👎


So now there is no way for me to use my Oculus Rift any more. I hope that they will fix this soon!!!


This worked for me! Thank you!

Thanks for the update.

As a quick sanity check, when I try to download the newest version of the App from the store, i.e. here:


That is linking to a setup file called OculusSetup.exe

Seems an odd filename with the rebranding to Meta.  Is that still the correct file?