Showing results for 
Search instead for 
Did you mean: 

Emerging Issue - Unable to log into Oculus App after Meta Account Merge

Level 3



I am on Windows 10, I have an Oculus RiftS and the Oculus PC application.


I have just updated my Oculus account to a Meta account. 


When I log in to my Oculus app I get the message in the title: 

"You're using a version of this app that's no longer supported. Download the latest version to continue."


There's no download link and I don't know how to continue. I cannot use my Oculus Rift S at the moment.



383 REPLIES 383

Level 3

I can't login to the Oculus app (phone or pc). I am logged into Meta in Chrome, but when I enter my email and Meta password into the login of the Oculus app, it responds with "Wrong email and/or password.". When I click "Forgot password?", it takes me to "". When I enter my email address into the prompt, I get a red error message: "To set a new password, go to and follow the instructions."


When I try going to that address, it redirects me to my Meta homepage, where I'm already logged in. I have changed and double-checked the Meta password. It still logs me into my Meta account in Chrome, but doesn't work for the Oculus app.

I just tried but no luck, after I get the prompt telling me to login on my machine, it goes back at the login with Facebook/login with Oculus thing. 
I am now re-downloading those 5 GB of data for the 4th time today. 

This is getting on my nerves. 

Level 2

I found a solution !


1 : Closed the Oculus desktop app

2 : Log with oculus link connected on the USB

3 : You will get an error but the Oculus app will appear !

4 : If you see the login with email appear = it will open a website and login with your account will work

5 : If not, change the language of the oculus app (US/UK), you will see the possibility to log with the email account

Ima try this as soon as the download finishes... again... 


Sorry why is this marked as a solution? 

same problem here...

Level 3


I can log in to the phone app with my new meta account.

1st - I tried the uninstall reinstall. I used the link. The facebook login takes me to the error screen I posted and the oculus account tells me wrong email and password.


2nd - I reset my password with the


Still receive the wrong email address and password error.

Oculus app continues to state it needs an update.

I ran into this same issue (i.e. Oculus PC app has no Meta account login option. Only the old options of Facebook or Oculus Account. Trying to login with the Facebook account which has already been updated/connected to a new Meta accounts yields the following error: "You're using a version of this app that's no longer supported. Download the latest version to continue." Uninstalling and reinstalling the Oculus PC app did not solve this problem for me either.


image (6).png


I ended up logging into my Oculus PC account with a different FB account that had not been updated/connected to a new Meta account and I was able to login. From there I went to Settings --> Beta --> Public Test Channel & I enabled that option which prompted a download for the new v43 update. 

However even after I had the new updated applied to my Oculus PC app, when I logged out the login menu still only had the old options of FB or Oculus Account login and the FB option still presented the above error when logging in with a FB account that had been updated/connected to a new Meta account.

These kinds of announcements on issue tracking threads are always marked as a solution to pin the post to the top of the thread for maximum visibility.

Take your destiny into your own hands. Sand cannot keep a shape by itself, but add water and it becomes malleable. Fate can be such, if you add the right element.

I tried this and unfortunately it didn't work. My oculus app is not switching to allow me to log in via Meta, still facebook or email.