Showing results for 
Search instead for 
Did you mean: 

Emerging Issue - Unable to log into Oculus App after Meta Account Merge

Level 3



I am on Windows 10, I have an Oculus RiftS and the Oculus PC application.


I have just updated my Oculus account to a Meta account. 


When I log in to my Oculus app I get the message in the title: 

"You're using a version of this app that's no longer supported. Download the latest version to continue."


There's no download link and I don't know how to continue. I cannot use my Oculus Rift S at the moment.



383 REPLIES 383

Same here. After migrating to Meta my iphone cannot pair with the headset. When I enter the 5 digit code I can wait forever, nothing happens. Reinstalled the app on the iphone several times without any improvement. The bluetooth-connection works as well as the WiFi-connection. Even the messages from my iphone appear in the headset. But pairing is impossible.

This "solution" might be great for Rift users but does NOTHING for Quest2 users. I switched over to Meta, the headset worked for a few days, now this. All I get is a log in page (for Oculus AND Facebook). Then I get the same stupid "update your settings" with NO OPTION to go back to settings! Here's an idea... let's not switch over EVERYONE until we are sure the system works correctly! God only knows how long this is going to take.

Community Manager
Community Manager

Hiya there! We understand that troubleshooting can be a time and data consuming process. We have been there plenty of times ourselves. If you do find you want to try troubleshooting, the steps are listed below. 

- Uninstall the reinstall the app

- Change the password on you account 

Some users have had success with those steps. In the case that you don't, we ask that you follow the link here and describe what you're experiencing there so our engineers can see the scope of the issue.

Level 2

Quest 2 User here. Need step by step help!!! Trying to sign in with email and I am in a never-ending loop of changing my password only to be told password invalid. Had to wait over 9 months to update to windows 11. Now this garbage! Been with Oculus since Samsung Gear VR Innovator edition in 2014. Specifically purchased my new computer for PCVR content. C'mon Meta or whoever the hell is in charge of this! My hyping up this product may finally be waning! FIX IT!!!

I ended up doing a factory reset and seems to be better 

Level 2

After dong the mandatory update I cant not only sign in my account my the app is impossible to even open to attempt to sign in.  initially it would open and fail to sign in one time then the app would go blank until the next day it would let me try again 1 time then it would fail then go blank again.  Its been 2 weeks of this and now the app will not even open.  I have tried complete uninstalling the oculus app including manually searching the drive to delete left over folders after the uninstall but still wont even boot with a fresh install,  So then I went onto my old laptop that I haven't used vr for in about a year, opened the oculus app successfully , it then updated by it self, asked me to sign in, failed signing in, and is now blank to!!!!!!!!!  


and yes i am 100% sure my log in is correct because I can login on a web browser. 


When the app used to let me try once a day i tried signing in with all the option( Facebook, Instagram, by email, etc.) but not a single one would let me sign it.  It would say failed to fetch?


The screen shot is the only thing that the app opens to nonmatter what I try.  


This will be the 3rd week of this not working and oculus support is 100% useless and have no fix.



The same problem, I open the windows app and it opens my browser and this message appears

Sorry, something went wrong.

We're working on getting this fixed as soon as we can.


Can't play or work connected to the PC

3 weeks? OMG. 
maybe revo uninstaller will help
Use the email login, I don't think the others can be used anymore if you have created a meta account.

The only way I got things to work was by doing a factory reset.  What a mess and they don’t give any instructions.


Thats 7 days I’ll never get back 

Same here.