Showing results for 
Search instead for 
Did you mean: 

Emerging Issue - Unable to log into Oculus App after Meta Account Merge

Level 3



I am on Windows 10, I have an Oculus RiftS and the Oculus PC application.


I have just updated my Oculus account to a Meta account. 


When I log in to my Oculus app I get the message in the title: 

"You're using a version of this app that's no longer supported. Download the latest version to continue."


There's no download link and I don't know how to continue. I cannot use my Oculus Rift S at the moment.



383 REPLIES 383


Is there a solution yet? I also see this screen and cannot move forward. A hard reset has been done twicebut hasn't worked. Is there a solution for this? Leo4eva_0-1662963113797.png


I was prompted to a software update first and after it finished i was told to setup  a Meta account 

Level 2

Similar problem for me, I logged out of my PC Oculus App today after encountering a "entitlement check failure" upon starting up Adobe Medium, and haven't been able to log back in to the Occulus App since. I can still use Gravity Sketch on my Quest 2 but not being able to use Adobe Medium for two days now already has me failing to meet deadlines. 


My system is running Windows 10 and here are some of the things I've tried so far.

1. Changing my default brwoser.

2. Logging out and back into my Facebook/Meta/Occulus accounts.

3. Resetting my passwords to my Facebook/Meta/Occulus accounts.

4. Changing the email addresses to my Facebook/Meta/Occulus accounts.

5. Fixing the PC Occulus App witht the setup wizard.

6. Uninstalling and reinstalling with the setup wizard.

7. Uninstalling with the setup wizard, downlaoding a new setup wizard and installing again.

8. Logging in with diffrent methods(Facebook: redirected to Meta. Instagram: redirected to Meta, Set Up Account With Email: redirected to Meta. Login With Email: Redirected to Meta. Login with Occulus Account: I "don't" have an Occulus account now that it's updated to be a Meta account.

9. Switching to Personal Hotspot instead of my WiFi.

10. Switching to an ethernet connection instead of my WiFi.

11. Using a VPN, and switching places on the VPN app.

12. Turning off Windows Firewall.

13. Turning off Firewall for the Occulus App, and my browser.

14. Restarting my cumputer.

None of the above worked. and mainly I've got two error messages, on is in the picture below:


the other is " Fetch Error", Initially I tought to myself--I must have bad internet, but oh wait, I'm on 1000m bandwidth fiber! 


"rant to the support team: idc about your re-branding strategies and frankly i like the whole metaverse thing, but this is my livelihood! my quest 2 used be a reliable productivity tool and now i'm disgusted beyond comprehension!!! it's unbelievably confusing how the accounts system work, it's so haphazardly put-together i bet even the devs are ashamed of it, and I understand that the quest 2 is an "economic approach" to vr but with less customer support than your local mcdonals, you're practically outright scamming ppl!"

Are you guys aware of the Meta Accounts screwing up the Oculus headsets? We can't login to our accounts for a variety of different reasons ranging from the verification code not sending to our email or the Quest says it needs a "system update" even though the settings say you're up-to-date. It's a whole thing on your Reddit server, r/Oculus. Here's the link incase:

Yes.  I had a software update and after that I had to switch to using a Meta account and had issues for 7 days.  Finally I did something and it currently working.  


They should have informed users PRIOR to forcing you to create a Meta account and HOW to do it 

First off I'm not even migrating to a stand alone meta account, staying with facebook.  How is this still an issue 3 weeks later and why is the posted "solution" a 3 week old post that says "we're working on it"?


Getting same error as of 9/14/2022

You will have to switch before 01/01/2023

Same issue, stuck in a login loop.  Can log into new meta account, when PC oculus app starts, asks for login info, says incorrect, click reset password, goes to the Meta account that is already logged in....:facepalm:

I had similar issues.  After 7 days I left the oculus off and looked at my Facebook and Meta accounts.  I changed my Facebook email to my Meta email and then shut everything down 


Then I started the oculus app on my PC and put on my headset.  Got instructions for a factory reset so I tried that and now everything works but really don’t know what I did to fix this mess 


Hopefully you’ll get back to running 

I have the same issue. I've had no response from Meta on a fix. I don't understand how they can send out a non working product without a way to fix it.