Showing results for 
Search instead for 
Did you mean: 

Emerging Issue - Unable to log into Oculus App after Meta Account Merge

Level 3



I am on Windows 10, I have an Oculus RiftS and the Oculus PC application.


I have just updated my Oculus account to a Meta account. 


When I log in to my Oculus app I get the message in the title: 

"You're using a version of this app that's no longer supported. Download the latest version to continue."


There's no download link and I don't know how to continue. I cannot use my Oculus Rift S at the moment.



383 REPLIES 383

The product is fine but the addition of the Meta account is causing issues for a lot of users.  From what I’ve read, they are going to disconnect with Facebook and oculus users will only need a Meta account but they failed to communicate this with oculus users and give the proper instructions 

I can log in and this is the error screen im getting


When i switched up English UK and logged in with email it worked

Hello there! We understand you were having some issues with the update, as well as issues with your Meta account; we understand this can be concerning, and you are unable to enjoy your VR experience; don't worry, we have your back. We will do everything in our power to get you all taken care of as soon as possible.


Can we ask if you are still having problems with your Meta account, if you are able to view your games, and what other problems you are experiencing so that we can assist you to the best of our abilities? 

Fortunately I got it working again!  I will continue to monitor it but don’t anticipate any problems 

This is what I'm having an issue with:


"Thank you for waiting for an update from us.
Upon checking with the relevant team, the mobile app and headset pairing issue is currently affecting some number of users. Therefore, our engineers are looking into getting this sorted as quick as they can.
That being said, I will keep this ticket open and active. Once the issue has been resolved, I will notify you via email on this ticket (#5528885). At the moment, we do not have a fixed timeline on when this issue will be completely resolved."

I received a headset I cannot use. I am on my fourth headset due to issues beyond my control. How will this be fixed?

How did you get 4 headsets?

The first one, I bought brand new. I developed a screen issue. The second one got stuck trying to download software and would not reboot or do anything. The third and fourth ones will not pair up due to software download issues that Oculus is aware of but does not have a fix for. I spent $299 for a new headset and keep getting crap in return. 

On mine I had to do the software update too.   It took quite a long time to complete and I thought maybe something was wrong but it completed and then came the creating a Meta account 


So when I did the download I didn’t have a Meta  account some maybe delete it and try  again.  What do you have to lose?

Level 3

After the Meta account update my Rift S isn't working. I haven't played for 2 weeks, I come back to find that it's stuck at 3 dots. I've tried many different things to removing usb's, uninstalling and reinstalling the entire thing, deleting folders, device manager usb uninstalling. None of these fix this issue. I'm now just stuck at this. 


and when I put on my headset I still just receive 3 white dots and a black screen.