Showing results for 
Search instead for 
Did you mean: 

Emerging Issue - Unable to log into Oculus App after Meta Account Merge

Level 3



I am on Windows 10, I have an Oculus RiftS and the Oculus PC application.


I have just updated my Oculus account to a Meta account. 


When I log in to my Oculus app I get the message in the title: 

"You're using a version of this app that's no longer supported. Download the latest version to continue."


There's no download link and I don't know how to continue. I cannot use my Oculus Rift S at the moment.



383 REPLIES 383

This doesn’t work I tried it twice and it still won’t stop saying something went wrong

Level 4


This is what worked for me! Didn't need to redownload, just had to launch the setup utility:


1. Run OculusSetup.exe found in C:\Program Files\Oculus\

2. Click "Repair" (fourth option):



3. Let the tool download and install a fresh copy of the app

4. Open the app to find the new "Meta" sign-on screen, where you can login with your Meta account:


(If you've set up your Meta account disconnected from a Facebook account, then you'll need to use the "Log in with email" link underneath the "Set up account with email" button.)


After clicking that button, it opened up a page in my browser to login to my Meta account, which then was supposed to reopen the Oculus client... but the client didn't react to the login. However, closing and reopening the Oculus app after this process brought up my library, so the login was successful even though it didn't show at first, so I'm good to go now.


Meta/ Facebook/ Oculus really needs to get their act together with this, the rollout has been a mess.

I agree.  They should have sent out detailed instructions because everyone is having issues 

Level 2

Is there a solution yet?

Haven’t see one but got mine working finally 🙏

Level 2

I’m having the same issue with the mobile app. It won’t let me log in with anything but my Oculus account, but then it takes me to an internet browser to log in. The app still isn’t logged into my account, even though I just logged in to the browser it took me to. Every time I click anything but log in with Oculus, it says an error occurred. I can’t log in with Facebook, instagram, or my email. I can’t even access my account through the mobile app until it lets me log in. I was told to uninstall then reinstall the app. Didn’t work. I was then told to uninstall the app, reset my phone, then reinstall the app. It still hasn’t worked. I’m getting frustrated because I paid all this money for games, subscriptions, and the device itself, but I can’t even log into my account to play the games or cancel the subscriptions until I can use my Quest again. I don’t know why people decide to mess with something that works. 

I'm in the same boat. Meta doesn't seem to have a fix yet.

Dumb  question >. Do you need a mobile app to run your games on your headset?  I just use the games off my PC and don’t have the app except on the computer 

I need the app to set up my Quest 2.