Showing results for 
Search instead for 
Did you mean: 

Emerging Issue - Unable to log into Oculus App after Meta Account Merge

Level 3



I am on Windows 10, I have an Oculus RiftS and the Oculus PC application.


I have just updated my Oculus account to a Meta account. 


When I log in to my Oculus app I get the message in the title: 

"You're using a version of this app that's no longer supported. Download the latest version to continue."


There's no download link and I don't know how to continue. I cannot use my Oculus Rift S at the moment.



383 REPLIES 383

I have the same oculus app on my PC. Never changed it but has to repair the Meat/Facebook accounts for it to work again 

Level 4

I have Windows 11 and once I had to “upgrade” my headset software, issues started to occur but I never had a message about my Oculus app?

Level 2

Working as of today - they fixed on the back end. Try your app again.

It still says I need a firmware update. I can get to that first page, but then it says the second anyways.

Screenshot_20220919-184137_Meta Quest.jpgScreenshot_20220910-192809_Meta Quest.jpg

I did the factory reset

I tried that but after i put in my info it just brought me to a blank screen.


Sorry to hear than.  One thing I discovered is that I had to make the email address on both my Facebook and Meta  accounts to get it to work

Why the **bleep** did you guys kick me out of oculus so now my account does not work

First I’m not one of those “guys” and had issues like you


When did it start?

Level 2

Today I updated to v44 (for no other reason than to just update). Big mistake. I usually have my VPN open from All Sources while I go in and access YouTube or Games. The reason I have my VPN open is because I live in a country that does not allow for YouTube or Facebook. All worked fine until this new v44. What it does is shut down any open other apps in the background when running any other app/or game. Now I can’t run some games or apps as it shuts down my VPN app in the background. I wish I never updated now L. I should have left it at v43 L. Any suggestions anyone.