Showing results for 
Search instead for 
Did you mean: 

Emerging Issue - Unable to log into Oculus App after Meta Account Merge

Level 3



I am on Windows 10, I have an Oculus RiftS and the Oculus PC application.


I have just updated my Oculus account to a Meta account. 


When I log in to my Oculus app I get the message in the title: 

"You're using a version of this app that's no longer supported. Download the latest version to continue."


There's no download link and I don't know how to continue. I cannot use my Oculus Rift S at the moment.



383 REPLIES 383

Same issue with mine. I transferred the account without using Facebook. Once that issue popped up I tried repairing the software but still no luck.

Just found a semi fix for the issue. Logging in with an oculus account is currently broken but press "login with an email address" and it will open up a website. Logging into the website with your oculus account details let's you sign into the app/software. Hope this helps

Sweet, it worked! Thank you

Wait, that actually makes complete sense as a semi least, kind of sort of. 😅 I think that's (at least currently) basically the option to login with your new Meta account. Definitely sounds like it might not be super clear about it, but I think you figured it out! Thanks for sharing with the community! 👍

Make sure you smash that Kudos button!

I have just downloaded the oculus pc app for the first time. I type in my log in info and when I hit enter instead of sending me through a red notification pops up. It says "You're using a version of this app that's no longer supported. Download the latest version to continue." There's nowhere to update the app from and I downloaded it right from the site so it should already be functional. The official page that tells how to update the app says I must go into the app, go into the library, and update from there.

So I can't login without updating & I can't update until I login. I have deleted and redownloaded 5 times now. I have deleted, restarted my computer, and redownloaded once already via the instructions from the help line. nothing seems to work. All I wanna do is play steam exclusive vr games, but the app doesn't even function upon first use. I had to explain everything like 4 times to the person on the help line before they understood the situation and now we are moving to email communications rather than chat box.

Level 3



I got an email this morning saying I can migrate my Facebook account to a Meta account to use for VR.

I have got a Rift S, so naturally, after successfully completing the migration, I opened up the Oculus app on my Windows PC. I found that I was logged out, so I went to log in again.

No matter if I use the "Continue with Facebook" or "Have an Oculus account?" buttons, after typing in my account details, I get an error message saying:

"You're using a version of this app that's no longer supported. Download the latest version to continue."


I have tried:

  • restarting the app
  • restarting my pc
  • downloading OculusSetup.exe to repair the Oculus app
  • completely uninstalling the app, restarting my pc, then reinstalling the app

I always get this same error message.


What do I need to do in order to be able to log in so I can use my headset?


Looking forward to your response,






Here's another thread discussing the same issue.




edit 2:


Oculus support suggested I do the following:

1. Disconnect the Rift/Link cable from the computer.
2. Disconnect your computer from the internet.
3. Backup any necessary content.
* You can find steps on how to do so by [clicking here](
4. Reboot into Safe Mode.
5. Uninstall Oculus PC app using the Control Panel.
6. Delete all Oculus folders from the following folder:
* C:\Program Files
7. Remove any Oculus folders from the following locations:
* C:\Users\YourUserProfile\AppData
* C:\Users\YourUserProfile\AppData\Local
* C:\Users\YourUserProfile\AppData\LocalLow
* C:\Users\YourUserProfile\AppData\Roaming
* C:\OculusSetup-DownloadCache
8. Restart your computer in normal mode.
9. Reconnect your computer to the internet.
10. Install Oculus PC app again using the setup tool from our website [here](
11. Reconnect the Rift/Link cable and re-test the headset.

It didn't work for me, but it might be the solution for some of you.

I have the same issue. If you find a solution, would you please let us know how you fixed it?

I have the same problem. I migrated my account. Now nothing works, every login option eventually leads to a message that my Oculus app version is unsupported. I've tried to download the installer again and reinstalled it. It didn't help.

If I figure it out I'll send you another reply. This is dumb and shouldn't be happening in the first place.


I have the same issue.  Went on the Meta page for devices, downloaded the linked setup and it gave the same error message.  What a **bleep** up.


My assumption is that all we need is for a member of Meta to provide the CORRECT URL for us to download v43.