Showing results for 
Search instead for 
Did you mean: 

Emerging Issue - Unable to log into Oculus App after Meta Account Merge

Level 3



I am on Windows 10, I have an Oculus RiftS and the Oculus PC application.


I have just updated my Oculus account to a Meta account. 


When I log in to my Oculus app I get the message in the title: 

"You're using a version of this app that's no longer supported. Download the latest version to continue."


There's no download link and I don't know how to continue. I cannot use my Oculus Rift S at the moment.



383 REPLIES 383

Hopefully you had a screen shot of you setting before  you updated your VPN.  Some software updates change the settings, Meta did when I charge to it on Oculus so I suggest change them back to the original settings 

Thanks for a reply (I'm new to this). But I didn't do anything to update my VPN. I had Quest v43 and everything was running fine. Then I updated to v44. Now v44 stops any background app or program when running a game or even opening the YouTube app. No VPN running means no YouTube. And some games I have like 8 Ball or Liminal won't work unless I have on my VPN in the background (which is opened by Sidequest). So basically Quest apps close down anything from SideQuest in the background when a Quest app/game is running.  

<copy of email to Meta Store Support>


We updated to V44. Deleted existing Meta account and because it will take a month to clear, created a new Meta account with a new gmail address. The Oculus Windows app updated and seemed to run fine and we could log in with the new account.  Went to the Oculus app on the iPhone and tried to log in, failed! After entering address and password, the app simple returned to the login in screen with no error indication. So I still can’t enable my Quest 2. I tried logging in with Oculus address and with Email Address. Neither works. Tried to SideQuest but need to enable Developer mode before it will connect, which I can’t do because the phone app won’ let us log in.
I tried both blue-tooth and cable connection from computer to headset. Could there be an problem with the headset that causes the phone app to fail? 
I am truly disappointed and frustrated, and now angry that you sold my brother a $400 device that can’t be used. I guess we will return it to Amazon with a scathing review of both the device, and of Meta customer support, that while polite, has been completely unable to help.

I created a Meta account and used a new email address with it. Entered the 8 digit/character code on my PC, says accepted, but Oculus wouldn’t work.  It worked great with Facebook right?  


So I noticed mt Facebook and Meta accounts had different emails so i changed my Facebook email address so it was the same as my Meta  account.  Put my headset on the next day and got a message for a factory reset and it’s working fine now

Level 5

I dont know if its the same for the Rift, but i suspect you need to update the Rift Code to the latest version, as Quest 2 users we are getting RMA units back when ours develop a fault, they are being shipped with code V42, however the app for Oculus on iPhone and Apple is now only supporting V43/V44 onwards, so we can never get the app to pair with the headset, my link below works for Quest 2 on RMA units, I am wondering if maybe you need a new version of the code you can "Sideload" from a PC Android Debugger Bridge to upload the latest firmware. 
This problem with Q2, is causing major headaches for users with RMA replacements as Meta/Quest are saying its a server problem, but its not, its the fact the RMA units were not flash rom updated before shipping.

Problems pairing RMA Quest 2 to Mobile App - Solve... - Oculus Community - 989979 (

Level 4

Hey Chris-K,  We recently purchased a "new" Quest 2 and have never been able to get the iPhone Oculus app to allow a login. Thanks for your suggestion because we are beyond frustrated. I'll try the procdure at your link. Fingers crossed. I'll report back.  -Tom

Thanks Tom, if you need a zoom or chat using that method, drop me a private message

Chris-K,  No go.  Followed the 16 step instructions. The was V43. All seemed to go OK, but the iPhone Oculus app would not connect. Took userid and password, but then just returns to the login screen with no error info, or anything else that might point to the problem.  We're going to return the Quest 2 and them maybe get a new Quest and try again.  Thanks for your post. Seemed like it might be the solution, but not for us. -Tom

Do you have a Facebook and Meta account?

Golferaa, We created a new Meta account for the new Quest 2.  No Facebook account. Does this explain the inabiltity for the iPhone Oculus App to seemingly accept our login, but to then not connect to the headset, and not return any error info?  I see v46 is now out, but I can't find a download site. I was going to try that 16 step update process to see if that would work. Do you have a link to v46?  -Thanks, Tom