Showing results for 
Search instead for 
Did you mean: 

Emerging Issue - Unable to log into Oculus App after Meta Account Merge

Level 3



I am on Windows 10, I have an Oculus RiftS and the Oculus PC application.


I have just updated my Oculus account to a Meta account. 


When I log in to my Oculus app I get the message in the title: 

"You're using a version of this app that's no longer supported. Download the latest version to continue."


There's no download link and I don't know how to continue. I cannot use my Oculus Rift S at the moment.



383 REPLIES 383

Level 3

Same here. Replugged, rebooted, reinstalled but no cigar. Windows 10, quest 2 wired, trying to sign in with facebook account that was migrated to Meta account successfully this morning. 

This is not a solution and it shouldn't have a big green link on top of this forum leading to a thread saying, "we don't know either, do your own troubleshooting and report back!" No. No. No... this is a multi-billion dollar company. You can't tell me you didn't test this extensively. I now cannot connect my Quest 2 to my PC to play HL: Alyx or anything else with hi-fidelity. How about Meta fixes this, and fast. 


I personally tried downloading the setup from the Oculus site and used the repair function. It downloaded 5.16gbs and said it was all good. Same issue. I'm not doing any 10 step nonsense that someone posted in this thread because that is likely not going to work and also, not something we should have to do! Get your crap together people. 

Level 2


I made a Meta / Meta Horizon account from my Oculus account but now I can't connect to the Oculus appl, it tells me incorrect email address or password.
The password recovery doesn't work either because it says it's a Meta account, so it redirects me to the meta authentication where I can log in
I have already tried to reinstall the application but nothing works


Capture d’écran 2022-08-24 192702.png

Capture d’écran 2022-08-24 193548.png


That is the correct file, they just suck and don't care about the PC experience or branding at all. Leftover from when they acquired oculus basically. What I'm hoping is that they release a new meta PC launcher that fixes all issues but that's unlikely 

That option doesn't exist for me, already switched languages.... rip

when ever i try to log in to oculus through facebook it shows a message saying 'you're using a version of the app that's no longer supported. download the latest version to continue.

is there any way to fix this issue??

So basically this is the reason I needed to buy a Reverb G2. I have had only Oculus devices up to now (notable exception: Samsung Odissey), even my quest 2 is branded "oculus". I think they have done it this time, killed it. 


Hopefully this will be fixed. Let's not forget that this day has also seen one of the biggest fu**ups in the history of facebook with the VIP pages posts etc... I am sure resources have gone into that and this WILL be addressed when possible. It's just unfortunate that this sends a signal: PC VR is probably dead.


Level 4

Anyway, if it is of any benefit to anybody, this is what support emailed me:

  1. Disconnect the Rift/Link cable from the computer.
  2. Disconnect your computer from the internet.
  3. Backup any necessary content.
  4. Reboot into Safe Mode.
  5. Uninstall Oculus PC app using the Control Panel.
  6. Delete all Oculus folders from the following folder:
    • C:\Program Files
  7. Remove any Oculus folders from the following locations:
    • C:\Users\YourUserProfile\AppData
    • C:\Users\YourUserProfile\AppData\Local
    • C:\Users\YourUserProfile\AppData\LocalLow
    • C:\Users\YourUserProfile\AppData\Roaming
    • C:\OculusSetup-DownloadCache
  8. Restart your computer in normal mode.
  9. Reconnect your computer to the internet.
  10. Install Oculus PC app again using the setup tool from our website here.
  11. Reconnect the Rift/Link cable and re-test the headset.

    I will try and redo the whole thing, then I will be throwing the **bleep** thing out of the window. 

I really don't know what to write.......... This situation is beyond comprehension. Although I am not a great fan of Meta, I always thought that they were a professional organization, taking good care of their customers. Like all the other people responded here (probably only a minor fraction of all users affected), I have done what Meta asked from me, with the result that I cannot use my headset at all. There isn't even the possibility to roll back and use it with just my Facebook account....or is there?


Please resolve this issue

I have the same problem, it makes me crazy.

When I made a meta account... I got an email to do that.


Tried a lot