cancel
Showing results for 
Search instead for 
Did you mean: 

Error when running OculusSetup.exe in Windows 10

CarlosNolasco4
Level 2

Hi, I bought a Meta Quest 2 a couple of days ago and I wanted to connect it to my pc. But when I try to install the Meta Quest app by running OculusSetup.exe, I just can see the administrator permissions prompt, when I accept the request, nothing happens. I checked the Windows Event Viewer and got the next error:

System.BadImageFormatException
in System.Windows.Style..ctor()
in System.Windows.FrameworkElement.get_DefaultFocusVisualStyle()
in System.Windows.FrameworkElement..cctor()

There's also another event error which says:

Fault Module Name: KERNELBASE.dll, version: 10.0.19041.2311, timestamp: 0xa27d2a44
Exception Code: 0xe0434352
Exception Offset: 0x0012e092

I tried by running the sfc scan tool and the DISM restorehealth but still no success.

Could anybody please help me to solve this?

1 REPLY 1

MetaQuestSupport
Community Manager
Community Manager

Hey @CarlosNolasco4. We understand how you feel, set up should be easy. Please check that your PC build has a compatible GPU and CPU, you can see the minimum requirements with this link. If your PC is compatible and the issue still persists, please reach out to our chat support team so they can help you resolve this issue step-by-step in real time! You can connect with our chat support team here.