cancel
Showing results for 
Search instead for 
Did you mean: 

Extreme Air Link Lag

merxity
Honored Guest

I've recently tried air link with my pc and headset, but I'm always met with an extreme amount of lag. I have no apps open that can cause stress on to either devices, my router is in the same room as both, and I use my Quest 2 only a few feet from it. I use a medium-end computer, a NIVDIA Geforce RTX 3060 ti, and it has no problems running games. What is the problem and how can I fix it?

5 REPLIES 5

I am having the exact same issue. I used my Oculus Quest 2 with Air Link across 2023 without any issues. Same PC, Same connection, Same Router, everything is the same. My Pc is a HIGH end PC with a 3080 TI and a I7 from the last generation with 64 GB of Ram. When I am in the Oculus Quest 2 lobby I have no lag at all, lag only starts when I go to Air Link. 

I have tried everything, activating PTC, installing latest updates in both the app and the headset, changing the resolution and refresh rate, etc. Nothing helps. Everytime I enter Air Link its impossible to use, with almost 5 seconds delay in any input or mote. 

If I use my Quest Link cable it works perfectly. It's only with Air Link. I want to stress again that nothing has changed in my set up or connection and nothing is interfering with the Wi Fi. All other devices work fine and the problem happens even next to the router.

Update:

If you want to connect your PC just to play in Steam, use Steam Link. Used it and it works like a charm. Just some slight input lag, but at least its a partial fix kinda.


MetaQuestSupport
Community Manager
Community Manager

Hey there! Thank you for bringing this concern to our attention. We hate to hear that you're experiencing difficulties with airlink, as we want to make sure you have a smooth PCVR adventure. Don't worry, we're here to help.

First off, we'd appreciate it if you could provide us with some details so we can investigate further:

To start, we'd like to gather a few details from you so that we can take a further look into this for you:

  • When did you first start to notice this?
  • Have you tried rebooting your headset by turning it off and turning it back on?
  • Have you tried repairing airlink by: Navigate to the Settings menu, Ensure "Air Link" is disabled/toggled off?

We'll be looking forward to hearing back from you on this.

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

MetaQuestSupport
Community Manager
Community Manager

Hello! It seems like it's been a while since we last heard from you, and we just wanted to check in and see if there's anything else we can assist you with. If you still need any help, please don't hesitate to reach out to us. We're always happy help!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

negativghostrdr
Explorer

I have the same issue and have arrived at the same conclusion.  Use Steam Link.

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?