Showing results for 
Search instead for 
Did you mean: 

[FIXED] Oculus Link - Loading Sign before returning to Oculus Home


Solution: I freaking rolled back my Nvidia drivers and it solved the problem.

This is a new issue after a few weeks of using Oculus Link without any problems.

Upon trying to load through Link, the headset goes into the black loading screen with three dots. After about 15 seconds, it returns straight back to the Oculus Quest Home screen without any errors. After this, both my PC and Quest headset act as if I've reconnected the link cable -- whereas my computer pops up with a "Can't Find Device" and my headset displaying an "Oculus Link Available in Settings" message subsequently. The same behavior results from using Air Link.

My equipment:
HP Omen 15 Laptop (Ryzen 5 4600h, GTX 1660 Ti, 16gb RAM)
Oculus PC Software - On version
Oculus Quest 2 - On version
PartyLink Cable

What I've tried so far:
Restarting PC and Quest 2 multiple times
Trying builds v30 and v31
Reinstalling the entire Oculus PC Software
All Refresh Rate options
Air Link
2 Different Link Cables

Ideas that I've found from other posts with similar issues:
Downgrading my Quest 2 firmware to match my PC's Oculus Version
A whole entire clean install of Windows

Where I think the issue might be:
Oculus v30 updates were dropped
My PC's bios was updated
I updated to Windows build 21H1
I updated my Nvidia Game Ready drivers
The versions between my PC and Quest are different (refer to above).

So there are quite a few places this issue could lie.



I had this after the V30 update. Turns out it was the 120 hz mode enable. I had it enabled on the oculus app on PC, but hadnt had it enable under experimental features on my quest 2. Enabled that and it worked fine. Hope this helps

Hey! Funnily enough, I actually encountered that issue about a week back. I've made sure that both ends have 120hz off.


Ahh sorry only just seen it said you tried the refresh rates. Mine connects fine, but im having another infuriating issue. It keeps losing tracking and guardian. I cant even play a game anymore as its every 20 seconds it loses is and returns to trying to create new guardian. Its only happened since v30 so its evidently a software issue but support have been useless

No worries! Reading through the v30 megathread on Reddit, I would be inclined to agree. I'm seeing a lot of complaints about network connectivity and guardian issues.

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?