cancel
Showing results for 
Search instead for 
Did you mean: 

[FIXED] Quest 2 PC Link Black Screen (But Audio and Desktop Mirror work)

Aussywoo
Level 3

My equipment:
HP Omen 15 Laptop (Ryzen 5 4600h, GTX 1660 Ti, 16gb RAM)
Oculus Quest 2
Included Charging Cable as a Link Cable (I am aware that it is a USB 2.0 connection -- I'm only testing at the moment)

Here's what's functioning:
Upon confirming that I want to run Oculus Link, the Oculus software does indeed open on my desktop. Checking in the devices section tells me that both controllers along with the headset are connected, though a USB 3.0 connection is recommended.

Here's what's not functioning:
The headset display itself doesn't display anything besides an occasional loading sign along with the guardian boundary warnings (since the charging cable only allows me to hover near my desk). I decided to open VRChat via the Oculus software to see what would happen. Opening the game doesn't display any errors. In fact, when I move my headset around, I can see my desktop version moving around along with the controllers. Sound does come through the Quest with no issues. The display continues its habit of showing the occasional loading sign.

I decided to try with the SteamVR version of VRChat. The results are a bit worse and confusing. In all scenarios, the VRChat client loads up frozen on the menu screen (though it is sometimes tilted as if my headset was tilted). The SteamVR window displays one of two things on any given occasion. The first, and most common, is where it shows the headset and two controllers connected, but has an error message above it stating there is a problem preventing it from working correctly. The second scenario simply shows no errors but still remains frozen.

Note: I opened both VRChat versions through my actual monitor.

Here's what I know:

  1. My laptop is capable and supports running VR
  2. Both my USB Type A and C are 3.0 and backwards compatible.

Here's what I've tried (in no particular order):

  • Restarting my PC
  • Restarting my Quest 2
  • Restarting the Software
  • Updating my graphics drivers
  • Using Nvidia Control Panel and setting Oculus Dash and other processes to use my dedicated graphics card
  • Trying a different cable (USB A to C through USB 2.0)

Here's what I have not tried, but plan to (in order):

  1. Reinstall the Oculus Software
  2. Reinstall my USB Drivers
  3. Factory reset my headset
  4. Buy an alternative Oculus Link Cable
  5. Give up

What I need help with:
Based on reading through other posts with similar issues, my guess is that there isn't just one known fix that should work. However, I would like some guidance on what to try or modify first. I just want to play Beatsaber.

Appreciate any help I can get!
Aus

Temporary Workaround (12/7/2020): Upon watching a video on the topic, I found out that my issue was caused by some sort of oversight/bug through Oculus Link's graphics recognition. Hybrid graphics cards setups (like in most gaming laptops), where some processes run on the dedicated card while others run on integrated graphics, cause Oculus to freak out and die. Going into the Device Manager and disabling the integrated GPU under Display Adapters fixed a lot of issues (after a restart). This came with the disadvantage that my laptop is now stuck at the lowest brightness because it now thinks that I'm using an external monitor.


Upon starting up Link and all that jazz, my Quest finally started outputting -- with ZERO LAG! What didn't have zero lag were all the games I tried playing though. VRChat, from the very beginning, had framerates of around 2 per second. Google Earth refused to start at all. Minecraft got a bit further, showing a zero-lag loading screen but then getting stuck at a red screen while eating up 50% of my CPU power.

After a bit more research, I found that if AMD is involved in any way (like my setup is) then Oculus will have further issues as well. What this tells me is that Oculus Link hasn't really been optimized for anything other than an Intel/GTX build. I've had friends with AMD processors that have had no issues, but it looks like a good chunk of people run into similar problems as me.

I'm unable to post links at this time, but the video I mentioned, by Sergeant Nathan, is titled "Oculus Link Black Screen Workaround".


FINAL UPDATE (12/16/20): My issues have been completely fixed, thanks to a suggestion sent in by a reply. A video titled "FIX OCULUS LINK/RIFT PROBLEMS on GAMING LAPTOPS - AMD/NVIDIA iGPU dGPU (Black Screen Issue) Quest 2." suggested that users with a similar hybrid GPU setup to mine use Window's direct graphics settings to change all Oculus files to "High Performance" instead of Nvidia's control panel. Highly recommend checking the video out.

12 REPLIES 12

Hey AkironQc, I understand you're having issues when linking your Quest 2 device with your PC. We know playing PC VR games on your Quest 2 is a great experience so let's try and get this resolved for you! 

 

Before performing any troubleshooting steps you should confirm your Quest 2 device works untethered to your PC - try playing a Quest 2 game without your Oculus Link to confirm everything plays as it should. Next, please check our Oculus Link compatibility - if your system isn't supported we cannot guarantee compatibility. Once you've confirmed your system is compatible use this support page to connect your Quest to your PC.  

 

If you're still getting a black screen on your Quest device you should consider resetting your graphic settings to default. You can find instructions for that here

 

Let us know if that resolves your issue or feel free to reach out to our excellent support team for additional help! 

I tried it but it didn't seem to work 😕

Hello MartTheDominator, we noticed that you are experiencing black screen issues upon utilizing troubleshooting steps. We understand how disappointing this can be. Rest assured, we're here to help! So that we can look into this matter further, please collect your Oculus logs. To collect your Oculus logs, you may click here and submit them to us in a support ticket by clicking here

 

We are always glad to help! 🙂