cancel
Showing results for 
Search instead for 
Did you mean: 

Fix for Sensor Disconnection Issue

cybereality
Level 15
We've just started rolling out a possible fix for the repeated sensor disconnection issue. This is a problem that could cause the sensor to disconnect while idle on certain hardware configurations. Although we had some trouble reproducing the exact problem in our lab, we have a good idea of what the core issue was and believe it may be resolved.

Some customers have already received the update, and everyone else should have it within a few hours. The update should happen automatically, but you'll have to just unplug and replug the sensor to reset its state.

I'd recommend people wait until later this evening to test and see if the fix actually resolves their issue. Either way, please report back so we can understand if the fix was a success. Thanks.
AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
304 REPLIES 304

XMerc
Level 5
Highly recommend those that have tried everything try the card and driver/firmware update that I did. I'm almost 3 hours now with zero disconnects and everything working perfectly now. 

scstudios
Level 2

When I unplugged the xbox controller it seemed to help.  The update didn't help me at all.

UnFknBLievable
Level 5
Call me ignorant, but I refuse to spend money on extra hardware to get a plug' play device that worked flawlessly to begin with to work even remotely correctly after software updates.

Any hardware fixes is on oculus as far as I'm concerned. I didn't blow $1200 just to spend more money to fix it.

Fix the software.

gokoolfl
Level 2
@XMerc

So still a solid fix for you so far?

XMerc
Level 5
@gokoolfl 

Yes. For some reason only 1 of the two USB 3.1 ports are working with the Oculus though, when the other port is used by Oculus Windows loses the card all together and I have to restart with the Oculus using only 1 port. So I have the sensor going into the Unitek card and it works great. Then I have my head unit going into a 3.0 port on my Inateck card. With this setup everything seems to be working fine and I get zero disconnect issues. Only side effect as noted is the Oculus can't determine what type of USB the Unitek 3.1 card is and omits listing anything. 

Hornet_F4C
Level 5

XMerc said:

Highly recommend those that have tried everything try the card and driver/firmware update that I did. I'm almost 3 hours now with zero disconnects and everything working perfectly now. 



Hi! Glad it seems to work for you.

Sadly though, your solution is not likely to fit for others as well. With all the things you did, it seems more like a lucky co-incidence that you reached a state where it momentarily works. Yet it is still not fully right as the Oculus device tab should show all devices connected as USB 3.0 which it doesnt do for you.

My story is similar to yours. After having suffered from sporadic headset/hdmi disconnects I updated Fresco (PCI Card) and ASMedia (Onboard) usb drivers and after that was able to run the headset from the onboard usb and the sensore from the PCI card with everything showing up as USB 3.0 and no visible disconnects ever since (god knows what's being logged in eventviewer and logfiles, but from a users point of view, everything is fine).

Until recently where I had a single particular app that gave me constant sensor disconnects which I never had expierenced before. I uninstalled it and be done with it. Everything else still is running fine. But inspecting the logs I could also find ealier sensor errors not connected to this particular app, they just dont seem to affect other apps not in the same way and also seem to occur much less often.

My point is, currently there is no solid solution. It is like a house of cards. Some find their way to get it stable but you cant put much trust into it.

Cheers

Hornet_F4C
Level 5

@cybereality

I for myself found a few sensor errors (Hardware health is bad)  in the logs that seemed to have went by unnoticed. I am not 100% sure on that, I'll have to keep monitoring, but If that is generally possible there might be  quite a large number of unkown cases. That poses a high risk  as these problems can exacerbate anytime to the point of making the rift unusuable.

Since the Oculus runtime is already transmitting data about the headset usage to Oculus, wouldn't it be possible to include error statistics in this information? Everytime an error is logged it should be transmitted to Oculus for statistic purposes to determine the real extend of the problem.

If the sensor "Hardware health is bad" error is on the top of the list because it virtually occurs for each and every user (unnoticed or not), that would certainly be an interesting information.

Maybe this is done already. I assume those numbers wouldnt be for public discussion then 🙂

greets!

Hornet_F4C
Level 5

One more thing:

The "Hardware health is bad" message seemingly can be found in virtually every case of sensor disconnect logfiles. In the meantime at least a handful of these cases could be solved by other means than hardware replacements (drivers, wifi adaptors, changing usb ports, rolling back updates, etc.).

That means this message is to take with a grain of salt. Maybe it should even be changed as it doesn't serve the purpose it was invented for. Obviously the software is unable to monitor the hardware health status as it is producing this message for perfectly good hardware, too.

That doesn't make things easier for support.

I really appreciate your efforts to stay in contact with the people here, trying to help.

Thanks!

XlordB
Level 5
well guys ive been going for 3 days solid now no disconnects.. windows 10 home NON ANNIVERSARY VERSION UPDATE. just try it.. but listen i have an intel chipset board running no motherboard software updates from my site only the miscrosoft update drivers... also clean installed nvidias latest driver. i been literally able to play anything in rift with no disconnects since i redid that install without upgrading to anniversary.  I have a asus z97-a motherboard but as i said i didnt need any motherboard drivers.. as microsoft update without updating to anniversary provides everything the system needs. also just so im completeley honest the only time ive had any disconnect and we are talking like 2 of them was if i start the system up and dont touch the rift at all but im sure thats just because the system can power off when not used. But the catch to that is they dont continually disconnect reconnect they just work as they should i.e firing up when used powering down when not. 😉

Hornet_F4C
Level 5

XlordB said:

only time ive had any disconnect and we are talking like 2 of them was if i start the system up and dont touch the rift


Well, while great that your rift eventually is usable for you at least, of course that sounds like a somewhat imperfect solutuion still.

Also in another post @cybereality recommended to use the manufacturer drivers with regards to Fresco and AsMedia, not the Microsoft ones.

In any case this Win 10 anniversary update might have something to do with it, albeit it won't help the win 7 folks while at the same time the rift is working with that update for others.

However - congrats it now works for you to a usable extend! 🙂

Enjoy it!