cancel
Showing results for 
Search instead for 
Did you mean: 

Frequent micro stuttering in Meta Quest 3

Angelina72200
Explorer
Hello,
 
I've owned a Meta Quest 3 for a few days now. Since yesterday, I've noticed a "micro stuterring" problem that appears when I use the headset in standalone mode.
 
This is the same problem described by pan.c.kaplanis and Renegade_R in this topic (see page 2 and following) : https://communityforums.atmeta.com/t5/VR-Experiences/Some-Quest-3-standalone-games-are-lagging-stutt...
Nevertheless, I'm making a new topic because the previous one was initially about Beat Saber (but it's been diverted to Home), and because the problem is marked "Solved" whereas it's not solved at all in my case.

 

Problem description:
In the Home application and standalone games, at certain moments, for example when I crouch or strafe from right to left, "micro stutters" appear. This is very visible on the Home application interface, but you can see it by looking at the background too. It's as if for a very short moment (1 frame) the position of the headset shifts, giving the impression that the image is hopping, before returning to its initial position. It happens very quickly, and the shift is not huge. Nevertheless, the repetition of the phenomenon makes it noticeable.
 
The problem appears when I crouch or strafe to the sides. It doesn't appear every time I do these movements, but it happens regularly. I have the impression that micro stutters appear more often when I'm pointing at something with the controller, and/or when the boundary walls are displayed. The problem is extremely noticeable on nearby objects, but it also affects distant scenery. Unfortunately, when recording video, the problem simply doesn't appear, or appears too subtly. In any case, I'm not able to perceive it on video.
 
I'm convinced that this problem wasn't present 3 days ago when I unpacked my helmet. I think it appeared with upgrade v59 as I found other reports of stuterring appearing at that time. I'm now on upgrade v60 but the problem persists. It's annoying because using the headset is generally smooth, but these micro stutters are so recurrent that they're ruining my life in Quest 3.
 
Incidentally, I have the impression that the problem is also present in PCVR with the Link cable. I have the impression of seeing these micro stutters when I crouch in Half Life Alyx. But here I'm less sure, because I know that in PCVR, problems can come from many places.
 
I really hope that an origin for this problem can be found, as all the posts I see on the net suggest that the problem appeared with update v59 and hasn't been fixed since. I can hardly use the headset at the moment, as this problem is really getting on my nerves.
1 ACCEPTED SOLUTION

Accepted Solutions

Angelina72200
Explorer
Hello,
 
It's been a while since I posted an update on this topic.
It's been a long time coming, but I've managed to get rid of my micro stuttering problem completely.
I'll describe how I did it.
 
First of all, you have to understand that in my initial message, I thought I was dealing with a single problem, whereas technically I had two:
- Stuttering when the Meta Quest 3 headset is used standalone;
- stuttering when I use it in "PCVR" mode (connected to the PC via wifi).
 
About the stuttering on the standalone headset: the problem simply solved itself with the arrival of the V60 update. With this update, all the stuttering I was seeing in the headset menu is gone.
 
That left stuttering in PC-connected mode ("PCVR"). This stuttering had nothing to do with the other one, even if the symptoms were exactly the same.
To fix the PC stuttering, I had to buy a new Wifi router corresponding to the "Wifi 6" standard. I'm now using an "Asus RT-AX57" router.
With this new router, the situation improved immediately. However, it wasn't enough; I continued to suffer from stuttering, albeit to a lesser extent.
To eliminate the problem once and for all, I had to start using the "Virtual Desktop" software instead of the "Airlink" software included with the headset. My PCVR performance under Virtual Desktop is light years ahead of what I get with Airlink. Even without having set anything up, I immediately noticed that the stuttering was completely gone with Virtual Desktop.
 
In summary, here's what you should try to do to eliminate stuttering in PCVR mode:
- Update your Meta Quest 3 headset;
- Buy a new Wifi router if your current one doesn't meet the Wifi 6 standard (you need a router running at 5 Ghz, 2.4 Ghz isn't enough);
- Use Virtual Desktop software from your headset, instead of Airlink (you have to buy this software from the Oculus Store).
 
I hope this message helps some of you.

View solution in original post

11 REPLIES 11

Occupunk
Heroic Explorer

I don't have beat saber unfortunately, so can't compare, but my feeling was that the frame dropping was due to other things going on in a game. When the stutter consistently happens at the same time, I would think that there are other things consistently happening at the time as well. I had believed in the past that starting a new sound playing was one of the things that could cause a stutter. So striking an object or shooting pistol, whatever, if it caused a new sound to be played, it could cause stutter. Sound of course is only one example. Reading something from flash could be another. It could be just about anything.

I'm guessing all these apps make use of meta API calls to do most things, so a game might start having issues even though the game itself was not updated. So playing sounds may be fine in a game with one version of the quest OS and cause a stutter in the next version (just guessing, but I'll bet I'm close).

It is a difficult problem because the game developer has little control over it, and meta can't debug every issue with every game on every update they make. Fingers crossed that it is something obvious that they can fix.

For the record, I was really surprised by the quest 3. I thought I was going to see a marked quality increase to things like frames dropping in games when compared to the quest 2, but when I first fired up the 3, I instead found that it stuttered just as much in the same games as the quest 2 did. I wonder where all the extra processor power is going ...

To be honest, the more I think about it, the more I think it might not even be stuttering.
 
I used this word, but I believe that stuttering implies that the image freezes for a very short time.
 
Here, in my case, I have the impression that technically the image doesn't freeze. It just seems that for one or two frames, the position of objects changes and they seem to "jump".
 
Here's an animation made by pan.c.kaplanis on the other topic that illustrates what I'm seeing on Home. 
 
 
You just have to realize that the hopping frequency is less strong and seems to be triggered by specific movements (turning around the menu while looking at it closely, crouching ...).
 
Is it possible to tell whether this is really stuttering? On other topics I see that people have access to tools to monitor the performance of their headset, but I don't know any more.

Hey there, @Angelina72200, and thank you for reaching out to the community with this issue! We can absolutely see how a "jitter" or "stutter" like you are experiencing could be very disrupting, reset assured we'll be happy to work with you to find a resolution! Graphics issues like these can have many root causes, but there are some basic troubleshooting steps that can resolve many of them:

 

  • Remove any unsupported third-party accessories that may affect boot (such as external battery packs, accessories that plug into the USB-C port, etc.)
  • Hold down the power button and volume down button for 30 seconds until you hear the boot-up sound
  • If the boot-up sound is not heard:
    • Hold the power and volume (-) button down simultaneously until the boot screen loads on your headset.
    • Use the volume buttons on your headset to highlight "Boot Device" and press the power button.
    • Use the volume buttons on your headset to highlight Yes and press the power button.

 

If the issue is still persistent, reach back out to us with a private message so we can dig into this deeper with you. To private message us just select our name to get to our profile page, or click HERE. Next, click "Send a Message" and we'll be replying soon! Please remember, you must be signed into the community first to send us a private message. Let us know the results when you can! Happy holidays!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

African_Duck
Honored Guest

Hey, did you ever figure out the source of your problem? I too started noticing objects kind of jittering around when turning my head. A few of the scenarios I've noticed are:

  • The universal menu or anything in a high contrast scenario. When I was facing a really bright direct sunlight window. Some thin sheer curtains were drawn and the blinds were closed but it still left really bright diffused light. The curtains would glow white and would surely be clipping in a camera. In this scenario the universal menu (among other things) would jump around a lot when turning my head. Facing away from the window fixed that particular issue.
  • I had a room setup with furniture, wall art, etc. Later when I came back the boundary was all off and I redid the boundary. The room stuff was still there but all out of place now. It seems like clearing the room data reduced a lot of stuttering.
  • I still get some jitters/stutters/micro jumping around here and there. It doesn't happen every time but usually happens when the universal menu loads for the first time and I move my head around, when I have "Glanceable Boundary" turned on and I glance down to illuminate it, and during games when "things happen" scene change, lots of sudden movements of things, etc.

Hi there, @African_Duck. We certainly don't want microstutters or lagging to stop you from enjoying all that the VR world has to offer. Could you please make sure that you are using the latest version of Quest software available? We have shared the steps to make sure your device is up-to-date HERE. Additionally, you can find out what the latest version is by going to the link shared HERE

 

If you are still having the issue, please let us know, and we would be more than happy to continue working with you to find a resolution. Please keep us posted on your progress! Thank you for your time, and we hope to hear from you soon.

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Hello again @African_Duck! Just wanted to check if you had a chance to take a look at the links we shared with you about your micro stutters. If you still need assistance, please feel free to let us know. We're excited to hear from you!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

ballhead4
Honored Guest

I am also experiencing this exact issue using version 60.0 on my Quest 3. It is most noticeable on the universal menu but is also slightly noticeable on the virtual environment and in some standalone games. It is extremely noticeable on close-up objects when I stream PCVR games wirelessly, through any of the PCVR streaming apps (Steam Link, Air Link, or Virtual Desktop).

It is like a kind of rubber band effect on 3D objects in the game space. The objects seem to skip a frame when moving the headset side to side, and then instantly snap back in place. I tried recording the phenomenon, but it doesn't appear at all in the recording for some reason.

Hello, @ballhead4, we see you are having the same issues with stuttering. High quality visuals are pretty important for VR both on PC VR and standalone. We would love to see how we can help!

Please try turning off the Wi-Fi on your Quest 3, and playing a game offline. If the stuttering continues, please enable Wi-Fi, Clear your guardian history, and then restart your Quest 3 headset before checking once more.

Let us know how that goes, and if anything changes! We would love to review further, and we have a few more ideas to look at. We look forward to hearing from you soon!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

African_Duck
Honored Guest

I've been updated to the latest the whole time. Mine kind of stopped doing it though. A little jitter/stutter here and there but nothing like the height of the issue. I'm not really sure why. 

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?