cancel
Showing results for 
Search instead for 
Did you mean: 

GAMES WON'T UPDATE

thickbeard
Level 3
I have a reoccuring problem of games needing an update, but it won't install the update. It downloads the update file, but once it goes into install mode it cancels. I click the update button again, same thing, it downloads the file but cancels on install. 

I just reinstalled Oculus. Still won't work. This happened to me a couple months ago and I deleted everything on my computer and reinstalled oculus to get it to work. I really don't want to do that again. 
38 REPLIES 38

MetaQuestSupport
Community Manager
Community Manager

Het thickbeard, have
you tried disabling any anti-virus software (including Windows
Defender) and see if the games will update? Also, please make sure
that you running the Oculus software as an administrator. If you
haven't already, please contact support at
https://support.oculus.com/
and provide your Oculus diagnostic logs so we can help you out.
Instructions on collecting logs are available here
https://support.oculus.com/172672339980954/
. Thanks! -Rick

thickbeard
Level 3
Sure have. And today, once again there's an update to my games and I'm back where I started. Almost every single time there is an update I have to delete everything and start all over. 

Devilstower
Level 5
I'm in the same position. Most of my games and apps will update just fine but three of them -- OrbusVR, Amaze, and Elite Dangerous -- have refused to update over and over again.

I've turned off the virus software and all firewalls.
I've confirmed that I'm logged in on an admin account with authorization to update anything.

Other apps download and install fine. But these three, no matter how many times I try, do the same thing. They download to 100 percent, hit the beginning of install, and then fail with the only message being "Sorry, we couldn't install XXX. Visit Oculus support to get help."

I previously had this issue with Elite: Dangerous and tried deleting files and directories, reinstalling the whole game, reinstalling the entire Oculus set up. I literally ended up starting my entire system over from scratch to get that one game working. And now it's not working again, even though dozens of other apps update just fine.

HansGold58
Level 2
Same here: Amaze, Elite, Pokerstars and Virtual Desktop are the ones that I have in my library and they will not update. Downloading seems to work fine, but installation fails. Tried all the above things to no avail. I am now waiting for an update of the Oculus software, hope they recognize and solve this. Must be a lot of folks having this problem.

FrontierSupport
Level 6
Hey folks, 

If you're having issues installing Elite Dangerous (and by extension other games also) it may be worth reinstalling Oculus itself and then giving it another go.

-CMDR Vulcan

Anonymous
Not applicable
Any luck? There was a similar Win Security Update that did this but I can't trace it. I got 4 Games stuck. Here's what I think happened to me:
I use a HDMI>DP adapter on either CV1 or Rift (not matters) but when I installed a Soundcard for Music DAW (a 1x in the 8x Slot) it prevented booting into Windows randomly. So I figured it needed the 1x Slot only and was drawing full Watts regardless. Another User posted that their USB card did the same until they used the 1x yet feared the proximity to GPU fans and air restriction but it worked. I'm bothered it may curtail the life of my DAW Card!
Anyways, these crashes made Drive errors and needed Scan&Repair for both OS SSD and the Games Hybrid Drive. Before repair I couldn't even delete the games to try reinstall them. Of the 1 I did when repaired, it now can't Download!
I think that part is due to me installing Oculus without AV=OFF. I did a repair but some files did not seem to be deleted and the repair was odd and warned me of no access to even the C: Drive Folder even though I had selected 😧 only. It plays the other games ok and I can start any game that is Pending Update manually in their folder by exe and they run.
Trying again soon with a fresh 3rd OS install on this new PC! It will need secondary Drives added after OS and the Auto Update I know may add that bad Security Update!

Genericat
Level 5
Having the same issues. Anyone find the solution?

Anonymous
Not applicable
I haven't managed to find it yet even though I tried on 2 occasions. However, Support also mentioned other option to try Creating another USER MS ACCOUNT and although I think that will work, I don't know if it is a simple matter to then transfer all progs permissions via any Renaming or just Deleting the broken User Account. I'll get around to it. I had this before on a Drive I considered was failing so just bought another Drive! Best of luck.

Worm777
Level 3
I just got hit with this today. 5 games wont update.