Showing results for 
Search instead for 
Did you mean: 

Gaming Laptop PCVR Latency RTX 3080

I am having issues with my Meta Quest2 in PCVR - while using either airlink or Link cable or even virtual desktop. 
this is not a network issue as i have tried with link cable, with 3.2 usb and a bandwidth resuly of 2.3-2.7 gigs
the issue is latency intervals every 1 second.
I have isolated it to the two point of interest. Using the debug tool I can disable PC Async spacewarp and adaptive gpu scale and the lag does not happen. but at some point, usually within a minute or two, they start automatically and the lag occurs again. about every second bewteen spikes
This issue does not occur with my Pico Neo3, Valve Index or Reverb G2. only with the Quest2.
ROG Zephyrus Duo 15se GX551QS
BIOS GX551QS.405
Processor AMD Ryzen 9 5980hx 3.3ghz
GPU Nvidea RTX 3080 Laptop 16vram 16shared
amd internal graphics processor
32 gig of ram
windows 11 version and all driver versions are latest and up to date.
I have reinstalled all Meta Oculus applications, and have also done a complete reinstall of the laptop, the issue persists. 
Nvidea control pannel has been adjusted to also specifically use the high powered nvide GPU, power setting is set to performance as well for redundancy.
all additional asus etc applications have been dissabled or set to use manual settings. 

Community Manager
Community Manager

Thank you for letting us know about this issue @white_Rabbit13x. We hate the fact that you are experiencing this issue. We want to do our best to help, so let's start with uninstalling all the app data on the computer. If you can please, try the following for good measure.

Can you please attempt the following:

  • Disconnect the Link cable from the computer.
  • Disconnect your computer from the internet.
  • Backup any necessary content.
    • You can find steps on how to do so by clicking here.
  • Reboot into Safe Mode.
    • You can find steps on how to do so by clicking here.
  • Uninstall the Oculus PC app using the Control Panel.
    • You can find steps on how to do so by clicking here.
  • Delete all Oculus folders from the following folder:
    • C:\Program Files
  • Remove any Oculus folders from the following locations:
    • C:\Users\YourUserProfile\AppData
    • C:\Users\YourUserProfile\AppData\Local
    • C:\Users\YourUserProfile\AppData\LocalLow
    • C:\Users\YourUserProfile\AppData\Roaming
    • C:\OculusSetup-DownloadCache
      • Note: The AppData folder is usually hidden. Use these steps to access AppData.
      • Press Windows key + R to launch the Run dialog window.
      • Type %AppData% in the Run box and click OK or press Enter
      • File Explorer will launch to the AppData\Roaming subfolder.
      • Click AppData in the File Explorer address bar to show all three subfolders in the AppData location.
  • Restart your computer in normal mode.
  • Reconnect your computer to the internet.
  • Install the Oculus PC app again using the setup tool from our website here.
  • Reconnect the Link cable and re-test the headset.


Let us know how this goes, we'll be here ready to assist you.

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Hey yeah just tried this DOESNT WORK. This is the 3rd time this month this has happened. All previous methods dont work even the developer mode isnt working.

Yes I already stated above that I have tried this, I have already tried all the typical copy paste solutions that are given on this forum and they haven't worked. Please provide additional support.

Hey @White_Rabbit_VR! Thank you for providing that clarifying information. We appreciate you clarifying you have tried those trouble shooting steps! We do have some follow up questions in order to further assist you. 

Just to further isolate the issue, could you please provide the following:


  • When was the last time you were able to use PCVR (link or airlink) successfully?
  • Are there any kinks, damages, frays to the cable itself?
  • If you are given any error messages, what do they say?
  • Is your headset fully up to date?

We hope to hear back from you to narrow down this issue and work together towards a resolution!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

On this Laptop I have not been able to successfully use airlink or link cable without the latency, using my whole desktop PC with RTX3090 etc has worked fine. but not with the RTX3080 Laptop GPU. 
There is no damage to the cable, I have even purhcased a new one to make sure of that. 

no error messages, but you can visibly see the lag spikes in dev displays. 

headset and all PC divers are up to date

Thank you for the update. If you're still experiencing some latency, try checking Nvidia's website for the latest game-ready drivers; you'll be able to cross-reference and see if they match your current ones. While using the link cable check to see if you have more than one location you can try plugging your link cable up to, you'll want to make sure it's a USB 3.0 port as well. If you're still having trouble, we'll need to get a better look at your PC.

Please send us a private message, and we'll be happy to assist you further. In order to PM us, all you need to do is select our name to get to our profile page, or click here. Next, click "Send a Message" to privately message us! Please remember that you must be signed in to the community first to send us a private message. We look forward to hearing from you.

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!
Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?