Showing results for 
Search instead for 
Did you mean: 

HDMI and Headset USB keep disconnecting every few seconds

Honored Guest
I just recieved my CV1 after using the DK2 for quite some time. Hours of trouble shooting and trolling about these forums, reddit, etc and I'm at the point I'm not sure what else to do. 

What's happening is during the setup process of my new device (in the Oculus software) I reach the step "Connect your rift headset and oculus sensors" Everything gets checked off green for a few seconds then the headset changes to a loading icon, rinse and repeat. (attempting to just go next results in a "there was a problem" esk message whenever the headset drops. After a minute or so of connecting / disconnecting it eventually gives up and just stays disconnected.

I've already tried updating what drivers I could come up with (Video, USB, etc) rebooting, Windows Update, Updating Oculus to the latest beta, uninstalling oculus and reinstalling it, uninstalling a variety of drivers and reinstalling them. digging into power management configurations, swapping to every imaginable combination of USB ports (both 2.0 and 3.0) Going with no adapters, trying adapters, trying HDMI straight, adapting HDMI to Display, etc. Nothing seems to have made any form of meaningful impact on the situation with the CV1 (my sanity may have been meaningfully impacted during this process)

I have also tried reseating all of the cables (on both the headset itself and the appropriate ports, At this point I'm grasping for straws, I am absolutely seeing things in the logs that might help, but I think any ability to concentrate left me hours ago, so please if anyone can help I'd greatly appriciate it.

Honored Guest
Also here's some sweet sweet log goodness, I just know you're stoked to just tear into these fresh off the C drive logs!

Honored Guest
Update: disconnected all non-critical devices, Updated BIOS, fully reinstalled windows, updated all drivers, installed oculus, rebooted, plugged in oculus, problem persists :(. (Note: I didn't plan to reinstall EVERYTHING when I did the BIOS update Windows stopped working so had to go through and start over, but now everything is up to date, still no luck)

Honored Guest
also, new fresh after windows reinstall logs. 

Expert Consultant
Open a support ticket.  My rift is currently in transit on an RMA.  It was having HDMI disconnects constantly.  I was always able to get passed setup, but it would randomly disconnect and progressively got worse as time went on.  It took a while because I didn't respond right away to every email, but Support responded to me right away.  I think your rift is Defective personally, so I would start the ticket and when nothing works they'll probably just have you RMA yours.  Depending of course on where and how you bought it in the first place.

Honored Guest
I bought it from Oculus directly here, I'm currently working through support though no luck. (No complaints on response time thus far, seems to take at least a few hours to get a response, but that's actually a pretty good turn around) I'm still tinkering a great deal on my side just incase I can figure something out. (As a software developer with a background in IT, I'm really bad at just leaving things for others to solve)

Honored Guest
Update: I think we've nailed the cause of my issues. There was a bent pin in my HDMI cable that plugs into the computer. Just updated my support ticket so hopefully we can get a replacement cable on it's way :smiley:

Honored Guest
I'll look for a bent pin, but I've noticed something different.

My Rift is also dropping out.  It started recently.

I noticed that the line on the headset was fairly tight, so I gave it some slack.  I removed and reconnected the connector.

When I put it on, it was cutting on and off a lot, but then I start adjusting the headset on my head.  I noticed that the left side pivots in the connection.  When the Rift is swiveled up, it cuts out, but when it's swiveled down, it reconnects.

That tells me the issue is at the headset and not the computer HDMI end.

I don't recall the strap connections pivoting like that, but it seems like a design feature and makes sense.  The odd thing is, the right side is rigid and does not pivot.  I don't want to force it.

Is there a way to open the thing up to have a look inside?
Rift with X-Plane 11, FlyInside, LeapMotion for flight sim

Honored Guest
Any luck with this issue? I got a regular Rift CV1 and touch on my other computer, but Im running my DK2 on a windows 7 64 bit pc with a 780gtx.

I use it for War Thunder and Elite Dangerous with my HOTAS setup. I have had BOTH games and a few others working properly with this DK2, but now since ive started messing with it again in the past month or so, its been Discconnecting every 2-5 mins of solid play.  Depending on the program it will just start up the rift again and ask me to look at the thing in the center for 2 secs to launch back into the application. But that will only work for a few apps, and now on War Thunder and ELITE it just blanks out after i look at the message and go back into it. 

Just getting solid D'Cd issues every 2-5 mins of use. Anyone else with a DK2 and this issue?. 

No problems at all with the CV1 but i would really like to not have to haul my cockpits and setups all over and inbetween rooms for gameplay.

My CV1 has my wheel and pedals with G-27 and PCars and iRacing and ACorsa, so ya, dont want to move everything around.

Any luck on this issue at all?

EDIT my post said i was running 2 CV1s, but im running a DK2 AND a CV1, the DK2 is the unit with the disconnection issues.

Honored Guest

You have the luxury of different pieces of hardware.

Is CV1 the first iteration of the consumer version (aka - not DK1 or DK2)?  If so, that's what I have.

I'm not sure I've solved anything, but I do want compliment Microsoft Stores.

Mine was purchased in December, so was still under warranty.  I bought it through a local Microsoft Store because I was not going to buy one without experiencing it first.  They did a great job.

After doing what I could myself... cleaning of connectors, making sure there was enough slack in the cable, unplugging and plugging... and not solving the problem, I called them up.

Great service.  Same day, I took my headset in.  They took a quick look and swapped it out for a new one.

People: This is why we need to support local brick and mortar stores.  Amazon may be great, but that kind of service was just outstanding.

I paid attention to the amount of slack in the new one and put a tie-wrap on the cable so it wouldn't slide in the little "U" clip on the headstrap.  As you might expect, I haven't had a lick of trouble with the new one.  I hope it doesn't develop a problem in 6 months.

So I didn't really "solve" the problem so much as I went around it.

Rift with X-Plane 11, FlyInside, LeapMotion for flight sim
Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?