cancel
Showing results for 
Search instead for 
Did you mean: 

HDMI not connected, USB is green - Fixed

DocDvorakian
Explorer
Hi all -
Long post ahead, so please bare with me because I'm at my wits end.

Specs off the bat:
GTX 1060
NVidia driver 442.59
W10 with all most recent updates
Oculus app installed on C:, which is a 500gb ssd if it matters.
All USB 3, USB 2, HDMI and DP work. The only thing I hadn't tried was DVI, but I doubt it makes a difference.

I'm on day 6 of trying to get my rift back up. I bought it Christmas of 2018 and used it about 9 months ago and it worked great, got busy with life and forgot about it for a bit; went to plug it over the weekend and it wouldn't work. When in the oculus app, it registers that the USB is plugged in, but the HDMI won't connect. I get the following image:
c81vtxbje3ok.png

The headset has an orange light. I've tried 3 HDMI ports and 3 Display Ports via adapter, but nothing works with the rift. For reference and to make sure my ports worked, I plugged in both a projector, TV and a gaming monitor and they all worked fine.

The app also recognizes my sensors when I plug them in and I get the "chime" when inserting/removing them, but not with the headset itself.

I can play audio through the headset, but no video will play.

I contacted support about 3 days ago, naturally was told that I was out of warranty and went through the official gambit, starting with:
==============================
  • Unplug all USB devices not needed to power your Oculus device (including extra monitors), and plug headset into a different 3.0 USB port on the back of computer. Front ports aren't always able to supply enough power.

  • If you have more than one sensor plugged into a single USB controller on your PC, try plugging your sensors further away from one another or into separate USB controllers.

  • Ensure that your USB power saving settings are turned off:

    1. Open Device Manager.
    2. Locate your USB ports.
    3. Right click and select Properties.
    4. Navigate to Power Management.
    5. Ensure that the options to save power are disabled

Also, you may run for a software repair by clicking here or the details on how to repair.

If problem still persists, you may need to perform manual uninstall process. To do this:

  1. Disconnect your computer from the internet.
  2. Backup any necessary content.
    • You can find steps on how to do so by clicking here.
  3. Reboot into Safe Mode.
  4. Uninstall Oculus Home using the Control Panel.
  5. Delete all Oculus folders from the following folder:
    • C:\Program Files
  6. Remove any Oculus folders from the following locations:
    • C:\Users\YourUserProfile\AppData
    • C:\Users\YourUserProfile\AppData\Local
    • C:\Users\YourUserProfile\AppData\LocalLow
    • C:\Users\YourUserProfile\AppData\Roaming
    • C:\OculusSetup-DownloadCache
  7. Restart your computer in normal mode.
  8. Reconnect your computer to the internet.
  9. Install Oculus Home again using the setup tool from our website here.
=======================

Didn't work. So out of initial frustration, I said screw it, wiped my entire computer with a fresh OS install and updated all of my drivers before proceeding to the next step, which was:

========================
  1. Unplug and Replug your Rift headset. To do this:
    • Carefully remove the facial interface from your headset. This allows you to access the cable.
    • Unplug the cable from the headset.
    • Wait 5 seconds.
    • Insert the cable back into your headset.
    • Insert the facial interface back into your headset.
  2. Reconnect your Rift to your computer:
    • First re-plug your USB cable into your computer.
    • Wait 5 seconds, or until the light on your headset comes on.
    • Re-plug your HDMI cable into your computer.
==================================

I even sent logs and nothing worked.

At this point, the tech simply suggested that I "buy a new Rift" and upgrade to an S, so I went onto Google and Reddit to see if there were any more popular fixes to which I found and tried:
  • Unplugging and replugging (again)
  • Removing all oculus files from my computer in safe mode and reinstalling (again)
  • Attempting to locate a file called "RiftDisplay.inf" in the C:\Program Files\Oculus VR Runtime Drivers\Drivers\Monitor, right click it and hit "install", but funny enough, that folder does not exist anywhere on my computer. I had wondered if that might be the culprit, but I can't find any info on it or the files to potentially replace it.
  • I reinstalled the rift drivers from C:\Program Files\Oculus\Support\oculus-drivers\oculus-driver.exe
  • Kill the oculus server from the task manager
  • Ensure all USB hubs have the "power saver" box unchecked
  • Make sure the computer is on "performance" mode to produce enough power for the rift
I absolutely loved this thing when I was able to use it, but it's terribly frustrating that a device that was used a handful of times "breaks" and the support team can't do anything other than suggest 1) I reinstall the app or 2) I buy another unit. I was even tempted to buy another cable in the event that -somehow- mine broke, but they don't even sell those anymore, which is absolutely insane because they only just stopped producing them a few months ago.

I'm at my wits end, guys (and gals). If anyone has any other ideas or can send me a straight up copy of their files, I would try anything. Thanks for reading and I hope someone might have an idea, if your idea gets my system back up I'll legitimately ship you a case of beer (if you're of legal age, of course).
6 REPLIES 6

DocDvorakian
Explorer
Update: Last night I downgraded my nvidia driver to 388.xx as recommended by some other posts similar to mine, it didn’t work. I reinstalled the current drivers overnight while I slept and left the oculus plugged in. This morning, the hdmi and usb showed connected and the headset had a white light, so I went to perform the setup with the sensors and controllers, and right after the controller setup the hdmi went dark again and popped an error saying that “your headset could not be connected”.

Edit: This occured when my main display was plugged into my television. I switched my display back to my projector via HDMI to DP, and thats when the error occured. I attempted to switch it back to my tv and the display would not show anything other than my wallpaper - no apps, programs, etc like were showing on my projector. I tried to duplicate the screen but it seems to be stuck on "extend" when the tv is plugged in, and on "pc only" when the projector is plugged in. 

 This tells me it’s not a headset or cable issue, but likely a driver, display or software issue. Any advice?

DocDvorakian
Explorer
Mods, you can delete this post. I figured it out and all is well with the world once again. 

As it turns out, the cv1 doesn’t like projectors or multimonitor setups. 

I ended up using my lgtv as my display, rolling back the gpu drivers to 388.xx, restarting, then upgrading back to the most recent drivers, restarting and it worked. 

Don’t know how or why, but if anyone else ever has a similar issue, give it a go with a different monitor and try what I tried. 

Hi @DocDvorakian, I read through this thread yesterday and I have to admit I was getting confused about how your desktop was being displayed across the monitors/projector so I guess the Rift got confused too!

Anyway, it's probably good to keep this thread (with the edited title) in case anyone else has a similar issue and wants to add a comment or ask for help.

Glad you found a fix.

13700K, RTX 4070 Ti, Asus ROG Strix Z790-A Gaming, Corsair H150i Capellix, 64GB Corsair Vengence DDR5, Corsair 5000D Airflow, 4TB Samsung 870 , 2TB Samsung 990 Pro x 2, DK2, CV1, Rift-S, Quest, 2, 3, Pro

MattVGEXP
Explorer
Hey I'm having the same issue with same device and specs but not a multimonitor set up to be seen. Does the Oculus CV1 need a downgrade in graphics drivers or restart? Im confused

Elremocho
Explorer
Me too, I think they have not released drivers for cv1 with our characteristics, please some mod to help us for those who have this same problem,

DocDvorakian
Explorer
Hey gents,
This is the driver I downgraded to:

https://www.nvidia.com/download/driverResults.aspx/127665/

As soon as I downgraded, the oculus worked. I'm not sure if its just a software issue between the newer drivers and the now-outdated CV1 headsets, but this worked for me

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?