cancel
Showing results for 
Search instead for 
Did you mean: 

Headset isn’t charging

My two-year-old Quest 2 headset with Elite Battery Strap is now not charging. The light turns orange, but the battery is not being refilled. I’m down to 55%, and 83% on the supplemental battery. And the numbers don’t go up no matter how long I charge. 
I tried a brand new cable and adapter, and I’m still getting nowhere. 
Please advise. Do I need a new headset?

5 REPLIES 5

MetaQuestSupport
Community Manager
Community Manager

Hey Hey EmpressStephanie! We never like to hear your VR experience has been interrupted! Let's see what we can do to get you back on your way to the amazing VR world. 

 

Please provide us with the following information so we can understand more of the situation:

  • Where did you get the new cable from?
  • Have you double-checked if the adapter is working with the cable or in general?
  • Have you tried any other outlets?
  • How long ago did all of this start, if you can recall?


We look forward to knocking this out for you! 

Hi, I got the cable and the plug-In from the Meta store. 

This has been going on a few days. 
My elite battery pack charged, but the headset does not. 
Orange light is on, but it doesn’t budge from 55%, except to go down more. 😭
I also tried other outlets. 
Thanks for your help!
🙂
Stephanie 

Hey Hey EmpressStephanie! Thank you for that information, we are glad to help our gamer family whenever we can. We have found a few things that could help resolve this issue, please try the following: 
 

  1. See if the headset will load the boot screen and then exit out:
    1. Hold the power and volume (-) button on the headset down simultaneously until the boot screen loads
    2. Exit and reboot the headset
    3. Reboot the headset if possible
    4. Factory reset

Let us know if this helps!

This won't help. You have to be aware of the issue it's in other threads here. It's the exact same issue here: https://forums.oculusvr.com/t5/Oculus-Quest-2-and-Quest/Quest-2-not-charging-pass-55/td-p/892387 and there are other threads. I've been offered a RMA and only have a few days to return it left. I'm afraid I won't get a replacement for months based on other threads but I recommend you do the same.

 

Stephanie if you want your quest to charge for now, turn it completely off. Then power it on holding the power and volume button. Once you see the Meta logo let go of the buttons and plug it in. It will charge to 100%.

 

Support is pretending like this isn't an issue and won't let us know if our batteries are a danger or if this is some kind of bug.

Thank you.