cancel
Showing results for 
Search instead for 
Did you mean: 

Help trouble shooting stuttering/tearing after watching video for a bit

jckinser
Honored Guest

Hi all,

My Specs:
Oculus Rift S
Windows 11

ASRock B650M Pro RS
AMD Ryzen 7 7800X3D
32gb G Skill F5 RAM
NVIDIA GeForce RTX 4070 Ti

 

 

 

 

I submitted a ticket to support, but thought I'd turn here for some help too.

I'm getting some lagging/screen tearing/stuttering when watching videos in my Oculus Rift S. It doesnt seem to matter what quality VR video. After 3-10 minutes the video begins to stutter and the screen tears. If I stop the video, the performance issue persists as I navigate menus in the video viewing program. The issue does not carry over to the Oculus home window or if I open up another non-video program. The issue appears both in DeoVR and Skyline and if it begins in one program and I switch to the other, it'll be present there. If I close the program and immediately re-open, the issue persists; however, if I wait a few minutes and then re-open the videos will run smoothly again for a while. A few additional curious details:

1) I had this issue on my old PC; however, it was only in the last several months. Previously, I never had issues viewing videos. Last week I built a new PC and the issue persists. 

2) I'm about 90% sure the performance issues coincides with a fan in my PC spinning up. After watching a while, I think I hear my PC begin to whir as if its working a bit harder and then the issue begins. 

3) One time I kept watching during the performance issue to see what would happen and eventually it started playing properly again. I havnt been able to recreate this. 

4) Once I had the issue begin when I left DeoVR open, but had not started a video yet. The menu just got really bogged down and started tearing. 

5) I wondered if I was overheating and I ran HWMonitor while experiencing the issue and while temps on my GPU and CPU got warm, they were within normal range. 

I find lots of threads online about video playback issues with tearing and stuttering, but I've not located any that seem to work fine for a while before they begin to have issues. 

Any help or thoughts about how to troubleshoot this are more than welcome! 

Thanks!

13 REPLIES 13

MetaQuestSupport
Community Manager
Community Manager

Hey @jckinser, we see that you are experiencing lagging issues while trying to watch videos and we understand how frustrating it can be when your device is not working properly. We would love to help troubleshoot and get a better understanding of what exact troubleshooting steps you have already taken. Since you already have a ticket with our support we highly recommend that you keep up with that email as our support are more equipped with tools for these kind of issues. In the meantime you can try these troubleshooting steps.

 

  1. Restart device
  2. Update your GPU drivers to the most recent version.
  3. Uninstall and reinstall GPU drivers.

We hope this helps!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Thanks for your reply. Support has been quite slow to reply, so I appreciate you helping me here too.

Tried those fixes to no avail. As I mentioned, I had this issue with an old PC, but only after having no problems for a couple of years. I built a new PC 2 weeks ago and get the same issue. This was the case before and after updating GPU drivers. At this point virtually every device on my new system has up to date drivers.

Hey there! Thank you for getting back to us. Do you have the same issues with every video player? Or only the specific ones you mentioned? While playing a video, if you open up your Task Manager, do you see any programs that seem to be taking more CPU, Memory, or Disk usage than you would expect them to?

It sounds like something in some software is causing issues that build up over time, which could explain why you have to wait for some internal memory stuff to clear up after closing the program before things work smoothly. If you are able, a screenshot of the task manager could be useful! We hope we can help you look into this to figure out what is going on.

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Thanks so much for getting back to me. I've been in communication with the Meta support via email and it's been pretty rough. Every time I'm getting a different support person, often they are just asking me to do something I've already done the week before. In your one forum reply you've already given this more thought than it seems that whole support team has. 

I had a chance this morning to trouble shoot to try and get you some information. Had a strange outcome. I opened up task manager and over the course of 25 minutes I watched a few different videos, some high demand and some not. Usually in that time I'd get the glitch. I kept an eye on the task manager and didnt notice anything out of the ordinary. I took a before picture of the task manager, which I can attach. 

One thing I noticed after I put away the Oculus is that there was a program running in task manager under "Movies and video" or something. It was Video.UI and it was marked as suspended to improve performance. I rebooted to see if that's a program that is on by default and it was not. I wonder if that's something that came up while watching video on the Oculus and somehow it being suspended resulted in the long period without issue? 

In any case, next time I have a chunk of time to experiment I'll see if I can get you some more information, including a screenshot of the task manager during the issue. Here's a screenshot of the task manager when working fine. Task Manager Before VR.png

Hey there @jckinser! Thank you so much for your response. Going off what you've told us, it appears to be an issue related to CPU usage. Previously we had mentioned to check out task manager which will show you spikes in CPU usage, this tool will allow you to better understand which applications or processes are causing the bog down. We know that it can look daunting but we're here to help! If you can screenshot task manager when the issue begins, we'll be able to investigate further.

 

Please let us know if there is any other questions or concerns you may have while we await those screenshots. We look forward to your response!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Hello @jckinser. Hope all is well. Just checking back in with you to see if there has been any updates on your current status with your CPU / PC issue and if you had the chance to look into yet. Hope to talk to you soon. 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Thank you so much for following up! I havnt had a chance to experiment just yet. As soon as I do I'll post more information about CPU usage. 

Hello again, @jckinser! It's our pleasure! We're happy to keep working with you once you're ready. We'll keep an eye out for your reply, and we'll be in touch again soon to check in!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Before ProblemBefore ProblemDuring ProblemDuring ProblemHello @MetaQuestSupport! It's looking like CPU usage is not the problem. I've attached two pictures. One is when the Oculus program is closed and the other is when I'm actively experiencing the video lagging, slowdown, and tearing. CPU usage doesnt climb too much at all. I downloaded Gizmo VR as a third video viewer. The issues does not seem to happen there; however, the program is less well designed than the other two. The issue seems to just occur with DeoVR and Skyline and when one program is malfunctioning, the other will be too (if I quickly swap programs and resume the video).

I have a couple of hypotheses and I wonder what you think. 

1) I don't know much about GPU throttling, but I know a GPU will throttle to manage temperature. I'm wondering if there is something happening where my GPU throttles/kicks on and it causes the slow down. I'm not sure how to check this or interact with it. 

2) Maybe DeoVR and Skyline are not optimized any longer for the Rift S? Deo used to work just fine on my Rift, but that was quite a while back. Perhaps they've released updates that optimize with new VR headsets at the expense of some problems with the Rift S? 

3) Related to #2, maybe there are some problems with my headset. Perhaps the cable? This seems unlikely since Gizmo seems to work okay. 

I'll look forward to your thoughts.

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?