cancel
Showing results for 
Search instead for 
Did you mean: 

Horizon world content not loading

The_MF_Sun
Honored Guest

Hello, Horizon is not loading friends and world. It says, “Unable to load content”

21 REPLIES 21

CamEleksis
Honored Guest

Same here. I get the unable to travel when i try to go to my world

MetaQuestSupport
Community Manager
Community Manager

Hi there! We know how frustrating it is to be ready to start a new game, but not being able to actually enter it. We hope these troubleshooting steps help resolve your issue:
  

  • Please navigate to your settings 
  • Under the Device section, scroll down to Languages and select English (US) as your main language. 
  • Reboot the headset and launch Horizon Worlds and you should be good to go!

If you continue to have issues with this or have any other questions or concerns, don't hesitate to reach back out to us here or by submitting a ticket on our website here: https://metaque.st/Support.

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

that doesnt work btw im on oculus link please help im not able to go into any worlds

Hello there! We see you're experiencing some difficulties playing on either Horizon platform, we understand this can be concerning and prevent you from enjoying Horizon. Don't worry, we'll do our best to help you get this resolved.

 

Can you tell us what error messages you're getting, if you've checked the WiFI and ensured it has a strong connection, if you've checked your storage space and ensured you have enough space, and if you've created a Meta account and the device is up to date?

 

We can help you further and get you back up and running once you provide that information.

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

i have good wifi and my meta device is up to date

Perfect, thank you. Have you tried to uninstall and reinstall the mobile app yet? Some folks have had success with that. You could also try hard rebooting your headset. This is done by putting your headset on and holding the power button for 30-40 seconds. Once you cycle back to the home screen, you're golden.

 

If that doesn't work, and given everything you've tried already, you may be in the same boat as a few of our other users. When Meta accounts rolled out a few days ago, folks let us know that they were having some difficulties getting into their accounts. This affected logging in to Meta accounts and a number of Horizon worlds users as well. Please keep an eye out for an official announcement soon, our engineers are aware of what's going on and are actively working to get it sorted.

 

In the meantime, we've set up a thread for people to tell us what they're looking at - here. If you can, please swing by and share you experience there as well. Every voice helps our engineers see just how widespread a given issue may be.

 

And one last thing. Some users have found that factory resetting their devices takes care of everything. If you can't get into Horizon Worlds after all this,  and you're interested in giving it a shot, go for it. If that's not something you're looking at making happen today, we totally understand. We look forward to getting this under control quickly, and expect a resolution soon.

 

Thank you for your patience. We can't wait to see you in the MetaVerse soon!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

WhatDoAmy56
Honored Guest

I can connect to Wi-Fi fine, strong signal on 5g also 2.4, in games see scoreboards, (had to reset to headsets for this) BUT with all merged accounts I go to meta or horizon and cannot go any further than the main “entrance”. It shows a faded Wi-Fi on the meta below where it says “we’re getting you connected now” and horizon won’t go to home I can stand there and look at all the options and see my avatar- have been asked to join a friend and bounce back to start.  Every time I log in I have to do the “are you standing or sitting, ahh you’ve done this before haven’t you thing. 

Thank you for letting us know @WhatDoAmy56, have you tried any of the troubleshooting steps listed above? or is there anything different you have done to try and solve the issue out on your end? 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

WhatDoAmy56
Honored Guest

I’ve tried everything- I also installed my account into a second heat I own I was going to sell (user can’t play. Gets nauseous) but - same problem.  

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?