Showing results for 
Search instead for 
Did you mean: 

I feel like I'm being gaslit. No store front page

Honored Guest

I own an original quest purchased in 2019 and a Quest 3 that I got on launch day. Sometime around last Tuesday, I noticed the front page of the store was blank, with a message stating "please try again later". I submitted a big report and figured it would work itself out.

Over the next few days I started troubleshooting.  I found out the store also behaved this way on my Quest 1. Curious, I attempted to access the store on an IOS app, android app, and Meta website, I can see the top selling and most popular list, but no sales, bundles, or suggested titles populate. Most importantly, my store page is still blank when accessed from my headsets. At this point (Friday) I contact support.


I have to tell you this has been the most frustrating experience with any company I have asked for help. Besides the 24 hour turn around time for any response to the simplist of questions, they are telling me that nothing is wrong!!! They fixate on the fact I mentioned that no sales are populating for me and suggested that I'm not being targeted for sales at this time, (this is bs) as the weekly sales are not even showing up. Regardless, the fact that when I go to access the store in my headsets, it literally tells me there is an error and try again. How am I to believe this is normal operation. 


I don't know if there is anyone out there that can help me, but I would so greatly appreciate any assistance. I feel like I'm not being heard and my issues are being dismissed. I'll stop now, whoever reads this, know that I hope you have yourself a good weekend.


Honored Guest

UPDATE: I have been dealing with customer support for over 3 weeks now without success. Is there anyone that has had anything similar happen to them?

When I go I to the store, instead of seeing banners promoting featured games and sales, I am greated with my "wishlist" and "most popular". This is not how the store works for my daughter, my wife, my friends that I have asked.  This extends across the mobile app,, and my quest 1 & 3.

Hello, @MarkMe2525. We appreciate you reaching out regarding this matter. We understand that you are eager to have your store functioning properly again, and we are here to provide our assistance! Could you please confirm if this issue occurs solely when you are logged into your account? Additionally, do you have any VPN enabled that might be causing your location to appear in a different region? We are eager to receive further information from you soon!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Hello once more, @MarkMe2525. We wanted to reach out and see if you are still experiencing difficulties accessing your store. Our main goal is to assist you in resolving this issue as swiftly as we can, so please inform us if there is anything we can do to assist you further.

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

I'm sorry that I haven't responded in a timely manner. My issues are network and hardware agnostic. Headset or mobile device, ios or android, att hotspot, verizon Hotspot, cox wifi it's all affected. I have been communicating with a Meta agent over email for over 4 weeks now with no eta on a fix. The agent states they are the highest level of tech support offered, but nothing is being resolved and I am at my wits end. 


I want to be clear that I am not complaining about the agent I am currently working with, but I am complaining about the lack of a resolution. 

If it is quest 1 that could be the problem as there trying to get people to get quest 2 or 3 from quest 1, if it is quest 3 i cant help you.

I also wanted to point out a new issue I noticed that may be related. Even though I have my facebook linked, I am not giving the option to activate the "hey facebook" voice command feature. In an effort to troubleshoot, I unlinked my social accounts. Afterwards, I found I was not able to sign back into the facebook account through the headset. When I clicked on "add facebook", the browser briefly pops up and disappears. Power cycled device with same result. I was able to re-link facebook through the mobile app, but the "hey facebook" feature is still not available for me.

It's across quest 1 and quest 3 headsets. 😞

Meta Quest Support
Meta Quest Support

Hey everyone. This sounds like an odd one. Can anyone else confirm that it's happening across headsets or is it just @MarkMe2525? Any info on what you're experiencing helps me out. Thanks guys! 

"Pirates are evil." "The Marines are righteous." These terms have always changed throughout the course of history. Kids who have never seen peace and kids who have never seen war have different values. Those who stand at the top determine what's wrong and what's right. This very place is neutral ground. "JUSTICE WILL PREVAIL" you say, but of course it will. Whoever wins the war becomes justice.