cancel
Showing results for 
Search instead for 
Did you mean: 

I need help-

Riperople
Level 2

So my oculus says it's "out of date" and I think it means the date is wrong and it can't track it, I've factory reseted it over 4 times and it won't work. Any suggestions? 

2 REPLIES 2

MetaQuestSupport
Community Manager
Community Manager

Hey there! We're happy to help get your headset back on track. Have you tried manually checking for updates? Make sure your headset is updated by doing the following:

 

1. Press  on your right Touch controller to pull up your universal menu.
2. Hover over the clock on the left side of the universal menu. When Quick Settings appears, select it to open the Quick Settings panel.
3. Select  Settings in the top right corner.
4. Select  System, then select  Software Update from the left menu.

From here, you can check your current software version. If a new version is available, a button to download the update will appear.

 

Make sure your phone is paired to your headset and is set to the correct date and time as well. Let us know if this worked for you!

MetaQuestSupport
Community Manager
Community Manager

Hey there! We wanted to check in and see if those steps were able to help you out. Let us know if you still require any assistance! We're always happy to help.