Showing results for 
Search instead for 
Did you mean: 

Is it me or is Oculus TV broken ?

Expert Protege

It seems when you watch a VR video now from any category the player stays on in front of you and you have to use the right Oculus button to remove it totally ?
before you could press the right trigger and pause or forward etc.


Community Manager
Community Manager

Hey there! If something in your Oculus TV app isn't working quite right, the first thing we'd suggest for you to try is uninstalling and reinstalling the app to see if that helps. After that, if things are still not quite working how they should be, we'd like to request that you submit a bug report to us by following the steps in this article.

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

I am having the same issue with Oculus TV.  The “immersive” message and player stays on top of the video unless I hit the right Oculus button.   I have also attempted to delete the app but it is not showing itself in storage and when I hit the 3 dots on the app the only menus are ‘see details, lock and permissions.’   How do I delete to reinstall?



It’s not you. I started having the same issue yesterday (June 6)


Hey there! Thanks for trying to follow those suggested troubleshooting steps. It's definitely weird that you couldn't see the option to uninstall! To see if we can get it working to allow an uninstall/reinstall of the app, go ahead and reboot your headset and see if you get the same result. Also, let's check that your headset is on the most recent update. It should update automatically, but you can check by following the steps in this article


If everything is up to date, and you're still having trouble after a reboot, go ahead and send us a support ticket here. That way we can dive a bit deeper into what's going on and get it all figured out!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Or ... 
You could just try it yourself back at Oculus and confirm whether its a bug or not 🙂 


Glad others are having this issue, I don't know why anyone would think this is a good update.
It's my go-to app for watching prerecorded VR video, and being able to pull up the UI briefly with the right trigger to FF or RW was really convenient. Please put it back to the way it was or give the user option to assign buttons for functions.

I am current on the OS as well as the app.  It is clear that multiple people are having the same issue.  Rather than another generic ‘submit a ticket’ which doesn’t allow me to direct it specifically to Oculus TV, would you kindly tell me how to force an update for only the Oculus TV app.  Having run 3 large data centers for most of my professional career, I would think the current version has a defect. 


Hello Chief0805. Thank you for contacting us. We understand that you're having issues with Oculus TV. No need to worry, We can definitely assist with resolving this. Have you tried uninstalling and reinstalling the app? This can help with updating the app. Another thing that could also help is restarting your headset.  If the issue persist please reach out! We're always here to help! 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Thank you for another quick reply, but your advice is redundant.  I have already done the restart numerous times as you advised before.  I have also confirmed the headset OS is up to date.   What now?

Get Help
Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

Check out some popular posts here:
Getting Help from the Meta Quest Community
Tips and Tricks: Charging your Meta Quest Headset
Tips and Tricks: Help with Pairing your Meta Quest
Trouble With Facebook/Instagram Accounts?