Showing results for 
Search instead for 
Did you mean: 

Issue with Mixed Reality Capture


Hello, I can't start mixed reality capture at any cost, I have Meta Quest 3, the problem I see is that I don't have the option to enable MRC made available in the games, I tried to get into mixed reality with the help of Liv connect, OBS or reality mixer, nothing works , please help me, any advice would be great!!


Thank you for your update @The_1st_Dark_Lord_Morgoth.


1) Regarding Quest 3:

-It is unfortunate mixed reality capture is not supported on this newest headset, despite this feature has been working on Quest 2 and Quest 1.  It is an excellent mean to share the gameplay with family & friends and to get them interested in VR.  I hope the engineers can add this functionality to Quest 3 at some point.


2) Regarding Quest 2:

-Sounds like the v60 firmware has broken mixed reality capture for almost all the games (except Figmin), in which the games are not able to accept the connection despite various workarounds to place the mrc.xml file in the required data folder.

-@tangjunlong, perhaps this article from Meta will help you to get it work again with OBS?

-@The_1st_Dark_Lord_Morgoth, would you or the engineers be able to shred some light on what’s required to get this working again for the Reality Mixer app ( for Quest 2 with v60 firmware?  It’s very convenient to be able to just use an iPhone to capture rather than having to use a PC workstation with green screen.



I appreciate you looking into this, and getting back to us, and recognize that you personally are in no way responsible for the outcome of this issue.  However, I would also like to state that it is ridiculous that Meta has an official tool for mixed reality capture, with instructions for setup on the quest 3, and they want us, the end users, to recommend that they add mixed reality capture capabilities.  I don't even know how to respond to that.


Thanks again @The_1st_Dark_Lord_Morgoth .

I went ahead and posted on the Ideas board, here :

Fingers crossed!! This is actually a very important feature.


Looks like Mixed Reality Capture is already fully supported by Q3 but Meta decided to break compatibility in v60 firmware so all devs needs to update their games because right now It cannot load required libs as you can see in logcat logs:


OVRMrcLib: Try loading /data/app/~~YrMPdG2-q7z1Fv6oJ3jETA==/com.beatgames.beatsaber-i16n_ZL1i615Yj5FPmgg6Q==/lib/arm64/

OVRMrcLib: Try loading /data/app/~~YrMPdG2-q7z1Fv6oJ3jETA==/com.beatgames.beatsaber-i16n_ZL1i615Yj5FPmgg6Q==/lib/arm64/

OVRMrcLib: Try loading

OVRMrcLib: Try loading

OVRMrcLib: Unable to load OVRMrcLib

OVRPlugin: Unable to load OVRMrcLib

OVRPlugin: ovrp_Media_Initialize failed. OVRMrcLib not loaded 


Solution is very simple because this lib already exist in the system: one-line fix:

<uses-native-library android:name="" android:required="true" />


We all knows how stupid is breaking compatibility with ALL games and saying its just not supported by Q3, LOL but it is what it is and for sure the only way to get it working is sending bug reports to game developers because Meta dont care and will not fix this anyway.


@The_1st_Dark_Lord_Morgoth you can send this to yours engineers, they could very easily fix this for everyone.


Just to prove my point, I made an experiment:

  • I decompiled newest version of Beat Saber
  • Added one-line lib info to manifest:
    <uses-native-library android:name="" android:required="true"/>
  • Compiled again
  • Installed modified Beat Saber APK to Quest 3 with newest firmware
  • Beat Saber has now found the MRC lib and start listening for a (this time successful) connection in OBS


logcat logs from modified Beat Saber:


$ logcat | grep OVRMrcLib
OVRMrcLib: Try loading /data/app/~~XRfD4z-jQxXRmsfzKRSyhA==/com.beatgames.beatsaber-Si0If9i1Bi99uU_TuIunqg==/lib/arm64/
OVRMrcLib: Try loading /data/app/~~XRfD4z-jQxXRmsfzKRSyhA==/com.beatgames.beatsaber-Si0If9i1Bi99uU_TuIunqg==/lib/arm64/
OVRMrcLib: Try loading
OVRMrcLib: OVRMrcLib loaded successfully
OVRMrcLib: Function GetVersions loaded
OVRMrcLib: version: 1.81.0
[several entries like OVRMrcLib: Function IsMrcEnabled loaded]
OVRMrcLib: ovrm_LoadSharedLibrary() succeeded. Module loaded from /system/lib64/
OVRPlugin: OVRMrcLib loaded. Versions 1.81.0
OVRMrcLib: MRC config file found: /storage/emulated/0/Android/data/com.beatgames.beatsaber/files/mrc.xml
[several entries about MRC camera data]
OVRMrcLib: [MediaManager] MRC camera found
OVRMrcLib: [MediaManager] MrcConfig: enabled 1 hq_mode 0, frame 2560 x 1080 image 1440 x 1080 tcp_port 28734 debugcamera 0 bitrate 8000000
OVRMrcLib: [MediaManager] Start Listening
OVRMrcLib: [MediaManager] Listening at tcp_port 28734
OVRMrcLib: [MediaManager] GraphicsAPI set to GLES
OVRMrcLib: [MediaManager] SetMrcActivationMode 0 listening 1


Its now ready to connect, APP doesnt matter, could be OBS, RealityMixer, whatever

I sent this to Beat Saber support but anyway @The_1st_Dark_Lord_Morgoth I strongly suggest to fix this on your end because it is very difficult to update every supported game and most of them will ignore this problem. Im happy to help your engineers, feel free to PM me. There is really minimal effort required and you will have cool feature for content creators.

Oh wow! Nice work. 🙏🙌

Thank you Wu70!

Would you be willing to provide the edited apk?  I tried it my self, and the instructions are good, but I'm very stupid.

Great find there, @Wu70! I'll go ahead and let the engineers know about this and see what they say. In the meantime, I hope this is able to help other users also experiencing this issue!

Peace is a lie, there is only passion. Through passion, I gain strength. I gain power. Through power, I gain victory. Through victory, my chains are broken. The force shall free me.

Awesome work! Thanks for chiming in here and on the reddit post with documentation of a fix!

Officially supported or not, I knew it was crazy to toss this off as, "not supported on Q3."

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?