Showing results for 
Search instead for 
Did you mean: 

Issue with Mixed Reality Capture


Hello, I can't start mixed reality capture at any cost, I have Meta Quest 3, the problem I see is that I don't have the option to enable MRC made available in the games, I tried to get into mixed reality with the help of Liv connect, OBS or reality mixer, nothing works , please help me, any advice would be great!!


So how does the average user benifit from this information currently?  Props for figuring this out im super excited to see it in action, but are we still at the mercy of meta and whenever they get arround to fixing it?  Maybe I missed something??

It looks like we're at the mercy of either Meta reversing the change that broke it (maybe it was intentional but not communicated; maybe it was accidental and they need to fix it) so that all apps supporting MRC work again; or,  devs updating their apps (which appears easy enough to do, just needs to be done, but I imagine they'll have to undo it if Meta ever rolls it back the way it was). 

Honestly, I haven't had time to go back and see if anything else now has MRC working on Q2/Q3 v60 other than Figmin.

Anyone got v62 yet and test it with other MRC apps? 


btw I just decompiled Figmin to check if they have another solution but looks like they are using exactly the same extra one-line in manifest. 

Based on logs this seems to be a proper solution, not a workaround.

@Da_Dingo average user should send this guide and thread to game developer and they should update their game. Probably most of developers have no idea this problem exist and I cant imagine they would refuse to fix it if we have already a one-line fix provided, that would be ridicoulus.

On the other hand average user should keep this thread alive so Meta perhaps will assign 1 hour for one engineer to fix it for everyone at once.

We need to believe in @The_1st_Dark_Lord_Morgoth ! 😉


I'm 1 of many I'm sure following all this. I've never figured this out on Quest 1 or now my Quest 3. I don't understand what Wu70 did with that extra line of code. Is that a thing I can do? Not sure what you mean about decompiling etc. Is there somewhere in the Quest files I can add that line of code to fix things? 

Somone over on my reddit post wrote out the steps; I haven't tried them yet but plan to (hope to):

HELP! Quest 3 cannot Mixed Reality Capture : OculusQuest (

Oh wow. Yeah that may be over my head. Why can't Meta just put MRC back?

For example, not sure what this step means or if it will be clear once I get there... 

Generate a keystore keytool -keystore keystore.jks -genkey -alias your_name -keyalg RSA -sigalg SHA1withRSA -keysize 2048 -validity 10000


Maybe one day someone will just put the updated apk file out there somehow for us less technical folks.


Maybe one day someone will just put the updated apk file out there somehow for us less technical folks.

Thanks for posting this. Developer here developing a new app that I want to use MRC with. I have attempted to add the line to my Android Manifest. But, I get a build error when I do it. Without that line, builds fine.

<?xml version="1.0" encoding="utf-8" standalone="no"?>
<manifest xmlns:android="" xmlns:tools="" android:installLocation="auto">
  <application android:label="@string/app_name" android:icon="@mipmap/app_icon" android:allowBackup="false">
    <activity android:theme="@android:style/Theme.Black.NoTitleBar.Fullscreen" android:configChanges="locale|fontScale|keyboard|keyboardHidden|mcc|mnc|navigation|orientation|screenLayout|screenSize|smallestScreenSize|touchscreen|uiMode" android:launchMode="singleTask" android:name="com.unity3d.player.UnityPlayerActivity" android:excludeFromRecents="true" android:exported="true">
        <action android:name="android.intent.action.MAIN" />
        <category android:name="android.intent.category.LAUNCHER" />
        <category android:name="com.oculus.intent.category.VR" />
      <meta-data android:name="com.oculus.vr.focusaware" android:value="true" />
    <meta-data android:name="unityplayer.SkipPermissionsDialog" android:value="false" />
    <meta-data android:name="" android:value="vr_only" />
    <meta-data android:name="com.oculus.ossplash.background" android:value="black" />
    <meta-data android:name="com.oculus.supportedDevices" android:value="quest2|questpro|eureka" tools:replace="android:value" />
  <uses-feature android:name="android.hardware.vr.headtracking" android:version="1" android:required="true" />
  <uses-permission android:name="com.oculus.permission.USE_ANCHOR_API" />
  <uses-feature android:name="com.oculus.feature.PASSTHROUGH" android:required="false" />
  <uses-permission android:name="com.oculus.permission.USE_SCENE" />
  <!-- Add the following uses-native-library -->
      android:required="true" />

Based on, the "uses-native-library" block should be inside of "application" container. 

Thank you. I was able to build successfully now! Unfortunately, using the Reality Mixer app on iOS, I still can't start mixed reality (even though i was able to do calibration).

Android logcat is showing MRC isn't even enabled...which might be a clue for something. But, its set to Automatic in my OVRManager.


Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?