Showing results for 
Search instead for 
Did you mean: 

Issue with Mixed Reality Capture


Hello, I can't start mixed reality capture at any cost, I have Meta Quest 3, the problem I see is that I don't have the option to enable MRC made available in the games, I tried to get into mixed reality with the help of Liv connect, OBS or reality mixer, nothing works , please help me, any advice would be great!!



+1 looking for a solution. I've tried all sorts of ways to get mixed reality capture working and fail every single way with Quest 3. I've tried the Meta MCR configuration tool on PC, I've tried OBS, I've tried Reality Mixer iOS app. I've tried Liv. I've also tried both the official and non-official calibration apps on the headset. I've copied files with abs and tried using different wireless networks. Nothing works.

Hey there @Da_Dingo! We're here to lend a hand! MRC is an amazing tool that lets you blend the real and virtual worlds together. It's always exciting to see what our players come up with when they use it! 


Could you please tell us where exactly you're facing difficulties while launching the MRC tool? It would be great if you could share some screenshots too! By the way, we have a helpful guide on our website for using MRC. Even though it mentions Quest 2, the same instructions apply to Quest 3 as well! 


Could you please confirm which version of the MRC tool you have? 

Is it the latest version, 5.1.2? 


Also, make sure that your OBS (or LiV/Reality Mixer), MRC Quest 3 app, and headset are all updated to the latest versions available. We've come across a discussion where users had similar issues with the MRC tool, and many of them found a solution by following the steps shared by our community members. You can check it out here! 


Let us know if that solves the problem or if there's anything else we can try to help you out!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Hey there, @Da_Dingo and @NeonStoic! Just wanted to see if you both were able to try the helpful tips posted here on this thread! If so, were you able to get MRC to work properly? If not, kindly provide us a few details, like the information requested in our post above, so we can take a deeper look for you. We look forward to your reply!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Haven’t had a chance since the post yesterday. Somewhat surprised that the suggestion from support is to try this kind of workaround.

Hey, @NeonStoic. When you get a chance to look into everything, feel free to reach out to us if you still need more help!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Hi again, @NeonStoic! Just checking in to see if you needed any more help; if so, please let us know!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

I gave all the information requested in my first post.  and that link refferes to a different problem that meta ignored for months then kina half way made a workaround for.  My issue is directly with Beatsaber and OBS or the OBS plugin rather.  And what do you sugguest follow the instructions on your web site or use the newest OBS?  Because im running OBS 24.0.3 like the app says to run but the newest one is 30.0.2 and isnt compatible with your plugin.....  I asked if there was a solution to the authors problem since it was taken into private before being solved. 

Hey there, @Da_Dingo!  Were you able to follow the steps detailed here. If everything is set up right and you're still having issues please let us know! 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

I've tried again all the steps and again, I get the same error. .

Quest 3 runtime version

Steps to reproduce :

  1. Install MRC tool on Windows (Mixed Reality Capture Tool on Meta Quest | Meta Store)
  2. Install MRC app on Quest 3 from the Meta Quest store
  3. Run MRC on Quest 3
  4. Run the MRC tool on Windows and go through calibration setup (success)
  5. Install version 24.0.3 of OBS
  6. Click on link at final step of MRC calibration to update OBS with plugin (successful)
  7. Save calibration scene collection json file to PC
  8. In OBS, import scene collection
  9. In OBS, select new MRC scene collection
  10. Open mixed reality supported app (Beat Saber, in my case but have tried many)
  11. In OBS, click on Oculus MRC in Sources. Ensure ip address for Quest is correct. Ensure port is set to 28734.
  12. In OBS, Properties for 'Osulus MRC', click on "Connect to MRC enabled game running on Quest"
  13. Observer the error : "Connection Failed.  Please verify the Quest IP address, and if MRC-enabled game is running on Quest. Reboot the headset and re-launch the game if the issue remains."

I have also tried copying the mrc.xml file from the calibration tool to the Beat Saber data directory via adb to ensure it is correct. I have also tried using other tools to no success with Quest 3 as well - Liv, Reality Mixer. Have also tried the unofficial Quest calibration tool from SideQuest.

Fundamentally, Quest 3 does not work with mixed reality capture. I have this all on video, if needed.

Have MetaQuestSupport been successful with Quest 3 and Mixed Reality Capture?

Additional note : I just tried with the same mrc.xml file generated with Quest 3 on my Quest 1 and used OBS Studio without even making any other changes and got it working with my Quest 1. So it's definitely something related to Quest 3.

Meta Quest Support
Meta Quest Support

Hey there, everyone! I came across this thread and saw that you were having issues with mixed reality for the Quest 3. I went ahead and brought this to the attention of our engineering team so they could look into this issue further. I'll let you all know if there is any additional information that they would need or if there is anything they can tell us as well.

Peace is a lie, there is only passion. Through passion, I gain strength. I gain power. Through power, I gain victory. Through victory, my chains are broken. The force shall free me.
Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?