Showing results for 
Search instead for 
Did you mean: 

Issue with Mixed Reality Capture


Hello, I can't start mixed reality capture at any cost, I have Meta Quest 3, the problem I see is that I don't have the option to enable MRC made available in the games, I tried to get into mixed reality with the help of Liv connect, OBS or reality mixer, nothing works , please help me, any advice would be great!!


Thanks! Also, to be clear, no problems with mixed reality. The problem is with mixed reality capture, using OBS or any other mixed reality capture software (Liv and RealityMixer on iOS included). In all cases, games\apps that should support MRC cannot get connections from the MRC tools.

I'm having the same issue and here's what I've discovered (if it helps because I'd really like to start recording my own mixed reality captures). 

Initially, I was trying to setup MRC with Beat Saber using iPhone camera. I installed Mixed Reality Capture from Meta's app store on Quest 3 and Reality Mixer on iPhone. Calibration completed fine (or appeared to), but I could not start MRC. It would fail with Unable to connect (unknownError) ... NOT a timeout error. 

I then learned the version of MRC in Meta's app store broke some time ago in an earlier Quest update (v51, I think, or whichever one it was where the base OS underwent a major update). Why hasn't that been fixed?

That update apparently broke file permissions, so a user-patched version, Quest Mixed Reality Calibration App on SideQuest, fixed that, but later another issue arose (I think, as this was all before I tried any of this myself).

There are multiple examples online how to fix all of those issues up to that point (for example, by copying the mrc.xml calibration file Reality Mixer writes to the headset over to the individual app's data folders). Many did that to get their MRC working again prior to v60 (on Q2 and Q3). They have MRC videos online proving it. 

It seems those workarounds quit working when v60 hit the headsets. Some Q3 users posted MRC videos with their new Q3, but now that v60 has rolled out, MRC is working in very few apps. Therefore, it's not broken entirely, but something changed in v60 that broke it in many apps. 

Figmin XR is one app where I've confirmed MRC works (again). I understand the app dev had to update their app somehow to get it working again, but I'm unsure at this point what they did.

MRC doesn't work in Beat Saber or Synth Riders. 

MRC works fine with those apps on my old Quest 1 with the original MRC app in Meta's app store, but as you know, Q1 never got any of the updates that keep breaking MRC. 

I've documented my own journey here: 

HELP! Quest 3 cannot Mixed Reality Capture : OculusQuest (


I'm having this exact same issue, does this have a fix yet?

No fix yet.

It would seem like MRC has been continually getting more broken for awhile. Starting with the inability for Meta's own calibration app to save the calibration file on the headset properly (which would theoretically be a fairly simple fix). It was an issue that was bad enought that someone in the community fixed this by creating a different calibration app and made it available through sidequest.

But now it seems like it's very broken with the latest OS, beyond just calibration. As mentioned earlier in the thread, some apps (like Figmin - maybe only Figmin) might work but required developers to do something. It seems like almost all apps on Quest now don't have mixed reality capture.

Which is too bad. Mixed reality capture was a key way for people to show off VR gameplay on social media. Watching people play Beat Saber with mixed reality capture was actually the reason why I bought a Quest 1.

Given the list of things broken or removed in v60, I suspect that Meta may not yet prioritize this particular issue so might be a bit of a wait.

Meta Quest Support
Meta Quest Support

Hey there, guys! Sorry for the wait in getting back to everyone, and a happy new year to you all as well! I wanted to let you know that I heard back from our engineers. They were able to confirm that mixed reality capture is not an official supported feature for the Quest 3.

I know this isn't the best news to hear, and I know how great it would be to have mixed reality capture for the Quest 3. I suggest that you make a post on the Ideas Page of the forums saying that you want to see this in a possible future update. There, other users and developers are able to share their suggestions with each other, and we've even seen some ideas implemented in past updates.

Peace is a lie, there is only passion. Through passion, I gain strength. I gain power. Through power, I gain victory. Through victory, my chains are broken. The force shall free me.

Well that's bad news ... but respectfully, I must ask, are you sure it's not supported on Quest 3?

It's currently working in some apps on Quest 3 running v60 (Figmin XR is an example), and to get it working, those devs had to change something (I'm still trying to figure out what). It was apparently working on Quest 3 with more apps back on v59. 

I've seen MRC used interchangeably with Mixed Reality Capture and Mixed Reality Casting, I want to ensure we're talking about the same thing (and honestly, I'm not 100% sure which is which). 

I recall seeing email from Meta a few months back, but can't find it, that Mixed Reality Casting (or Capture) was being removed from the Oculus app on iPhone; that appeared alongside live overlay, and with this 3D cube icon. It, indeed, is gone. When you're told it's no longer supported, I wonder if they mean this. 

Mixed Reality Capture, however, is not that. Also, as of v60, it appears to be broken on Quest 2, as well, but again, only in some apps, not all. 

In summary, I'd like to understand how it's working with some apps, but not others. 

Hey, @mareksoon! I get what you mean. From what I was informed, this is a feature that is not officially supported for the Quest 3. That said, since you mentioned seeing this feature being implemented for some apps and not others, I'd be happy to follow up with them to see if we can get some clarification about this. I'll let you know what they've said as soon as I can.

In the meantime, would it be possible for you to recreate what you're seeing and share it here on the thread as a video? This way, I can pass it on to them, and they can have a better understanding of this issue.

Peace is a lie, there is only passion. Through passion, I gain strength. I gain power. Through power, I gain victory. Through victory, my chains are broken. The force shall free me.

Thanks for getting back here. Meta’s Mixed Reality Capture app suggests that it is supported for quest 3 in the App Store, so that might need to be updated accordingly if it is a feature being dropped.

Very unfortunate if this is another feature being dropped. 😟 Seeing others share videos of themselves with mixed reality capture is actually what influenced me to buy my first quest.


Oculus Quest Mixed Reality OBS needs an update! I can't connect Quest2, Quest Pro using OBS because of this issue "Please verify the Quest IP adress, and if MRC-enabled game is running on Quest. Reboot the headset and re-launch the game if the issue remains" but I can use OBS connects to Quest1. I think the key to the problem comes from the system of the helmet. Quest1 is currently V50, while the systems of Quest2 and Quest Pro are V60! Before the system update, my Quest Pro could be connected to OBS normally to record MRC videos. Now I can only use Quest1 to record MRC videos!

Meta Quest Support
Meta Quest Support

Hey there, guys! Sorry that it's been a while since I last reached back out to you all. I wanted to let you know that I spoke again with our engineers, and they confirmed that the Quest 3 headset should not be capable of mixed reality capture. If you have a headset that does, then great! But in the end, this feature just isn't officially supported for the Quest 3.

It would be great to see the Quest 3 be able to allow mixed reality capture like other headsets can. So I recommend that you share this suggestion on our Ideas Page in the forums. This way, there is a chance that this could be seen in a future update for the Quest 3.

Peace is a lie, there is only passion. Through passion, I gain strength. I gain power. Through power, I gain victory. Through victory, my chains are broken. The force shall free me.
Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?