Showing results for 
Search instead for 
Did you mean: 

Issue with Mixed Reality Capture


Hello, I can't start mixed reality capture at any cost, I have Meta Quest 3, the problem I see is that I don't have the option to enable MRC made available in the games, I tried to get into mixed reality with the help of Liv connect, OBS or reality mixer, nothing works , please help me, any advice would be great!!


I'm not a VR app dev, but based on the logcat error, looks like the runtime is unable to find "mrc.xml" file in your app's data folder.

After the calibration process is done, copy the "mrc.xml" file from the calibration app under "/Android/data" to your app's folder.



Why is this still an issue requiring every dev to recode their apps? What did Meta change/break to cause MRC to break in every app that previously supported it? MRC still works fine on my old Quest 1 because updates for it were suspended. 

Also, regarding the need for USERS to manually copy mrc.xml, will Meta ever fix Mixed Reality Capture in Meta's own app store which broke some time ago in an earlier Quest update (v51, I think; whichever version it was where the base OS underwent a major update to the file system permissions) fixed in user-patched Quest Mixed Reality Calibration App over on SideQuest? 

... or is MRC *still* no longer officially supported on Quest 3, @The_1st_Dark_Lord_Morgoth? We're just lucky if we can get it working? Is that the official answer? 

You may be right! I read somehwere about the Reality Mixer app is no longer able to push the calibration to the device. Which could be related to Android 12's new file permission limitations. Thank you for this insight! I'll give this a try as soon as I can!

I also want to put this here, because I overlooked it before. But, looks like every app you want to use MRC in, needs the calibration file uploaded to a unqiue folder in Android/Data.


The path mentioned in that link was wrong for me though. i found it here:
C:\Users\{user}\AppData\Roaming\Mixed Reality Capture\savedCalibrationData

The mrc.xml file should also be available in the Quest itself, iirc it's "/Android/Data/com.oculus.MrcCameraCalibration/files/mrc.xml"


I was able to build the game to device. I could run the game from device. Using Reality Mixer to connect MRC to my running game, did not show any errors in Reality Mixer, but Reality Mixer showed black screen. And in headset, the app essentially black screened (its a passthrough app, so all game objects just disappeared).

Logcat did show an error.

I checked the Tombstone file, but it was empty and 0 kb.





I just tried "Thrill of the Fight" and MRC works instantly in the Reality Mixer App. Both in Mixed Reality and Regular. I may need to reach out to that dev and see what he did.

Does the game's sound audible on the RealityMixer app?

I have the same experience with latest BeatSaber version, RealityMixer showed black screen in mixed reality mode, no audio either. But in BeatSaber version 1.28.0, the mixed reality mode works just fine. 

Most of content i create is based on mrc or greenscreen. I can confirm that mrc/reality mixer worked for me in April 2024 on After the Fall as well as Pixel Ripped 1989 and Pixel Ripped 1995

What development engine do you use?

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?