cancel
Showing results for 
Search instead for 
Did you mean: 

Just give up

stubble88
Level 4

When I first bought the quest 2 everything worked fairly well. But anything over Questlink has become “VIRTUALLY” useless!!!  
ALYX at first ran great. Now I can play for a bit then everything becomes unbearably laggy after a couple minutes. Wired or wireless.  Doesn’t matter. 
I’ve spent hours with tech support. ( they are great). But nobody seems to know what’s going on with this severe lag on quest link.  I’ve tried all the tricks in the book (internet).  I’m tired. These units should be free if we are to be test subjects. I’m trying to squeeze in some VR between work and family. Now I have to spend that just trouble shooting. It’s ridiculous.  They are smart though. Sell the system, and let the users become our free testers. 

1 REPLY 1

stubble88
Level 4

It’s also amazing that when you get support they blame everything outside there unit.  Don’t ask me to update my drivers, windows, change the oil in my car.  It doesn’t do shiatsu.