Showing results for 
Search instead for 
Did you mean: 

[Kinda solved] Rift S disconnecting after a few minutes, then reconnecting by itself

Level 2

"Fix": It appears that my cable was broken, I contacted support and got a new one withhin a week, even though I'm pretty sure the warranty already expired. I had no problems at all so far. So if you experience similar problems, make sure to look at your cable toroughly and probably contact support.


Edit: Well, after not getting to use the headset for like a month, I tried it again today and get no display port connection at all. After close inspection it seems that my cat chewed on the cable and it's broken. Thanks to Oculus I can't get an official new cable, and inofficial ones are 150€+, I'll try to contact support.


So since about a month ago my 2 year old Rift S just crashes after about 20 minutes (Sometimes more, sometimes less) of use. I don't remember anything changing between it working and not working. Both SteamVR and Oculus games are affected. The picture suddenly just freezes and there's a high pitched sound. Then there's a disconnect sound, I hear very loud static and the headset goes black. The LED then turns red and the Oculus Software tells me to reconnect my Display Port cable, however after about a minute of not changing anything the Headset reconnects by itself and everything works perfectly again for the next 20 minutes. During the time where it shows a black screen, the games run in the background, and my PC still works, but my mouse and keyboard are basically frozen. Because of that I suspected that maybe my PC was just not powerful enough to handle some moments in these games, but it also crashes while playing Gorilla tag, so I doubt that it's an issue with my PC. I also don't think the issue is the cable physically disconnecting, since I also had it happen in seated games in moments where I didn't make any sharp movements.


What I've tried so far:

  • Trying every possible Display Port
  • Trying every possible USB 3.0 port
  • Turning off everything connected to my PC except for one screen, my mouse and my keyboard
  • Updating Windows and my Nvidia drivers
  • Removing the Rift S USB hubs in the device manager
  • Reinstalling the Oculus App
  • Making sure that power save if off for the USB ports
  • Replugging the cable on the headset side
  • Changing the sound output device to something other than the Rift S

And my PC Specs, in case it matters:

  • Intel(R) Core(TM) i7-8700 CPU @ 3.20GHz 3.19 GHz
  • 16 GB Ram
  • 64 Bit
  • Geforce GTX 1070

Community Manager
Community Manager

Hey Salticus! Having your Rift S disconnect then reconnect on its own is definitely an issue that needs to be resolved. Thank you for laying out your current troubleshooting steps. Your current OS may need to be updated, and we will need a little bit more information from you, such as a log, etc. So we highly recommend that you place a support ticket with us so one of our specialists can take a deep dive into your issue. Thank you!

You cant get a support ticket for the Rift S now. It only shows that junk Quest 2 support.

Level 4

Dude, I have had the same exact problem since two years ago when I first bought this HUNK OF JUNK. And now these scams want $150+ for a new cable which may or probably wont work. Oculus has completely RIPPED ME OFF with their inferior NO-WORKING PRODUCT. No joy, no fun, all headaches and frustration and failed MSFS2020 flights. I only bought it for flight sims and it fails completely on all levels. The only thing good about the Rift S is the comfort on your head. They ruined that with the JUNK flimsy plastic Quest 2 which I also own that has a picture like total crap and cant display MSFS2020 or any other flight sim properly. Go with Vario or Pimax. F Oculus. And MORE OVER, this company has made zero effort to fix this problem. I doubt they have even contacted Asobo or visa versa to discuss integration with MSFS2020. Oculus failed to work to fix this problem. They only throw these bots in the comments to issue stupid directions that fix nothing. Meanwhile what have the engineers at Oculus done to address this disconnect issue that a good percentage of users are having? Nothing as far as I can tell. I dont even know if I should be using the test beta or not for the latest updates always change this between the sim and Oculus. What a fricking mess of a disaster this VR is. For as many users using VR with MSFS2020, DCS and XP11/12, there should be a fixed comment section here concerning only these sims. And yet there is no such thing.