Showing results for 
Search instead for 
Did you mean: 

Known Isssue - Unstable wifi covarage with Quest 3 on some Router Brands.

Expert Protege

On my Quest 3


The WIFI signal is hopping from 720 - 864 - 960 

But my Quest 2


Is stable at 1200 Mbps

I am sitting 1 m from the Ruter

Is my Quest 3 broken or is this a bug?


Edit FYI: This is a firmware bug with communication between some brand of routers. Please post your info here as a reply.

(Se MetaQuestSupports reply)

The team has been made aware and is currently looking into the unstable connection reports.

Meta needs to know:

  1. What version is your headset running? (Full number, i.e. 57.0.0.####)
    • Quick Settings > System > Software Update
  2. Which router do you currently have?
  3. Tag @MetaQuestSupport 

Also.. Remember to send a bug report via Oculus apps or headset...

Here is how:


Edit 2, to be clear: 

The issue is not dependent on AirLink or VirtualDesktop. It's a clear communication issue between the Quest 3 and certain routers in Quest build vertion 57.  That effects both 5Ghz and 6Ghz. Quest 2 is unaffected.

Here is the issue we are facing demonstrated to TP-link:


If you're r not experiencing any issues please post the details on this seperate thread:


Edit 3 - Update:

Version 59 showed no improvement. TP-Link has received a unit and are experiencing the same negotiation rate problems. They are investigating the problem. 


@MetaQuestSupport has stated that they are working on the issue and it will be fixed in a future firmware update.


Edit 4 - Update...
TP-Watched  @VirtualOmnipresence 's video  and confirmed: 

Our Wireless RD found that it might be the case Quest3 are kind Quest3's wireless connection rate strategy is more aggressive in terms of speed reduction. Once it encounters wireless packet loss or interference, it will reduce the negotiation rate on a large scale, thus affecting the actual wireless performance.

In other words, it is actually unnecessarily overly sensitive... especially when interference is basically impossible at 6GHz.

We've tested the Quest3 v57(haven't got v59 yet) so far with almost all our routers from wifi6e to wifi7 with QCA/BCM chipest...

Also thanks a lot for your updates about that article, we will also notice to get the previous quest2 sample to check how it works with our router in old firmware, then upgrade it to newer one for checking.

We will also focus on this issue later quickly if there's new firmware released.

Thanks a lot for your valued feedback and understanding


Edit 5 - November 20th 2023

Still no more contact with meta and the silence is deafening. 

Though with the new update to v.59 it is actually a lot better on AXE75 for both 5g and 6g. It's fluxing, but not below 1200 in 6g and not below 720 in 5g. Making it... "usable"... if you are relatively close to your router.

Version, Runtime Version, OS Version SQ3A.220605.009.A1

But we still want to take advantage of the 2401 Mbps so that we are not reliant on no interference and being 2 to 3 meters from the access point. 

Any working 6Ghz device connected to a 6 Ghz router, dedicated at close range should output a connection at 2401Mbps. If it doesn't it's simply not working correctly. 

So I'm not giving you a pass just yet Meta. 😉


Edit 6 December 8th

A lot of new posts here and in my community on still experiencing this issue making their wireless experience unbearable. The uptick has been noticeable since the release of SteamLink bringing more people over to PC wireless. 

I also go a new confirmation from MetaSupport over email:

Hello Thomas,

This is _____ again from Meta Store Support following up on your issue.

To clarify, the issue you are experiencing is most likely to be patched up with a new software update.

I know how inconvenient this may be for you. We really appreciate your extended patience and utmost understanding regarding this matter.

As much as I would like to give you an exact timeline, since this is still a known issue, I'm afraid we are still unable to provide an exact date for it.

This is also for our customers, as we don't want to set you an expectation that is vague. We value transparency here at Meta, and we can assure you that we will quickly contact you as soon as possible once the issue is resolved or workarounds are provided.

We're eager to have this one sorted out for you, so we'll keep an eye on this issue. Looking forward to solve this issue at your earliest convenience so you can proceed enjoying your VR experience.

527 REPLIES 527

Honored Guest

My Quest 3 also doesn't find my 6ghz WiFi and 5ghz is fluctuating between 1900 and 2400.

  1. Version:
  2. Router: Tenda Nova AXE5700 - MX21 Pro


and did you get it?

OK I got it and set it up

Note this is in a similar setup to before:

Original setup was GT-AX11000 PRO + GT-AX6000 mesh - Quest exclusively on 5GHz-2

Now setup is GT-AXE16000 + GT-AX6000 mesh - Quest exclusively on 6GHz

RESULTS: Quest 3 had no difficulties locating and staying connected to the 6GHz band of the GT-AXE16000, connection remained stable throughout testing.  The link speed on v59 on 6GHz with the GT-AXE16000 was extremely similar to the GT-AX11000 PRO on 5ghz at 160mhz channel width, which is what I expected - between 2401mbps and 2161mbps.  Latency, was maybe 1 or 2ms better on the 6ghz band? Nothing to write home about that was noticable in gameplay.  In terms of signal strength, a room over from the router and through a wall the 6ghz radio was about 15db worse than the 5ghz radio, so if you don't plan to play in the same room, 6ghz is a bad idea.

In summary, if you want a 6ghz router, I can confirm the Quest 3 works well with the GT-AXE16000.  However, if you are able to maintain a 160mhz channel width 5ghz band without interference, expect little to no improvement from the GT-AX6000 or GT-AX11000 PRO to the GT-AXE16000. This is what I expected theoretically, but have now confirmed it in testing.  The main improvement with the GT-AXE16000 is getting a wide open 6ghz band, if you need that.

In summary, I can confirm the GT-AX6000, GT-AX11000 PRO, and GT-AXE16000 all work incredibly well with the Quest 3, and the one to buy of these three depends on your home network circumstances/wifi interference.

UPDATE: I have now played 3 hours or so straight of Asgard's Wrath over virtual desktop, 200mbps AV1 10-bit, Godlike, 90hz.  Worked flawlessly on the 6ghz band of the GT-AXE16000.


My Quest 3 doesn't find my 6ghz WiFi and 5ghz is fluctuating between 1700 and 2400.

  1. Version:
  2. Router: TP-Link Archer AXE75



Same problem with my Quest 3 and D-Link VR Air Bridge.
Can't do fixed bitrate of 200 Mbit/s via Airlink.
PCVR is getting shaggy and messy after some minutes. Dynamic 200 Mbit/s works though. But the quality is bad.
My D-Link VR Air Bridge is 2-3 meters away from me on a table.

Quest 3 has v59.


I am having all kinds of problems with the Quest 3 (at. V59, specifically) and my Comcast XB8, a Wifi 6E router. It was fine under the XB7 - a Wifi 6 router (no 6GHz) but as soon as I upgraded to the XB8, which is Wi-Fi 6E, it's been nothing but problems. I can't load the store or the TV app at all on the Quest 3. Apps run fine but anything that needs Internet access doesn't work. Virtual Desktop works more or less fine if I am sub 90 Mbps, but there are spikes in the signal at anything above that. And I am sitting next to the Router with a solid 2400 Bit connection. If I connect to the XB7- at 5 GHz - there are no problems at all. If I connect to a mobile hotspot off my phone, at  5Ghz Wifi 6 - there are no problems at all. My quest 2 and Pro run fine no problems at all. It's something to do with Wi-Fi 6E implementation on this specific device. And I believe it's software regulated because the problems weren't that bad on the previous version. But they still existed. It's definitely a 6 GHz issue.

Just as a counterpoint I tried the Asus GT-axe16000 and 6ghz works flawlessly . So it's not strictly 6 GHz, but there does seem to be some unoptimized Wi-Fi code in these initial Quest3 builds that appears not to work well with certain router chipsets

Where is @MetaQuestSupport ?


the silence on this matter is deafening 




I’ve done more testing with the Comcast router. It’s just the 6 GHz band. If I create a separate network on the thing at 5 GHz everything is fine. So it’s Wi-Fi 6E specifically