Showing results for 
Search instead for 
Did you mean: 

Known Isssue - Unstable wifi covarage with Quest 3 on some Router Brands.

Expert Protege

On my Quest 3


The WIFI signal is hopping from 720 - 864 - 960 

But my Quest 2


Is stable at 1200 Mbps

I am sitting 1 m from the Ruter

Is my Quest 3 broken or is this a bug?


Edit FYI: This is a firmware bug with communication between some brand of routers. Please post your info here as a reply.

(Se MetaQuestSupports reply)

The team has been made aware and is currently looking into the unstable connection reports.

Meta needs to know:

  1. What version is your headset running? (Full number, i.e. 57.0.0.####)
    • Quick Settings > System > Software Update
  2. Which router do you currently have?
  3. Tag @MetaQuestSupport 

Also.. Remember to send a bug report via Oculus apps or headset...

Here is how:


Edit 2, to be clear: 

The issue is not dependent on AirLink or VirtualDesktop. It's a clear communication issue between the Quest 3 and certain routers in Quest build vertion 57.  That effects both 5Ghz and 6Ghz. Quest 2 is unaffected.

Here is the issue we are facing demonstrated to TP-link:


If you're r not experiencing any issues please post the details on this seperate thread:


Edit 3 - Update:

Version 59 showed no improvement. TP-Link has received a unit and are experiencing the same negotiation rate problems. They are investigating the problem. 


@MetaQuestSupport has stated that they are working on the issue and it will be fixed in a future firmware update.


Edit 4 - Update...
TP-Watched  @VirtualOmnipresence 's video  and confirmed: 

Our Wireless RD found that it might be the case Quest3 are kind Quest3's wireless connection rate strategy is more aggressive in terms of speed reduction. Once it encounters wireless packet loss or interference, it will reduce the negotiation rate on a large scale, thus affecting the actual wireless performance.

In other words, it is actually unnecessarily overly sensitive... especially when interference is basically impossible at 6GHz.

We've tested the Quest3 v57(haven't got v59 yet) so far with almost all our routers from wifi6e to wifi7 with QCA/BCM chipest...

Also thanks a lot for your updates about that article, we will also notice to get the previous quest2 sample to check how it works with our router in old firmware, then upgrade it to newer one for checking.

We will also focus on this issue later quickly if there's new firmware released.

Thanks a lot for your valued feedback and understanding


Edit 5 - November 20th 2023

Still no more contact with meta and the silence is deafening. 

Though with the new update to v.59 it is actually a lot better on AXE75 for both 5g and 6g. It's fluxing, but not below 1200 in 6g and not below 720 in 5g. Making it... "usable"... if you are relatively close to your router.

Version, Runtime Version, OS Version SQ3A.220605.009.A1

But we still want to take advantage of the 2401 Mbps so that we are not reliant on no interference and being 2 to 3 meters from the access point. 

Any working 6Ghz device connected to a 6 Ghz router, dedicated at close range should output a connection at 2401Mbps. If it doesn't it's simply not working correctly. 

So I'm not giving you a pass just yet Meta. 😉


Edit 6 December 8th

A lot of new posts here and in my community on still experiencing this issue making their wireless experience unbearable. The uptick has been noticeable since the release of SteamLink bringing more people over to PC wireless. 

I also go a new confirmation from MetaSupport over email:

Hello Thomas,

This is _____ again from Meta Store Support following up on your issue.

To clarify, the issue you are experiencing is most likely to be patched up with a new software update.

I know how inconvenient this may be for you. We really appreciate your extended patience and utmost understanding regarding this matter.

As much as I would like to give you an exact timeline, since this is still a known issue, I'm afraid we are still unable to provide an exact date for it.

This is also for our customers, as we don't want to set you an expectation that is vague. We value transparency here at Meta, and we can assure you that we will quickly contact you as soon as possible once the issue is resolved or workarounds are provided.

We're eager to have this one sorted out for you, so we'll keep an eye on this issue. Looking forward to solve this issue at your earliest convenience so you can proceed enjoying your VR experience.

527 REPLIES 527

I have 4090. Dynamic looks bad because it never does 200 Mbits. Furthermore Air Bridge should work.

"Air Bridge isn't recommended by the developer of Virtual Desktop": It's by Meta/D-Link. So it should work with Quest 3.

I have all new updates for Quest 3.

Honored Guest

hope they fix it soon its been driving me mad i dint realise it first and noticed blocky image sometimes and not very clear, checked my connection speed to me ax211 wi fi 6e i had set at 6ghz and it was only connecting with a speed of 289mb/s, i  did loads took virtualization software off the pc everything , re installed windows 11 and drivers and still same issue glad i am not the only one and its recognised but i hope they can fix this soon otherwise i have to stick to connecting through virgin router and that's not good i only get 600mbs and increased latency of going through router . my quest 2 was 5ghz 1200mbps every time if it didn't connect full speed first time just disconnect reconnect and it sorted the problem out. have tried every fix for quest 3 command line different drivers no difference max i get is 20mhz channel with and 289mb/s with odd spike to 300mbps but lows go down as low as 75 mbps and the lows happen more often than the spikes upwards.


come on oculus my pc cant charge my quest 3 very good and dies too fast and have to use a wall charger so wi fi is a must  as i mainly pay car and flight sims so charge cable is no problem but charge rate is need to get a better wall charger too and a mobovr v3 with couple extra battery's

Honored Guest

Man I'm pretty sad this hasn't been fully fixed yet. I have my main router (Orbi RBS850 - Wifi 6) that is then connected to my PCVR dedicated router (Eero Pro 6e - Wifi 6e) and my Mpbs has been jumping between 2400 and 1000 Mpbs on 6ghz. If it's just my main router (Orbi), it would be between 1200 and 400 Mpbs on 5ghz.

I am also very close to my router(s) as I'm playing it in the same room where the router(s) is. Using the most up to date drivers for my Quest 3, Windows 11, network equipment drivers, and NVIDIA drivers.

I also tested it if my Mbps still jumps when just using either just my main router or just my dedicated router, and the problem still persists sadly. Hopefully this gets fixed soon.

Update: Now it's just not letting me use the 6ghz bandwidth. Sometimes it works, sometimes it doesn't.

The framerate/stutter/tracking issue still persists in the PTC v60 and Meta doesn't even reply on the matter anymore aside from the ususal half-automated post to use the repair functions that have no effect.

Expert Protege
Finally i got an email response from Meta support. Hopefully we can start having a real conversation. 
On Fri, 24 Nov 2023 at 09:49, Meta Store Support wrote:
Hello Thomas, 

I would like to sincerely apologize for the late response as we are currently facing a high volume of request at this time. Rest assured we are still fully committed to addressing your concerns and making sure you well taken care of. 

My name is ------ and I will be serving as your next level support.  I would like to thank you for the feedback and providing the thread in your email. We would first like to confirm if you are still experiencing an unstable connection with your Wi-Fi when using your headset. 

If you are could you please provide the serial number to your headset? 

Once this has been provided our team will look into this further and provide you possible solutions for this. 

Meta Store Support

My response:

SN: --------------------

But you won't find a solution to this without updating the Firmware.
I have several users on the forums and in my youtube community who have the same issue. And there is simply something wrong with your communication protocols.
A working device should have a stable 2401 Mbps connection in close range if it is dedicated. Right now it's fluxing from 1080 to 2100 Mbps. And that's just from reading the connection details on the headset. (No PC involved)
TP-Link are trying to get in contact with your engineers because they want to help you fix the issue. They are of course interested in having the Quest 3 hardware working as well as possible with their network units. They have their own headsets now, one in the US office and one in shenzhen kina. Both are experiencing the same issues.
This is what we have found so far:
  • After trying to change channel and adjust wireless function, it still only randomly gets MCS9 negotiation, even in a short distance, at which it should have full speed and MCS 11 without any issue.
  • Both v57 and v59 are experiencing package losses on the Quest 3
  • Quest3's wireless connection rate strategy is more aggressive in terms of speed reduction. Once it encounters wireless packet loss or interference, it will reduce the negotiation rate on a large scale, thus affecting the actual wireless performance.In other words, it is actually unnecessarily overly sensitive... especially when interference is basically impossible at 6GHz.
Please share my contact in TP-links email with your engineering team:


His name is ----- Senior Technical Support at TP-Link Shenzhen
Email is ----------------

Don’t get too excited… none of those emails make it anywhere near real support engineering.

their next email to you (in a few weeks) will be “can we have you factory reset your headset and try again…”

The fact that they are asking you for a serial number and asking if you still have an issue with a problem that they haven’t resolved is the clue here it’ll go nowhere.

Expert Protege

Yeah they're the most useless support I've ever been through. They're in India, have no idea what's going on and their goal is basically to stall the conversation until you give up.

I said this a while back but it's worth repeating, meta definitely knows about this problem and has known about it for some time.   But you still have to develop and test a fix, and this issue probably isn't the highest priority due to lesser focus on PCVR

Supports not going to be able to do anything other than give you an RMA, and your replacement will have exactly the same problem

While it's frustrating the only options are to just wait or buy one of the few known good routers. Starting to look from reports that the MSI Radix AXE6600 is a viable option under $200, btw 


after playing a few days with link cable i was trying to set up airlink today. First i got no connection because of my firewall. Just when i disabled the firewall oculus PC app could connect via airlink to the Quest 3 and shows that connection is fine. But if i start the Air link in the headset i got only black screen with the 3 loading dots. Nothing happens...sometimes there is only black screen with no loading dots...I may see a little flickering thing for a milisecond when the three dots disappear but this can be imagination too...after that i could only look into the black abyss. Touch controllers are not visible.


I now have updatet to the latest Nvidia drivers which made no difference.

Reinstalling Oculus app and restarting both devices a few times did also nothing.


My PC is a bit older Gaming rig from 2018 (ASUS ROG STRIX 1080ti, i7 8700K). But 1080 is listed in the supported Devices List and cable link works just fine. Do you know what problem i could have?


Router is a ASUS RT-AX58U. Connected to 5ghz Wlan and activated 160mhz band.

After that process switching back to cable link works directly like a charm.


Maybee someone who had a similar problem here? Found a few threads where people with laptops had Problems like this... but mine is a normal tower PC.

my laptop is fine but my tower pc for sim racing has this issue. Seems a lot of others have recently run into it and when i have oculus console up i see a lot of errors regarding image casting, inability to edit files etc.. working with support