Showing results for 
Search instead for 
Did you mean: 

Known Isssue - Unstable wifi covarage with Quest 3 on some Router Brands.

Expert Protege

On my Quest 3


The WIFI signal is hopping from 720 - 864 - 960 

But my Quest 2


Is stable at 1200 Mbps

I am sitting 1 m from the Ruter

Is my Quest 3 broken or is this a bug?


Edit FYI: This is a firmware bug with communication between some brand of routers. Please post your info here as a reply.

(Se MetaQuestSupports reply)

The team has been made aware and is currently looking into the unstable connection reports.

Meta needs to know:

  1. What version is your headset running? (Full number, i.e. 57.0.0.####)
    • Quick Settings > System > Software Update
  2. Which router do you currently have?
  3. Tag @MetaQuestSupport 

Also.. Remember to send a bug report via Oculus apps or headset...

Here is how:


Edit 2, to be clear: 

The issue is not dependent on AirLink or VirtualDesktop. It's a clear communication issue between the Quest 3 and certain routers in Quest build vertion 57.  That effects both 5Ghz and 6Ghz. Quest 2 is unaffected.

Here is the issue we are facing demonstrated to TP-link:


If you're r not experiencing any issues please post the details on this seperate thread:


Edit 3 - Update:

Version 59 showed no improvement. TP-Link has received a unit and are experiencing the same negotiation rate problems. They are investigating the problem. 


@MetaQuestSupport has stated that they are working on the issue and it will be fixed in a future firmware update.


Edit 4 - Update...
TP-Watched  @VirtualOmnipresence 's video  and confirmed: 

Our Wireless RD found that it might be the case Quest3 are kind Quest3's wireless connection rate strategy is more aggressive in terms of speed reduction. Once it encounters wireless packet loss or interference, it will reduce the negotiation rate on a large scale, thus affecting the actual wireless performance.

In other words, it is actually unnecessarily overly sensitive... especially when interference is basically impossible at 6GHz.

We've tested the Quest3 v57(haven't got v59 yet) so far with almost all our routers from wifi6e to wifi7 with QCA/BCM chipest...

Also thanks a lot for your updates about that article, we will also notice to get the previous quest2 sample to check how it works with our router in old firmware, then upgrade it to newer one for checking.

We will also focus on this issue later quickly if there's new firmware released.

Thanks a lot for your valued feedback and understanding


Edit 5 - November 20th 2023

Still no more contact with meta and the silence is deafening. 

Though with the new update to v.59 it is actually a lot better on AXE75 for both 5g and 6g. It's fluxing, but not below 1200 in 6g and not below 720 in 5g. Making it... "usable"... if you are relatively close to your router.

Version, Runtime Version, OS Version SQ3A.220605.009.A1

But we still want to take advantage of the 2401 Mbps so that we are not reliant on no interference and being 2 to 3 meters from the access point. 

Any working 6Ghz device connected to a 6 Ghz router, dedicated at close range should output a connection at 2401Mbps. If it doesn't it's simply not working correctly. 

So I'm not giving you a pass just yet Meta. 😉


Edit 6 December 8th

A lot of new posts here and in my community on still experiencing this issue making their wireless experience unbearable. The uptick has been noticeable since the release of SteamLink bringing more people over to PC wireless. 

I also go a new confirmation from MetaSupport over email:

Hello Thomas,

This is _____ again from Meta Store Support following up on your issue.

To clarify, the issue you are experiencing is most likely to be patched up with a new software update.

I know how inconvenient this may be for you. We really appreciate your extended patience and utmost understanding regarding this matter.

As much as I would like to give you an exact timeline, since this is still a known issue, I'm afraid we are still unable to provide an exact date for it.

This is also for our customers, as we don't want to set you an expectation that is vague. We value transparency here at Meta, and we can assure you that we will quickly contact you as soon as possible once the issue is resolved or workarounds are provided.

We're eager to have this one sorted out for you, so we'll keep an eye on this issue. Looking forward to solve this issue at your earliest convenience so you can proceed enjoying your VR experience.

527 REPLIES 527

So finally got my Quest 3 yesterday and was thrilled to continue my playthrough of Propagation Paradise Hotel. Only to find that the tracking of the controllers in AirLink is totally broken. It's like they are moving at 6 fps and its impossible to aim.

Tried using USB Link and there they work fine!

(Also my Quest 2 controllers work grate in Airlink)

I Hope this is a bug an not a limitation of the new controllers.  

Don't know what I did... but after testing virtual desktop, where the controllers worked fine. I went back to AirLink and now they are better... still not grate for fast movements but a lot more usable.

Nope... never mind. Back to choppy.. feel like maybe the device has worst WIFI coverage then to quest 2... Can that be the case?

On my Quest 3


The WIFI signal is hopping from 720 - 864 - 960 

But my Quest 2


Is stable at 1200 Mbps

I am sitting 1 m from the Ruter

Is my Quest 3 broken or is this a bug?




I am having the same exact issue. Trying to figure out if it's a faulty antenna, intended (but problematic) antenna, or firmware/driver issues on the Quest 3.

Since my Quest 2 has full speed I'm hoping its a quest 3 firmware issue.

Also check to make sure that your own networking equipment has all of its required firmware updates. Sometimes if a newer gadget is using newer TCP/IP specifications than what a router with older firmware supports, you won't get the best performance possible. I've seen the same with bluetooth as well. Everything works fine until a new device shows up and then all the old devices need updating to be fully compatible.

Don't get my hopes up like that. 😅

Took a full firmware update on my entire network. Still very unstable unfortunately 

Expert Protege

For context. I connect my headset to a dedicated 1500Mbps Wifi6 Accsess Point wired into my main network. My PC is also wired.

(Both my main Ruter (TP-link TP-AX1800 wifi6) and AP (TP-link RE-505X wifi6) has the latest firmware.)

In otherwords nothing else is using that particular wifi signal so we can rule out interference.