Showing results for 
Search instead for 
Did you mean: 

Known Isssue - Unstable wifi coverage with Quest 3 on some Router Brands.

  • Update January 2024 - full post history below
Hi. Let me try to give a quick TLDR summery.
Since the launch of the Quest 3, numerous users have encountered difficulties with their Wi-Fi connections related to wireless PCVR. A notable bug affects certain mid-range AX and AXE routers, such as TP-Link's AXE75, leading to significant packet losses and varying negotiation rates. Consequently, connection speeds fluctuate between 480 and 1921 Mbps, occasionally reaching 2161 Mbps but rarely achieving the full 2401 Mbps speed.
In contrast, the Quest 2 maintains a stable 1200 Mbps on 5GHz dedicated networks. However, on release, the Quest 3 struggled to reach 720 Mbps, with speed fluctuations occurring every other second.
Meta was promptly notified of this issue on launch day and has been working on resolving it through build updates. Versions v.57 to v.60 have seen a dramatic reduction in negotiation rates, making wireless VR "usable" under certain conditions, particularly when in close proximity to the router and within the line of sight. Nevertheless, users still report random speed reductions to unusable levels (below 740 Mbps), even at close range.
TP-Link has been diligently working on resolving the issue since the initial launch. Unfortunately, their latest update indicates that they couldn't make a breakthrough on their end, and they believe the problem persists on the client side. They've conducted thorough tests with various chipsets, including MTK, BCM, and QCA routers, and it seems these routers are experiencing similar issues. Their focus shifted to Meta software updates, and their most recent test with the Quest3 V60 suggests that while the negotiation rate still varies, the occasional streaming lag seems to have disappeared.
A glance at this threads posts reveals that TP-Link is not the only affected brand; users with Asus and other AX and AXE routers also face similar challenges. The root cause seems to be linked to either Meta or Qualcomm. Users have noted similar issues with the Google Pixel 7, leading to speculation about problems with the XR2 Gen2/Snapdragon 8 Gen2 drivers. So in other words it's in Meta and Qualcomm's hands at the moment.
Please reply to this thread and post your information as per Metas instructions:
"December 14th Update from @MetaQuestSupport 
Hey everyone! I wanted to let you all know that I heard back from our engineering team. It looks like there might've been some changes with the recent v60 update. I recommend checking your headset to make sure that it is updated to the latest version, and then checking your Wi-Fi connection with your headset. If you're still having trouble after updating your headset, please let me know the below information and I'll pass it along to our engineering team so this can be looked into further.
 1. Router make and model.
 2. Router firmware.
 3. Full Headset version. (59.0.0.##) Go to Settings > System > Software Update"
You can also make a video grab of your issue and send it to Meta over the "report a problem" option in the headset.
NOTE: If you have a working setup with a different router and not experiencing any issues please post the details on this separate thread:
Original post October 10th 2023

On my Quest 3 the WIFI signal is hopping from 720 - 864 - 960 

But my Quest 2 ti stable at 1200 Mbps

I am sitting 1 m from the Ruter

Is my Quest 3 broken or is this a bug?


Edit FYI: This is a firmware bug with communication between some brand of routers. Please post your info here as a reply. (Se MetaQuestSupports reply)

The team has been made aware and is currently looking into the unstable connection reports.

Meta needs to know:

  1. What version is your headset running? (Full number, i.e. 57.0.0.####)
    • Quick Settings > System > Software Update
  2. Which router do you currently have?
  3. Tag @MetaQuestSupport 

Also.. Remember to send a bug report via Oculus apps or headset...

Here is how:


Edit 2, to be clear: 

The issue is not dependent on AirLink or VirtualDesktop. It's a clear communication issue between the Quest 3 and certain routers in Quest build vertion 57.  That effects both 5Ghz and 6Ghz. Quest 2 is unaffected.

Here is the issue we are facing demonstrated to TP-link:


If you're r not experiencing any issues please post the details on this seperate thread:


Edit 3 - Update:

Version 59 showed no improvement. TP-Link has received a unit and are experiencing the same negotiation rate problems. They are investigating the problem. 


@MetaQuestSupport has stated that they are working on the issue and it will be fixed in a future firmware update.


Edit 4 - Update...
TP-Watched  @VirtualOmnipresence 's video  and confirmed: 

Our Wireless RD found that it might be the case Quest3 are kind Quest3's wireless connection rate strategy is more aggressive in terms of speed reduction. Once it encounters wireless packet loss or interference, it will reduce the negotiation rate on a large scale, thus affecting the actual wireless performance.

In other words, it is actually unnecessarily overly sensitive... especially when interference is basically impossible at 6GHz.

We've tested the Quest3 v57(haven't got v59 yet) so far with almost all our routers from wifi6e to wifi7 with QCA/BCM chipest...

Also thanks a lot for your updates about that article, we will also notice to get the previous quest2 sample to check how it works with our router in old firmware, then upgrade it to newer one for checking.

We will also focus on this issue later quickly if there's new firmware released.


Edit 5 - November 20th 2023

Still no more contact with meta and the silence is deafening. 

Though with the new update to v.59 it is actually a lot better on AXE75 for both 5g and 6g. It's fluxing, but not below 1200 in 6g and not below 720 in 5g. Making it... "usable"... if you are relatively close to your router.

Here is my video in my test with v. 59.

We still want to take advantage of the 2401 Mbps so that we are not reliant on no interference and being 2 to 3 meters from the access point. 

Any working 6Ghz device connected to a 6 Ghz router, dedicated at close range should output a connection at 2401Mbps. If it doesn't it's simply not working correctly. 

So I'm not giving you a pass just yet Meta. 😉


Edit 6 December 8th

A lot of new posts here and in my community on still experiencing this issue making their wireless experience unbearable. The uptick has been noticeable since the release of SteamLink bringing more people over to PC wireless. 

I also go a new confirmation from MetaSupport over email:

Meta Store Support following up on your issue.

To clarify, the issue you are experiencing is most likely to be patched up with a new software update. I know how inconvenient this may be for you. We really appreciate your extended patience and utmost understanding regarding this matter. As much as I would like to give you an exact timeline, since this is still a known issue, I'm afraid we are still unable to provide an exact date for it.

This is also for our customers, as we don't want to set you an expectation that is vague. We value transparency here at Meta, and we can assure you that we will quickly contact you as soon as possible once the issue is resolved or workarounds are provided.

We're eager to have this one sorted out for you, so we'll keep an eye on this issue. Looking forward to solve this issue at your earliest convenience so you can proceed enjoying your VR experience.



I can confirm that your issue regarding Wi-Fi connection has been coordinated with our engineering team; however, they didn't provide an exact time; maybe they are still figuring out the root cause of the issue. By the way, thank you for the clear explanation of your issue; that helps us a lot.


Edit December 14th Update from @MetaQuestSupport 

Hey everyone! I wanted to let you all know that I heard back from our engineering team. It looks like there might've been some changes with the recent v60 update. I recommend checking your headset to make sure that it is updated to the latest version, and then checking your Wi-Fi connection with your headset. If you're still having trouble after updating your headset, please let me know the below information and I'll pass it along to our engineering team so this can be looked into further.

  1. Router make and model.
  2. Router firmware.
  3. Full Headset version. (59.0.0.##)
    1. Settings > System > Software Update


Here is my video on testing version 60

1,166 REPLIES 1,166

Who is the ‘most of us’ you refer to? 

from what I can see most users are not experiencing any issue since the v62 update.  Most of the people who were on this  thread have reported the issue resolved. 

I have a solid 2401 unless I put walls in the way ( which is expected ) and I can stream at 500mbits.  If I have any stuttering it’s an issue with my PC not the wireless network.  

perhaps it’s just an issue with your headset, PC or your Ethernet cable to your router

Hi m8, i think we aren't all donkey with this device no?

3 friend all with same router and all with Quest 3 except that one of them have bought the device in october (First release) and me and the other bought device in January.

Summarizing, my friend that bought the device in october never had any issue with both of router 1)Huawei AX3 Pro 2)Xiaomi AX1800 with all firmware V59, V60, V62, opposite situation for me and my other friend, that had any of the issue reported.

We have found a workaround but only with the Xiaomi AX1800 that giove us the opportunity to change the country to CN and use the 5Ghz Channel from 149 to 161.

With this workaround It seems that the user experience Is not bad, for sure Is not at the same level of the V62 Public Test.


Recap for who thinking that claim Is the new 2024 job, not all quest3 mount same antenna or same component, it's the only explanation why we don't have the same problem.



i still have problems especially when using the oculus software i have to use virtual desktop on 5ghz at 2400mbs . if i elct 6E channel it goes down to 1200mbs since the latest update i have reset router and done everything but it still connects at 1200mbs on the 6e channel and before the update the 6e channel was as good as the 5 ghz wifi channel but not as good as it is now the wifi 5 channel i can get 2400 and play virtual desktop at 300mbps with asset Corsa and can game ok but it does have the odd stutter still i can run the same settings on wifi 6e at 12000mbs , i dont go higher on the 5gz channel on bitrate as its not much difference for more latency and power usage 300 is already 100mbs higher  for me than the quest 2 which is a 1 third better i have an rtx 3070fe and new i wouldn't get much improvement going from quest 2 to 3  but wanted the better optics and higher resolution screen for xplane12. my system is now ready for me to save for an rtx4090 or maybe wait to see what the next line is as xplane 12 and asseto corsa are my main hobby's, those games are the one's i am building my vr system for. this will be the best of my era now so no need to take games any further i see them as sims not games so maybe a rtx 5090 my be the most i will feel i need for the games i play unless assetto corsa 2 needs an upgrade to the system if its like asset corsa that i play now and worth the investment to have it full quality or there abouts if a rtx 4090 is there abouts aging which i dont think it will be it will be the rtx 5090 at least for good vr compared with assetto corsa  depends ifi upgrade to a higher fov vr headset in the future as i would love over 130 or 140 fov horizontally for the effect of speed in your peripheral vision smaller fov makes it seem as though your going slower than you really are , its why a lot of people cannot game they dont have the sence of passing objects in their peripheral vision.


This thread is marked as resolved because most of the posters, including myself as the OP, have resolved all issues. I can't relate to or follow up on your issues unless I can replicate them.

Framerate and stuttering issues with VD or being unable to connect or stay connected to 6G are not part of the original issues of this post. They are separate issues that need to be addressed in a separate post.

So again, if you are experiencing additional issues, I advise you to use the "report a problem" function in the headset and start a new thread.

If there is a new thread I'd gladly follow it. Share a link here an I'll share the URL on the "resolved" post.


If you are still experiencing specific fluctuating speed problems due to packet losses and negotiation rates, make a video grab showing your WiFi connection speed fluctuating (randomly changing speed like 1700-2400Mbps even when staying close to the router) and post it below with your Build and Router brand. That would be related and cause to "unresolve" this thread.


Got an ASUS GT-AXE16000 (EU, so limited 6 GHz channels) after the first reports that it would help with the issue to at least make the best out of the situation. The good news was that the 6 GHz Wifi would be immediately found by the Q3 and I also never got full disconnects or needed to restart the Q3 like others. But both a dedicated 5 GHz band as well as the 6 GHz band would still have lots of lags and fluctuations (router on head level only a few feet away without obstructions in between). Playable for slower games, but killing Beat Saber Expert+ maps pretty much. Quite disappointing. The v60 update didn't really change anything about this for me either.

Now with v62 (which took a long time to become available here) the 5 GHz band improved a bit, but is still not 100% stable, maybe because there are quite a few 5 GHz networks around here already. However, the still empty 6 GHz band has outstanding performance now, at least with my config. Just finished 2 hours Beat Saber (where especially the movements within the room and raising the arms in front of the headset posed extra challenges to connectivity) without a single hiccup, for the first time ever. I changed a few settings even before and left them as they were through the v62 update, thought I'd share my router config here for others who still got issues even with that expensive router and v62, hoping that it's helpful:





VD is set to H.264 with automatic bitrate option disabled on VD Streamer and the bitrate set to max. 200 Mbps in the VR settings. I might try H.264+ with an even higher bandwidth later, but honestly in Beat Saber and a few other games I couldn't see any quality issues with 200, stability is more important for me right now and 200 Mbps will always have a higher chance of surviving smaller Wifi hiccups.

Since I mostly play SteamVR games I would prefer to use the Steam Link app for ease of use, but for some reason using it (with also 200 Mbps and even also 150) I get a small lag exactly every 20 seconds, which I think is a bug in that app, so I am sticking with VD for now.


i use virtual desktop as oculus software has serious lag and stutteres using virtual desktop i can play for a good leigtn of time but oculus i cant even get it to woork right in the main gray vr menu after enabling oculus link over wifi , if i use cable it seems to be fine but wifi and oculus link are not sorted . we are using the wifi signal you have improved but not sorted, to play wireless vr by virtual desktop as oculus link and wifi is not sorted yet.

Have same router, but I have sometimes small stutter on 5Ghz and 6Ghz seen in Beat Saber. What difficulty You play? On ranking >= Expert maps one 50-100ms lag = FAIL.

What's your network latency in BS?

Thx for settings. Will compare with mine, but I think I'll stick with link cable because I have no lag/stutters with it and 34-35ms delay at 120Hz.

Usually play Expert to Expert+, so yes, even the smallest lag would kill the score for the current song, which is why I am so happy that I don't get any at all anymore now. Latency is usually around this, often even lower (saw dips down to 28 ms):


But sure, if the cable doesn't bother you too much, go ahead with it. For me it was the single most annoying thing, I'd rather play with a few lags than with that cable. It's 2024, I barely use any wired things at all anymore, keyboard, mouse, multiple headsets, it's all wireless for me.

Hello everyone,
I am happy to tell you that with the latest update v.62 the quest 3 works also on the 6 ghz band with the discussed Asus AXE7800.
The great thing is that this happens without special parameters or configurations.
That is, if the device reveals a good signal range, the frequency will be balanced on the 6 ghz automatically.
Interesting to know also that in these days there has been an update of the firmware of this router.
I have not done any particular tests of band stability on virtual desktop / steam link ... maybe I will update you about that.
Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?