cancel
Showing results for 
Search instead for 
Did you mean: 

Known Isssue - Unstable wifi coverage with Quest 3 on some Router Brands.

tfosseli
Adventurer
  • Update January 2024 - full post history below
Hi. Let me try to give a quick TLDR summery.
 
Since the launch of the Quest 3, numerous users have encountered difficulties with their Wi-Fi connections related to wireless PCVR. A notable bug affects certain mid-range AX and AXE routers, such as TP-Link's AXE75, leading to significant packet losses and varying negotiation rates. Consequently, connection speeds fluctuate between 480 and 1921 Mbps, occasionally reaching 2161 Mbps but rarely achieving the full 2401 Mbps speed.
 
In contrast, the Quest 2 maintains a stable 1200 Mbps on 5GHz dedicated networks. However, on release, the Quest 3 struggled to reach 720 Mbps, with speed fluctuations occurring every other second.
 
Meta was promptly notified of this issue on launch day and has been working on resolving it through build updates. Versions v.57 to v.60 have seen a dramatic reduction in negotiation rates, making wireless VR "usable" under certain conditions, particularly when in close proximity to the router and within the line of sight. Nevertheless, users still report random speed reductions to unusable levels (below 740 Mbps), even at close range.
 
TP-Link has been diligently working on resolving the issue since the initial launch. Unfortunately, their latest update indicates that they couldn't make a breakthrough on their end, and they believe the problem persists on the client side. They've conducted thorough tests with various chipsets, including MTK, BCM, and QCA routers, and it seems these routers are experiencing similar issues. Their focus shifted to Meta software updates, and their most recent test with the Quest3 V60 suggests that while the negotiation rate still varies, the occasional streaming lag seems to have disappeared.
 
A glance at this threads posts reveals that TP-Link is not the only affected brand; users with Asus and other AX and AXE routers also face similar challenges. The root cause seems to be linked to either Meta or Qualcomm. Users have noted similar issues with the Google Pixel 7, leading to speculation about problems with the XR2 Gen2/Snapdragon 8 Gen2 drivers. So in other words it's in Meta and Qualcomm's hands at the moment.
 
Please reply to this thread and post your information as per Metas instructions:
 
"December 14th Update from @MetaQuestSupport 
Hey everyone! I wanted to let you all know that I heard back from our engineering team. It looks like there might've been some changes with the recent v60 update. I recommend checking your headset to make sure that it is updated to the latest version, and then checking your Wi-Fi connection with your headset. If you're still having trouble after updating your headset, please let me know the below information and I'll pass it along to our engineering team so this can be looked into further.
 1. Router make and model.
 2. Router firmware.
 3. Full Headset version. (59.0.0.##) Go to Settings > System > Software Update"
 
You can also make a video grab of your issue and send it to Meta over the "report a problem" option in the headset.
 
 
NOTE: If you have a working setup with a different router and not experiencing any issues please post the details on this separate thread: https://communityforums.atmeta.com/t5/Get-Help/What-Wifi-6e-routers-currently-works-bug-free-with-th...
 
 
pagerip.jpg
 
 
Original post October 10th 2023
 

On my Quest 3 the WIFI signal is hopping from 720 - 864 - 960 

But my Quest 2 ti stable at 1200 Mbps

I am sitting 1 m from the Ruter

Is my Quest 3 broken or is this a bug?

 

Edit FYI: This is a firmware bug with communication between some brand of routers. Please post your info here as a reply. (Se MetaQuestSupports reply)

The team has been made aware and is currently looking into the unstable connection reports.

Meta needs to know:

  1. What version is your headset running? (Full number, i.e. 57.0.0.####)
    • Quick Settings > System > Software Update
  2. Which router do you currently have?
  3. Tag @MetaQuestSupport 

Also.. Remember to send a bug report via Oculus apps or headset...

Here is how: https://www.youtube.com/watch?v=7i9Q_h_yeQQ

 

Edit 2, to be clear: 

The issue is not dependent on AirLink or VirtualDesktop. It's a clear communication issue between the Quest 3 and certain routers in Quest build vertion 57.  That effects both 5Ghz and 6Ghz. Quest 2 is unaffected.

Here is the issue we are facing demonstrated to TP-link:

https://youtu.be/JFrl9rTJH8E?si=2vBOI6E2PjGvPL_7

 

If you're r not experiencing any issues please post the details on this seperate thread: https://communityforums.atmeta.com/t5/Get-Help/What-Wifi-6e-routers-currently-works-bug-free-with-th...

 

Edit 3 - Update:

Version 59 showed no improvement. TP-Link has received a unit and are experiencing the same negotiation rate problems. They are investigating the problem. 

 

@MetaQuestSupport has stated that they are working on the issue and it will be fixed in a future firmware update. https://communityforums.atmeta.com/t5/Get-Help/Unstable-wifi-covarage-with-Quest-3-on-some-Router-Br...

 

Edit 4 - Update...
TP-Watched  @VirtualOmnipresence 's video  and confirmed: 

Our Wireless RD found that it might be the case Quest3 are kind Quest3's wireless connection rate strategy is more aggressive in terms of speed reduction. Once it encounters wireless packet loss or interference, it will reduce the negotiation rate on a large scale, thus affecting the actual wireless performance.

In other words, it is actually unnecessarily overly sensitive... especially when interference is basically impossible at 6GHz.

We've tested the Quest3 v57(haven't got v59 yet) so far with almost all our routers from wifi6e to wifi7 with QCA/BCM chipest...

Also thanks a lot for your updates about that article, we will also notice to get the previous quest2 sample to check how it works with our router in old firmware, then upgrade it to newer one for checking.

We will also focus on this issue later quickly if there's new firmware released.

 

Edit 5 - November 20th 2023

Still no more contact with meta and the silence is deafening. 

Though with the new update to v.59 it is actually a lot better on AXE75 for both 5g and 6g. It's fluxing, but not below 1200 in 6g and not below 720 in 5g. Making it... "usable"... if you are relatively close to your router.

Here is my video in my test with v. 59.

We still want to take advantage of the 2401 Mbps so that we are not reliant on no interference and being 2 to 3 meters from the access point. 

Any working 6Ghz device connected to a 6 Ghz router, dedicated at close range should output a connection at 2401Mbps. If it doesn't it's simply not working correctly. 

So I'm not giving you a pass just yet Meta. 😉

 

Edit 6 December 8th

A lot of new posts here and in my community on still experiencing this issue making their wireless experience unbearable. The uptick has been noticeable since the release of SteamLink bringing more people over to PC wireless. 

I also go a new confirmation from MetaSupport over email:

Meta Store Support following up on your issue.

To clarify, the issue you are experiencing is most likely to be patched up with a new software update. I know how inconvenient this may be for you. We really appreciate your extended patience and utmost understanding regarding this matter. As much as I would like to give you an exact timeline, since this is still a known issue, I'm afraid we are still unable to provide an exact date for it.

This is also for our customers, as we don't want to set you an expectation that is vague. We value transparency here at Meta, and we can assure you that we will quickly contact you as soon as possible once the issue is resolved or workarounds are provided.

We're eager to have this one sorted out for you, so we'll keep an eye on this issue. Looking forward to solve this issue at your earliest convenience so you can proceed enjoying your VR experience.

----

later:

I can confirm that your issue regarding Wi-Fi connection has been coordinated with our engineering team; however, they didn't provide an exact time; maybe they are still figuring out the root cause of the issue. By the way, thank you for the clear explanation of your issue; that helps us a lot.

 

Edit December 14th Update from @MetaQuestSupport 

Hey everyone! I wanted to let you all know that I heard back from our engineering team. It looks like there might've been some changes with the recent v60 update. I recommend checking your headset to make sure that it is updated to the latest version, and then checking your Wi-Fi connection with your headset. If you're still having trouble after updating your headset, please let me know the below information and I'll pass it along to our engineering team so this can be looked into further.

  1. Router make and model.
  2. Router firmware.
  3. Full Headset version. (59.0.0.##)
    1. Settings > System > Software Update

---

Here is my video on testing version 60

1,166 REPLIES 1,166

minh1987
Explorer

Hi everyone,

MY SETUP:

NETGEAR RAX43 ROUTER CONNECTED DIRECTLY TO MY PC VIA ETHERNET IN AP MODE. WIFI IS 160MHZ 5GHZ 802.11AX. PC IS WINDOWS 11.

Firstly, I have firmware v62. I believe this unstable wifi bug is still present. To compare data, you'd need to sideload an iPerf client/server apk onto your Quest 3. I prefer Magic Iperf. Next, setup an iPerf3 server on your PC. Run iPerf3 on the Quest 3 as a client with the following command: -c "Your_COMPUTER_IP" -P 10 -R -V -t 500 

This will make your Quest 3 run 10 TCP download streams for 500 seconds. Next, open Task Manager, go to the Performance tab and observe your ethernet send rate (assuming you have a dedicated router connected to your PC). As you can see from my attached video, there is predictable and constant fluctuation in transfer speed. Rarely, I may have a solid transfer speed so I do not know what triggers this fluctuation. It does not matter if I choose 80mhz or 160mhz channel width or change channel. I tested my smartphone (Galaxy S20 FE) for comparison and there is no such fluctuation so I believe this rules out problems with my router.

 

STABLE PHONE SPEEDSTABLE PHONE SPEED

 

- are you/your router in the EU or outside US (wifi regs differ)?

- just for testing, try switching to 802.11AC (still 160mhz)

I am in the USA and so is my router. I just tried switching to 802.11AC and still get the same fluctuation/instability with iPerf3. Tried with my Galaxy S20 FE and there is much better stability.

nothingname1
Explorer

I want to share my experience with v62:

It's definitely better, but not fully solved - for me at last.

Router: ASUS AXE7800 (all factory reset, therefore default settings, newest firmware, Wi-Fi 6E; 1.5-2 meters away from me with no obstacles and 1.5 meters above the ground)

PC: 7800x3d, 64 GB of RAM, RTX 4090

I am just using Oculus PC App for Airlink with fixed bitrate of 200. All other settings are default - in Oculus App and in Steam.


I sometimes have these weird situations where the picture is streamed to my headset with a delay (the picture simply tries to catch up) - also the sound. This makes it nearly impossible to play. But these problems now tend to be less frequent, and the picture will be streamed fully without a delay again after a few seconds.

 

I will be posting in the upcoming week in this thread with all the details Meta needs to have:

https://communityforums.atmeta.com/t5/Get-Help/Not-Resolved-Known-Issue-Quest-3-Airlink-micro-lags-and-stutter/td-p/1150175

DaftSpartan104
Explorer

Issue persisting for me. Constant disconnects on dedicated WIFI 6 router.


Quest Version: 63.0.0.326.363.576419514

PC App Version: 62.0.0.235.346

No PTC on either device.

No workarounds so far.

Issue is persisting with Quest 3. No issues on Quest 2 using same network/PC.

Asus RT-AX82U on latest firmware 3.0.0.4.388_24232

802.11ax. Have tried mixed and legacy on 5Ghz, separate channels, no effect.

I have tried 75-200Mbps, issue persist with any bitrate. All default settings otherwise.

System Specs-

Windows 10 22H2

AMD R9 7950X

64GB DDR5 5400

Nvidia RTX 4080

Dedicated 1Gbps port for router.

grumpy_bob
Honored Guest

Just purchased a Quest 3 today, updated to latest firmware and I have unusable amount of lag with PCVR.

Every other device is fine with full strength WiFi 6.  I just upgraded from the Quest 1 and it worked perfectly in the same room.

Specs:

Meta Quest Link App Version 63.0.0.216.361 (63.0.0.216.361)

Quest Version 63.0.0.400.363.579005045

Sofware Version 49872870063700510

Windows 11

AMD R7

32 GB DDR5

RTX 4070

WiFi 6e Eero 6

Is your PC plugged in to the network? Only the Quest should be wireless, pc should be plugged in. Are you connecting to wifi 6 or 6e? 6e has the highest throughput and the lowest latency but is also the most suseptible to physical interference; you'll need to be in the same room and line of sight. What app are you using to connect? Steam Link or Airlink? Does it happen in both?

@ziglaf 

 

PC Plugged in - Yes, ethernet

Wifi 6

Airlink

Try SteamLink if you haven't. It'll rule out settings and stuff with airlink. Some people (myself included) go back and forth depending on the game as results can vary depending on the game. 

D3ft0ne
Protege

TBH, I just noticed a weird ass issue, I think its related possibly to this thread.

Quest 3

TPlink AXE75  (directly on the table 2 meters away from head set)

Connected to PC with a cable

Nothing else on wifi6e network but quest.

Just reset to fac. def settings.

ONLY on wifi6E - when I am facing (with Quest 3 on my head) the router - the transmit / receive is solid at 2401 /2401.... Now I noticed some crazy lags in Games via Air Link or VD. when I was physically turning around.

- Well, when i Face AWAY from the router, still 2m away - my transmit / receive is constantly jumping up and down - to 1200 or so...  What the actual s.. ? I think this started with v62 / v63, i never noticed this before.

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?