cancel
Showing results for 
Search instead for 
Did you mean: 

Known Isssue - Unstable wifi coverage with Quest 3 on some Router Brands.

tfosseli
Adventurer
  • Update January 2024 - full post history below
Hi. Let me try to give a quick TLDR summery.
 
Since the launch of the Quest 3, numerous users have encountered difficulties with their Wi-Fi connections related to wireless PCVR. A notable bug affects certain mid-range AX and AXE routers, such as TP-Link's AXE75, leading to significant packet losses and varying negotiation rates. Consequently, connection speeds fluctuate between 480 and 1921 Mbps, occasionally reaching 2161 Mbps but rarely achieving the full 2401 Mbps speed.
 
In contrast, the Quest 2 maintains a stable 1200 Mbps on 5GHz dedicated networks. However, on release, the Quest 3 struggled to reach 720 Mbps, with speed fluctuations occurring every other second.
 
Meta was promptly notified of this issue on launch day and has been working on resolving it through build updates. Versions v.57 to v.60 have seen a dramatic reduction in negotiation rates, making wireless VR "usable" under certain conditions, particularly when in close proximity to the router and within the line of sight. Nevertheless, users still report random speed reductions to unusable levels (below 740 Mbps), even at close range.
 
TP-Link has been diligently working on resolving the issue since the initial launch. Unfortunately, their latest update indicates that they couldn't make a breakthrough on their end, and they believe the problem persists on the client side. They've conducted thorough tests with various chipsets, including MTK, BCM, and QCA routers, and it seems these routers are experiencing similar issues. Their focus shifted to Meta software updates, and their most recent test with the Quest3 V60 suggests that while the negotiation rate still varies, the occasional streaming lag seems to have disappeared.
 
A glance at this threads posts reveals that TP-Link is not the only affected brand; users with Asus and other AX and AXE routers also face similar challenges. The root cause seems to be linked to either Meta or Qualcomm. Users have noted similar issues with the Google Pixel 7, leading to speculation about problems with the XR2 Gen2/Snapdragon 8 Gen2 drivers. So in other words it's in Meta and Qualcomm's hands at the moment.
 
Please reply to this thread and post your information as per Metas instructions:
 
"December 14th Update from @MetaQuestSupport 
Hey everyone! I wanted to let you all know that I heard back from our engineering team. It looks like there might've been some changes with the recent v60 update. I recommend checking your headset to make sure that it is updated to the latest version, and then checking your Wi-Fi connection with your headset. If you're still having trouble after updating your headset, please let me know the below information and I'll pass it along to our engineering team so this can be looked into further.
 1. Router make and model.
 2. Router firmware.
 3. Full Headset version. (59.0.0.##) Go to Settings > System > Software Update"
 
You can also make a video grab of your issue and send it to Meta over the "report a problem" option in the headset.
 
 
NOTE: If you have a working setup with a different router and not experiencing any issues please post the details on this separate thread: https://communityforums.atmeta.com/t5/Get-Help/What-Wifi-6e-routers-currently-works-bug-free-with-th...
 
 
pagerip.jpg
 
 
Original post October 10th 2023
 

On my Quest 3 the WIFI signal is hopping from 720 - 864 - 960 

But my Quest 2 ti stable at 1200 Mbps

I am sitting 1 m from the Ruter

Is my Quest 3 broken or is this a bug?

 

Edit FYI: This is a firmware bug with communication between some brand of routers. Please post your info here as a reply. (Se MetaQuestSupports reply)

The team has been made aware and is currently looking into the unstable connection reports.

Meta needs to know:

  1. What version is your headset running? (Full number, i.e. 57.0.0.####)
    • Quick Settings > System > Software Update
  2. Which router do you currently have?
  3. Tag @MetaQuestSupport 

Also.. Remember to send a bug report via Oculus apps or headset...

Here is how: https://www.youtube.com/watch?v=7i9Q_h_yeQQ

 

Edit 2, to be clear: 

The issue is not dependent on AirLink or VirtualDesktop. It's a clear communication issue between the Quest 3 and certain routers in Quest build vertion 57.  That effects both 5Ghz and 6Ghz. Quest 2 is unaffected.

Here is the issue we are facing demonstrated to TP-link:

https://youtu.be/JFrl9rTJH8E?si=2vBOI6E2PjGvPL_7

 

If you're r not experiencing any issues please post the details on this seperate thread: https://communityforums.atmeta.com/t5/Get-Help/What-Wifi-6e-routers-currently-works-bug-free-with-th...

 

Edit 3 - Update:

Version 59 showed no improvement. TP-Link has received a unit and are experiencing the same negotiation rate problems. They are investigating the problem. 

 

@MetaQuestSupport has stated that they are working on the issue and it will be fixed in a future firmware update. https://communityforums.atmeta.com/t5/Get-Help/Unstable-wifi-covarage-with-Quest-3-on-some-Router-Br...

 

Edit 4 - Update...
TP-Watched  @VirtualOmnipresence 's video  and confirmed: 

Our Wireless RD found that it might be the case Quest3 are kind Quest3's wireless connection rate strategy is more aggressive in terms of speed reduction. Once it encounters wireless packet loss or interference, it will reduce the negotiation rate on a large scale, thus affecting the actual wireless performance.

In other words, it is actually unnecessarily overly sensitive... especially when interference is basically impossible at 6GHz.

We've tested the Quest3 v57(haven't got v59 yet) so far with almost all our routers from wifi6e to wifi7 with QCA/BCM chipest...

Also thanks a lot for your updates about that article, we will also notice to get the previous quest2 sample to check how it works with our router in old firmware, then upgrade it to newer one for checking.

We will also focus on this issue later quickly if there's new firmware released.

 

Edit 5 - November 20th 2023

Still no more contact with meta and the silence is deafening. 

Though with the new update to v.59 it is actually a lot better on AXE75 for both 5g and 6g. It's fluxing, but not below 1200 in 6g and not below 720 in 5g. Making it... "usable"... if you are relatively close to your router.

Here is my video in my test with v. 59.

We still want to take advantage of the 2401 Mbps so that we are not reliant on no interference and being 2 to 3 meters from the access point. 

Any working 6Ghz device connected to a 6 Ghz router, dedicated at close range should output a connection at 2401Mbps. If it doesn't it's simply not working correctly. 

So I'm not giving you a pass just yet Meta. 😉

 

Edit 6 December 8th

A lot of new posts here and in my community on still experiencing this issue making their wireless experience unbearable. The uptick has been noticeable since the release of SteamLink bringing more people over to PC wireless. 

I also go a new confirmation from MetaSupport over email:

Meta Store Support following up on your issue.

To clarify, the issue you are experiencing is most likely to be patched up with a new software update. I know how inconvenient this may be for you. We really appreciate your extended patience and utmost understanding regarding this matter. As much as I would like to give you an exact timeline, since this is still a known issue, I'm afraid we are still unable to provide an exact date for it.

This is also for our customers, as we don't want to set you an expectation that is vague. We value transparency here at Meta, and we can assure you that we will quickly contact you as soon as possible once the issue is resolved or workarounds are provided.

We're eager to have this one sorted out for you, so we'll keep an eye on this issue. Looking forward to solve this issue at your earliest convenience so you can proceed enjoying your VR experience.

----

later:

I can confirm that your issue regarding Wi-Fi connection has been coordinated with our engineering team; however, they didn't provide an exact time; maybe they are still figuring out the root cause of the issue. By the way, thank you for the clear explanation of your issue; that helps us a lot.

 

Edit December 14th Update from @MetaQuestSupport 

Hey everyone! I wanted to let you all know that I heard back from our engineering team. It looks like there might've been some changes with the recent v60 update. I recommend checking your headset to make sure that it is updated to the latest version, and then checking your Wi-Fi connection with your headset. If you're still having trouble after updating your headset, please let me know the below information and I'll pass it along to our engineering team so this can be looked into further.

  1. Router make and model.
  2. Router firmware.
  3. Full Headset version. (59.0.0.##)
    1. Settings > System > Software Update

---

Here is my video on testing version 60

1,166 REPLIES 1,166

IRefuseToLose
Explorer

this driving me crazy! I purchased Quest 3 especially to play PCVR wireless so i bought 2400mbps router with it and every time i move my head i get stuttering. The only setting that gets rid of stuttering was at 72fps. Even 80Hz creates a significant stuttering.

I tried to play directly through SteamVr software without installing anything from Oculus.

I blamed Steam at first but then i tried to play wireless. 

I installed Oculus software to play by wire and manage to play Half-Life: Alyx at 90fps and dynamic resolution with no lags at all!

I started to blame my router so i bought more expensive model. At my despair, it did not fix anything! Then i kinda pushed to all in, and bought 250$ router because i did not know what else could be a problem. IT STILL JUST THE SAME as with previous two routers! 

I thought that my item was defected but i can finally see that a lot of users have this problem.

My current PCVR experience is a dog**bleep**! I really love My Quest 3 but i can not enjoy what i bought it for. Please fix this issue, i did not want to sit with wire while i bought it to play wirelessly with a good router.

Routers that i tried: TPLink archer ax53, Asus ax57, Asus ax86u. I tried every possible combination of settings ac/ax, 80/160Hz, channel number but it wont matter! It is definitely not a router problem!

I have latest version on my headset and Oculus PC Software.

I am not sure about that either. Maybe the Quest 3s wifi signal strength can be a problem, but it is for sure not the only wifi related problem.

When i got my Quest 3, 10 days ago it lost the Wifi 5 GHZ connection to my Fritzbox 7590 exactly every 10 minutes for about 1-3 seconds and i mean exactly 10 minutes. On the 2.4 GHZ network of the same router but with different SSID it was better but i had still lost connections.

When i created a Guest network SSID exclusively for the Quest 3 and disabled any restrictions for that network, the connection losses were gone and i am constantly connected via 5GHZ so in my case the problem wasn't hardware related. 
Haven't tried Airlink yet, but i am happy i can play on my Quest 3 without constantly getting notified about lost connections.

Gimpen
Explorer

I am having the same problems with Quest 3 128gb and the axe75 router, both bought and used in Europe with a PC using a 4090 and 13900k.

Everything worked perfectly on v62, now the connection speed drops when I move and even worse if I dont look at the router.

I do not know if this is related but also standalone games lag now (tried Vail and Asgards Wrath 2).

I cant use my device and it is getting really frustrating after this much time.

Quest is on v66 and router is on latest firmware.

polozmrd.udatny
Explorer

still broken, any online app is unusable. But it´s okay, I don´t want to have big expectations from a small indie company called meta

brispower
Honored Guest

new quest 3 owner, been wondering if i was alone with my wireless dropouts looks like ive joined a club!

im on an Asus rt-ac68u, submitted my bug report to join the list 🙃

 

Digipro
Protege

 One of the  biggest club of the world though 😉 and it only costs £479.99 for 128gb of prblems or £529.99 for a woping 512gb of problems. cheap as chips. imagen buying a house to find half the rooms are faulty or stinks of rotting flesh cause when they built it 3 months before a rabbit got stuck in the cavity walls and died . least with the cavity wall the builder ripped half the front wall of the house away and left it open for 2 weeks so the smell went away then built it back up for them no cost to the custoomer other than a few weeks without a front wall in their new build 4 bedroom house.   plus compensation as they lived in a house that stunk for several weeks till it was found to be a rabbit between the walls near the font door. this qust 3 situation is becoming to stink just as much though.

Welcome to the club! We have cookies that are months old 🤣

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?