Showing results for 
Search instead for 
Did you mean: 

Known Issue - Cannot pair Replacement Quest Headset with the Oculus App


Hello all,


I recently got a brand new Oculus Quest via RMA, and I'm in the process of updating it. However, I'm having some issues trying to pair the new Headset with the app. I have the Oculus Quest 1 (or the OG quest).


When I try to setup the headset inside the Oculus app, I get through the part asking me to plug in the Quest to power, turn it on, etc. After I put in the pairing code found inside the Quest (sometimes it automatically finds the pairing code, sometimes it doesn't, don't know why), it says "pairing to headset". After a minute or two it spits out an error saying it cannot connect to the headset. I've tried all the following troubleshooting:


  • Factory Resetting the headset (even though it's brand new :/)
  • Uninstalling/Reinstalling the Oculus app
  • Trying the setup on multiple different devices
  • Turning bluetooth & location off and on again, along with checking the app has proper permissions to use them on each of the devices I tried it on
  • Restarting the headset & devices

I don't know what's causing this. Is anyone else having this issue, and if so, is there any potential fixes for it? I already opened a ticket with Oculus Support and all I got as a response is "our developers are aware of the issue are are currently working on it" which could mean a lot or absolutely nothing judging by how you look at it. It looks like a LOT of other people are having this issue, so hopefully they fix whatever's causing it soon.



~ Dom


(EDIT: I posted a fix in the replies which appears to have fixed the issue for most. If it helped you at all, and you'd be so inclined, feel free to use my referral code, as when you (finally) activate your headset, we'll both get $30 of credit to use on whatever you want:


204 REPLIES 204

Honored Guest

So I just wanted to share my experience because in the year of our lord 2023 this is still an issue.  The tldr is that the solution of flashing v31 firmware worked, but to share in my trials and tribulations continue onwards gentle reader.

Last week I pulled out my Quest (v1) for the first time since all the Meta jiggery pokery.  I dutifully converted from an Oculus account (albeit begrudgingly) and updated everything.  However problem!  My Quest was saying no internet connection even though it was connected to the WiFI (I believe this is because WiFi mesh and the Quest are not good friends - I've since set up a separate non mesh AP just for the Quest).  So after mucking around a bit and doing some googling I decided to factory reset the device.  And then my travails really began; I ran into the dreaded pairing issue as described here.


After some more mucking around and trying various restarts with no luck I decided to take the drastic step of contacting support.  They were very helpful, if a little robotic.  We tried a factory reset on the headset itself (previously I had reset it via the app).  We tried uninstalling and reinstalling the app.  We tried a different phone.  We tried resetting the WiFi network.  Nothing worked so the support folks kindly organized an RMA.  My old headset was shipped away, and today the new one arrived.


I eagerly signed for my package, opened it up, and tried to pair the refurbished device.  Uh oh!  The exact same behaviour occurred.  This is when I decided the mesh network might be a problem so I tried non mesh 5GHz wifi.  That didn't work either so I tried non mesh 2.4GHz.  Still no joy.  So looked at the Bluetooth devices in the phone and saw the Oculus so tried to manually pair it there.  It started doing it's thing, and the headset made wake up noises so that gave me hope, obviously it is able to connect.  However a minute or so later I got an error saying incorrect pairing code or PIN.  So I tried again.  With the same issue.  This led me to believe this seemed to be a software error, and googling it luckily brought me to this thread.  After sideloading with v31 (the full version for >v25 for those who got a bit confused like I did) all is well and good with the world.  The device paired to my phone and got all the updates it needs.

My final thoughts: one of two things needs to happen.  One; the firmware needs to get better so this stops being an issue.  It's obviously ubiquitous so should be easy enough to reproduce, so one would hope producing a fix should be relatively easy.

Two; the last usable firmware should be hosted by Meta and this solution should be written in to a KB and added to the script for support staff.  I understand informing customers they need to manually flash an older firmware is probably not desirable but in the absence of solution one this absolutely needs to happen.  Just blindly doing an RMA only for the customer to run into the same issue isn't a great look.

it stops at 47% and the quest restarts and nothing has changed 

Honored Guest

I too had the issue with the pairing code not working on a quest 1. 

After reading and researching for far too long and coming up empty, I finally fixed it. What I did was to download an older version of the oculus app on my android phone (version Once installed, I went through the steps on the app to pair the headset and it went straight through! 

Honored Guest

I'm running into the same issue after a factory reset of the Meta Quest 1. I've tried the following to no avail:

  • Pairing the Meta quest with the Meta Quest App newest version on my Android phone (uninstalled / reinstalled / restarted multiple times)
  • Pairing the Meta quest with the Meta Quest App newest version on my iPhone (uninstalled / reinstalled / restarted multiple times)
  • Pairing the Meta quest with the Meta Quest App (version 214) on my Android phone
  • Pairing with the Meta Quest Developer Hub on my Laptop. Seemed promising, I could configure the WLAN on my Laptop. Then, the Quest started installing Update 1 of 2 and completed the update. But then on the quest it said "Update 1 of 2 done, continue on the Meta App". However, in the Meta Quest Developer Hub the device did not show up as paired and when going through the new device process again, at the WLAN step it said "Error retrieving network state". Tried it with two different networks. The Quest knows there are 2 updates, why it only downloads one of them and then requires to continue on the app I don't understand.
  • Tried sideloading the firmware V30 and V41, apk sideload command stopped at 47%, nothing changed.

I am at my wits end. It feels like I've tried everything but it just wont work. As it stands now, I am sitting on a device that is unusable. I understand that the Quest 1has moved on to legacy support, but if for Meta "legacy support" means you just cant use the device anymore, we might need to rethink on what manufacturer we will go with in the future...

Hey @Ves22. Pairing issues can be the worst and we totally understand how all of this can be frustrating for you. We appreciate you trying all of those troubleshooting steps, and not to worry we are going to help you with getting back into VR.


We would like to discuss what other options we have for you, so can you please send us a PM? To send us a private message please click here. Next, click "Send a Message" to privately message us! Please remember, you must be signed into the community first to send us a private message.

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

this is unbelievable bro, ive tried everything you've tried too and it just wont work. Straight up just bricks sitting in our room 😪 

I absolutly tried everything I think, but I still can't get the quest to pair... Tried an Android phone, Android Tablet and an iPhone.... Also tried the mentoined solution, still unable to pair...
Also tried developer hub, can find the headset, installs update 1 of 2 please continue in the app.... AAArrrgghhhh, the app can't find the headset!?!?!?! What the heck guys.
BT and Wifi are on

I'm am running into the exact same issues..... It is maddening....😡
Got the quest from a friend, who had this new, in a box, never used. He got it paired once to test it, Did a factory reset, and now we can't get it paired to any of my devices etc etc.

Hey there! We hate to hear that you're having issues pairing your headset, we know how that can hinder your gameplay. No worries, let's see what we can do. If you could please PM us directly so we can gather some personal information from you. Please select our name to get to our profile page, or click here. Next, click "Send a Message" to privately message us! Please remember, you must be signed into the community first to send us a private message. We look forward to hearing from you! 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

yo give this a go, it worked for me. if u got an android download meta quest version i thibk one of the updates to the app broke the pairing

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?