Showing results for 
Search instead for 
Did you mean: 

Known Issue - Cannot pair Replacement Quest Headset with the Oculus App

Level 6

Hello all,


I recently got a brand new Oculus Quest via RMA, and I'm in the process of updating it. However, I'm having some issues trying to pair the new Headset with the app. I have the Oculus Quest 1 (or the OG quest).


When I try to setup the headset inside the Oculus app, I get through the part asking me to plug in the Quest to power, turn it on, etc. After I put in the pairing code found inside the Quest (sometimes it automatically finds the pairing code, sometimes it doesn't, don't know why), it says "pairing to headset". After a minute or two it spits out an error saying it cannot connect to the headset. I've tried all the following troubleshooting:


  • Factory Resetting the headset (even though it's brand new :/)
  • Uninstalling/Reinstalling the Oculus app
  • Trying the setup on multiple different devices
  • Turning bluetooth & location off and on again, along with checking the app has proper permissions to use them on each of the devices I tried it on
  • Restarting the headset & devices

I don't know what's causing this. Is anyone else having this issue, and if so, is there any potential fixes for it? I already opened a ticket with Oculus Support and all I got as a response is "our developers are aware of the issue are are currently working on it" which could mean a lot or absolutely nothing judging by how you look at it. It looks like a LOT of other people are having this issue, so hopefully they fix whatever's causing it soon.



~ Dom


(EDIT: I posted a fix in the replies which appears to have fixed the issue for most. If it helped you at all, and you'd be so inclined, feel free to use my referral code, as when you (finally) activate your headset, we'll both get $30 of credit to use on whatever you want:


189 REPLIES 189

Merci pour ta réponse jérome. Es que ca veut dire que nous sommes tous bloqué sur cet écran et que nous ne pouvons pas utiliser le casque ou il y a une solution alternative ?


Yes it seem as many you currently have an unusable headset. Welcome to Meta 😞

Make sure you put in a ticket. 


It doesn't sound great, support told me: "Our engineering team is working around the clock to get this issue resolved and you can reach out to us at any time for an update on this issue. In the meantime, every few days go ahead and try to pair your headset again and see if you have any luck. We can't wait for your device to be working properly again!"

Bonjour Retrogoy, 


Merci tout d'abord de nous faire part de votre situation concernant votre difficulté de pairer votre Meta Quest 2 avec votre téléphone. 


Afin d'être certains qu'il n'y ai pas de confusion, nous allons vous demander de: 


  1. Vérifier que vous essayez de configurer votre appareil avec le même compte que celui auquel vous êtes connecté sur l'application en allant sur
  2. Vous pouvez vous rendre sur sur votre application mobile ou de bureau et vous déconnecter si vous vous trouvez sur le mauvais compte.
  3. Ensuite, vous pouvez soit vous connecter avec le bon compte, soit recommencer avec des informations de connexion différentes en réinitialisant leur casque.


Si la situation persiste malgré cette vérification, nous vous invitons donc à contacter notre assistance technique juste ici: .


Merci pour votre coopération! 


Level 4

My phone: iPhone SE (ios 15.6.1)


What I did?

I unboxed the Quest 2, charged it until the green lights, turned it on, followed the instructions ... did the updates, everything good.


I downloaded the app from the App Store, setup my account but when I reached the "pair" part of the process i got stuck...


And i still stuck... I tried:


- Factory Reset Quest 2

- Reset Network Settings from my phone

- Remove the app and reset the phone many times

- Remove my meta facebook account and created a new one with an email

- Try with different wifi networks

- On / Off Bluetooth many times

- Set on all Location services and stuff related on settings


Did all that in different order, again and again


Still stuck in "pairing your quest 2" ...


I frankly have the desire to smash this thing with a hammer



Same issue here, same phone, can't pair, very frustrating

Can confirm that I had the same issue with a new account and a new quest 2.

Solution was to borrow a friends iphone 11 and pair the device there.

I've got same problem I've been on to surport 4 abt 25hours now and still no luck have u got yours to work yet

Meta Quest Support
Meta Quest Support

Hey hey! Just wanted to update this thread with this solution since it seems we may have forgot to post it in here.


For anyone having this issue, please try the following:


  1. Open the Meta Quest app on your iOS or Android device. Wait about a minute while a background update is automatically applied.
  2. Close the Meta Quest app.
  3. Factory reset your headset.
  4. Try to pair your controllers and headset as new.

Note: Please be sure to check your Mobile app and Headset for the latest versions.


If that doesn't work, we suggest hitting up the team with a support ticket


Thank you! 

On my side same issue with the registration on an Iphone 6S (everything tried), it unlocked when I finalised the pairing on an Android galaxy s6 lite tablet. When I logged on the Android app, the headset was already listed in the devices, I selected the action to finalise the pairing (Don't know the exact name in English) and it paired in 2 seconds. After that the device was fully configured and recognised directly on the Iphone.


In parallel a ticket was opened on Meta support side but I don't know if it has anything to do with the resolution (they were only asking me to resintall the app).

So maybe try the pairing on your actual phone, then when it fails try to finalise the pairing without reseting the headset on another device.