Showing results for 
Search instead for 
Did you mean: 

Known Issue - Cannot pair Replacement Quest Headset with the Oculus App


Hello all,


I recently got a brand new Oculus Quest via RMA, and I'm in the process of updating it. However, I'm having some issues trying to pair the new Headset with the app. I have the Oculus Quest 1 (or the OG quest).


When I try to setup the headset inside the Oculus app, I get through the part asking me to plug in the Quest to power, turn it on, etc. After I put in the pairing code found inside the Quest (sometimes it automatically finds the pairing code, sometimes it doesn't, don't know why), it says "pairing to headset". After a minute or two it spits out an error saying it cannot connect to the headset. I've tried all the following troubleshooting:


  • Factory Resetting the headset (even though it's brand new :/)
  • Uninstalling/Reinstalling the Oculus app
  • Trying the setup on multiple different devices
  • Turning bluetooth & location off and on again, along with checking the app has proper permissions to use them on each of the devices I tried it on
  • Restarting the headset & devices

I don't know what's causing this. Is anyone else having this issue, and if so, is there any potential fixes for it? I already opened a ticket with Oculus Support and all I got as a response is "our developers are aware of the issue are are currently working on it" which could mean a lot or absolutely nothing judging by how you look at it. It looks like a LOT of other people are having this issue, so hopefully they fix whatever's causing it soon.



~ Dom


(EDIT: I posted a fix in the replies which appears to have fixed the issue for most. If it helped you at all, and you'd be so inclined, feel free to use my referral code, as when you (finally) activate your headset, we'll both get $30 of credit to use on whatever you want:


204 REPLIES 204


Same issue here. I just returned the Oculus to the store. I’m not keeping a $400 paper weight while they try to resolve this!! Shame on Meta for selling these!


I got the same issue but where I from I can't even return it cause don't have Meta Store so I have to wait and wait a beautiful explanation and excuses to use it….. lucky to you guys, bad for me cause i buy it in the USA and bring it to Argentina 🤷🏻‍:male_sign:🤦🏻

I just tried signing in into instagram but it doesn’t let me now because it says my headset is linked to another account. 

A guy said he has been waiting 3 weeks and the issue hasn’t been fixed. I’ve tried soft-reset , Hard Reset - factory reset - powering both devices off and unlinking my bluetooth decides - uninstalling and installing the app again and nothing work. Do you know when this will be solved?


This is, in fact, pretty wack.

Honored Guest

I recently factory reset my Meta Quest 2 due to a login issue in the Meta account migration. When in the introduction screen on my Quest 2, it shows a code to enter into the Meta Quest app on my phone. I have typed it in multiple times and it shows the prompt "Unable to Connect to Your Headset." I have my Bluetooth on constantly and have factory reset my Quest 2 multiple times at this point. I have been waiting for Meta to fix their migration error for two weeks now and without it fixed, my headset is essentially locked and cannot be used.


Please provide any fixes you may have and Meta please fix this issue!

They said they would fix this. There is no way to fix this I don’t know how other people got to work theirs. I just hope they really fix it soon. A guy has been waiting for over 3 weeks

In my case, it has been more than 3 weeks since I started the claim, they contacted me from META SUPPORT and confirmed that it was their problem that "the engineers are trying to solve" but I am still waiting for a solution, I am quite disappointed, especially with my Oculus that is new and at first it worked correctly and then the controls started with synchronization problems, and the following week this pairing problem. Unfortunate because I have friends with Oculus 2 (not the latest version they released) and it works without problems

Struggling with this is well. My 10 year old doesn't understand why the one we bought doesn't work at all (stuck on pairing code screen) but his friends have a slightly older Quest 2 that work fine. Such bull**bleep** that Meta can't figure this out. Also I'm very disappointed in having to use my Facebook account for my kid's Oculus. This is not a kid and parent friendly solution at all. We returned our Quest 2 yesterday and I'm not sure we'll buy another because of the FB account requirement, even if they get the pairing issue fixed. 

Not applicable

Having same issue, they had an update for phone app, updated it, but still having same issue. **bleep** began with having to get meta app.